{"thread":{"id":"30694","subject":"[ANNOUNCE] Git 1.7.11.rc1","startedAt":"2012-06-03T23:46:13Z","lastAt":"2012-06-04T14:19:26Z","messageCount":2,"participants":["Junio C Hamano","Marc Branchaud"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"192783","messageId":"7v1ulwvsz1.fsf@alter.siamese.dyndns.org","threadId":"30694","inReplyTo":null,"subject":"[ANNOUNCE] Git 1.7.11.rc1","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-06-03T23:46:13Z","receivedAt":"2012-06-03T23:46:13Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"A release candidate Git v1.7.11-rc1 is now available for testing at\nthe usual places.\n\nThe release tarballs are found at:\n\n    http://code.google.com/p/git-core/downloads/list\n\nand their SHA-1 checksums are:\n\nc5805f67a1c21922f5fe7456dae9fb9b8c4b9a16  git-1.7.11.rc1.tar.gz\n379bc711136df07ae64da4f14a90a3837f3e248c  git-htmldocs-1.7.11.rc1.tar.gz\n5ba3bc8dd9fcf775a2364a5b73bb84600cc903af  git-manpages-1.7.11.rc1.tar.gz\n\nAlso the following public repositories all have a copy of the v1.7.11-rc1\ntag and the master branch that the tag points at:\n\n  url = git://repo.or.cz/alt-git.git\n  url = https://code.google.com/p/git-core/\n  url = git://git.sourceforge.jp/gitroot/git-core/git.git\n  url = git://git-core.git.sourceforge.net/gitroot/git-core/git-core\n  url = https://github.com/gitster/git\n\nGit v1.7.11 Release Notes (draft)\n=========================\n\nUpdates since v1.7.10\n---------------------\n\nUI, Workflows & Features\n\n * A new mode for push, \"simple\", which is a cross between \"current\"\n   and \"upstream\", has been introduced. \"git push\" without any refspec\n   will push the current branch out to the same name at the remote\n   repository only when it is set to track the branch with the same\n   name over there.  The plan is to make this mode the new default\n   value when push.default is not configured.\n\n * A couple of commands learned the \"--column\" option to produce\n   columnar output.\n\n * A third-party tool \"git subtree\" is distributed in contrib/\n\n * Error messages given when @{u} is used for a branch without its\n   upstream configured have been clatified.\n\n * Even with \"-q\"uiet option, \"checkout\" used to report setting up\n   tracking.  Also \"branch\" learned the \"-q\"uiet option to squelch\n   informational message.\n\n * Your build platform may support hardlinks but you may prefer not to\n   use them, e.g. when installing to DESTDIR to make a tarball and\n   untarring on a filesystem that has poor support for hardlinks.\n   There is a Makefile option NO_INSTALL_HARDLINKS for you.\n\n * The smart-http backend used to always override GIT_COMMITTER_*\n   variables with REMOTE_USER and REMOTE_ADDR, but these variables are\n   now preserved when set.\n\n * \"git am\" learned the \"--include\" option, which is an opposite of\n   existing the \"--exclude\" option.\n\n * When \"git am -3\" needs to fall back to an application to a\n   synthesized preimage followed by a 3-way merge, the paths that\n   needed such treatment are now reported to the end user, so that the\n   result in them can be eyeballed with extra care.\n\n * The output from \"diff/log --stat\" used to always allocate 4 columns\n   to show the number of modified lines, but not anymore.\n\n * \"git difftool\" learned the \"--dir-diff\" option to spawn external\n   diff tools that can compare two directory hierarchies at a time\n   after populating two temporary directories, instead of running an\n   instance of the external tool once per a file pair.\n\n * The \"fmt-merge-msg\" command learns to list the primary contributors\n   involved in the side topic you are merging.\n\n * \"git rebase\" learned to optionally keep commits that do not\n   introduce any change in the original history.\n\n * \"git push --recurse-submodules\" learned to optionally look into the\n   histories of submodules bound to the superproject and push them\n   out.\n\n * A 'snapshot' request to \"gitweb\" honors If-Modified-Since: header,\n   based on the commit date.\n\n * \"gitweb\" learned to highlight the patch it outputs even more.\n\nForeign Interface\n\n * \"git svn\" used to die with unwanted SIGPIPE when talking with HTTP\n   server that uses keep-alive.\n\n * \"git svn\" learned to use platform specific authentication\n   providers, e.g. gnome-keyring, kwallet, etc.\n\n * \"git p4\" has been moved out of contrib/ area and has seen more work\n   on importing labels as tags from (and exporting tags as labels to)\n   p4.\n\nPerformance and Internal Implementation (please report possible regressions)\n\n * Bash completion script (in contrib/) have been cleaned up to make\n   future work on it simpler.\n\n * An experimental \"version 4\" format of the index file has been\n   introduced to reduce on-disk footprint and I/O overhead.\n\n * \"git archive\" learned to produce its output without reading the\n   blob object it writes out in memory in its entirety.\n\n * \"git index-pack\" that runs when fetching or pushing objects to\n   complete the packfile on the receiving end learned to use multiple\n   threads to do its job when available.\n\n * The code to compute hash values for lines used by the internal diff\n   engine was optimized on little-endian machines, using the same\n   trick the kernel folks came up with.\n\n * \"git apply\" had some memory leaks plugged.\n\n * Setting up a revision traversal with many starting points was\n   inefficient as these were placed in a date-order priority queue\n   one-by-one.  Now they are collected in the queue unordered first,\n   and sorted immediately before getting used.\n\n * More lower-level commands learned to use the streaming API to read\n   from the object store without keeping everything in core.\n\n * The weighting parameters to suggestion command name typo have been\n   tweaked, so that \"git tags\" will suggest \"tag?\" and not \"stage?\".\n\n * Because \"sh\" on the user's PATH may be utterly broken on some\n   systems, run-command API now uses SHELL_PATH, not /bin/sh, when\n   spawning an external command (not applicable to Windows port).\n\n * The API to iterate over refs/ hierarchy has been tweaked to allow\n   walking only a subset of it more efficiently.\n\nAlso contains minor documentation updates and code clean-ups.\n\n\nFixes since v1.7.10\n-------------------\n\nUnless otherwise noted, all the fixes since v1.7.10 in the maintenance\nreleases are contained in this release (see release notes to them for\ndetails).\n\n * \"git rebase -p\" used to pay attention to rebase.autosquash which\n    was wrong.  \"git rebase -p -i\" should, but \"git rebase -p\" by\n    itself should not.\n   (cherry-pick 8a6dae1 vr/rebase-autosquash-does-not-imply-i later to maint).\n\n * \"git submodule init\" used to report \"registered for path ...\"\n   even for submodules that were registered earlier.\n   (cherry-pick c1c259e jl/submodule-report-new-path-once later to maint).\n\n * \"git diff --stat\" used to fully count a binary file with modified\n   execution bits whose contents is unmodified, which was not quite\n   right.\n\n----------------------------------------------------------------\n\nChanges since v1.7.11-rc0 are as follows:\n\nErik Faye-Lund (2):\n      rebase: report invalid commit correctly\n      Makefile: add missing GIT-VERSION-FILE dependency\n\nJeff King (30):\n      ident: split setup_ident into separate functions\n      http-push: do not access git_default_email directly\n      fmt-merge-msg: don't use static buffer in record_person\n      move identity config parsing to ident.c\n      move git_default_* variables to ident.c\n      ident: trim trailing newline from /etc/mailname\n      format-patch: use default email for generating message ids\n      fmt_ident: drop IDENT_WARN_ON_NO_NAME code\n      ident: don't write fallback username into git_default_name\n      drop length limitations on gecos-derived names and emails\n      ident: report passwd errors with a more friendly message\n      ident: use full dns names to generate email addresses\n      ident: use a dynamic strbuf in fmt_ident\n      ident: trim whitespace from default name/email\n      format-patch: refactor get_patch_filename\n      fetch-pack: sort incoming heads\n      fetch-pack: avoid quadratic behavior in remove_duplicates\n      add sorting infrastructure for list refs\n      fetch-pack: sort the list of incoming refs\n      fetch-pack: avoid quadratic loop in filter_refs\n      fetch-pack: sort incoming heads list earlier\n      ident: reword empty ident error message\n      ident: refactor NO_DATE flag in fmt_ident\n      ident: let callers omit name with fmt_indent\n      format-patch: use GIT_COMMITTER_EMAIL in message ids\n      ident: rename IDENT_ERROR_ON_NO_NAME to IDENT_STRICT\n      ident: reject bogus email addresses with IDENT_STRICT\n      format-patch: do not use bogus email addresses in message ids\n      t5701: modernize style\n      INSTALL: update asciidoc recommendation\n\nJens Lehmann (1):\n      submodules: print \"registered for path\" message only once\n\nJiang Xin (5):\n      l10n: Update git.pot (41 new messages)\n      l10n: zh.CN.po: update by msgmerge git.pot\n      l10n: zh_CN.po: translate 323 new messages\n      l10n: Set nplurals of zh_CN.po from 1 to 2\n      i18n: apply: split to fix a partial i18n message\n\nJonathan Nieder (3):\n      git-svn: move Git::SVN::Prompt into its own file\n      git-svn: rename SVN::Git::* packages to Git::SVN::*\n      git-svn: make Git::SVN::Fetcher a separate file\n\nJunio C Hamano (6):\n      refs: do not create ref_entry when searching\n      cherry-pick: regression fix for empty commits\n      Start preparing for 1.7.10.4\n      Update draft release notes to 1.7.11\n      Git 1.7.10.4\n      Git 1.7.11-rc1\n\nMarco Paolone (1):\n      l10n: New it.po file with 504 translations\n\nMatthieu Moy (1):\n      Reduce cost of deletion in levenstein distance (4 -> 3)\n\nMichael Haggerty (5):\n      free_ref_entry(): do not trigger reading of loose refs\n      cmd_fetch_pack(): declare dest to be const\n      cmd_fetch_pack(): handle non-option arguments outside of the loop\n      cmd_fetch_pack(): combine the loop termination conditions\n      cmd_fetch_pack(): respect constness of argv parameter\n\nNguyễn Thái Ngọc Duy (2):\n      pack-objects, streaming: turn \"xx >= big_file_threshold\" to \".. > ..\"\n      pack-objects: refactor write_object() into helper functions\n\nPeter Krefting (1):\n      Update Swedish translation (728t0f0u)\n\nRené Scharfe (3):\n      refs: convert parameter of search_ref_dir() to length-limited string\n      refs: convert parameter of create_dir_entry() to length-limited string\n      refs: use strings directly in find_containing_dir()\n\nTran Ngoc Quan (2):\n      Init translation for Vietnamese\n      First release translation for Vietnamese\n\nVincent van Ravesteijn (1):\n      Do not autosquash in case of an implied interactive rebase\n\nVitor Antunes (3):\n      git-p4: Test changelists touching two branches\n      git-p4: Verify detection of \"empty\" branch creation\n      git-p4: Clean up branch test cases\n"},{"id":"192805","messageId":"4FCCC3EE.1090009@xiplink.com","threadId":"30694","inReplyTo":"7v1ulwvsz1.fsf@alter.siamese.dyndns.org","subject":"Re: [ANNOUNCE] Git 1.7.11.rc1","fromName":"Marc Branchaud","fromEmail":"marcnarc@xiplink.com","sentAt":"2012-06-04T14:19:26Z","receivedAt":"2012-06-04T14:19:26Z","isPatch":false,"sender":{"key":"marcnarc@xiplink.com","avatar":"https://avatars.githubusercontent.com/u/14980203?v=4"},"body":"On 12-06-03 07:46 PM, Junio C Hamano wrote:\n> A release candidate Git v1.7.11-rc1 is now available for testing at\n> the usual places.\n\nI have a few release note tweaks, below.\n\n> The release tarballs are found at:\n> \n>     http://code.google.com/p/git-core/downloads/list\n> \n> and their SHA-1 checksums are:\n> \n> c5805f67a1c21922f5fe7456dae9fb9b8c4b9a16  git-1.7.11.rc1.tar.gz\n> 379bc711136df07ae64da4f14a90a3837f3e248c  git-htmldocs-1.7.11.rc1.tar.gz\n> 5ba3bc8dd9fcf775a2364a5b73bb84600cc903af  git-manpages-1.7.11.rc1.tar.gz\n> \n> Also the following public repositories all have a copy of the v1.7.11-rc1\n> tag and the master branch that the tag points at:\n> \n>   url = git://repo.or.cz/alt-git.git\n>   url = https://code.google.com/p/git-core/\n>   url = git://git.sourceforge.jp/gitroot/git-core/git.git\n>   url = git://git-core.git.sourceforge.net/gitroot/git-core/git-core\n>   url = https://github.com/gitster/git\n> \n> Git v1.7.11 Release Notes (draft)\n> =========================\n> \n> Updates since v1.7.10\n> ---------------------\n> \n> UI, Workflows & Features\n> \n>  * A new mode for push, \"simple\", which is a cross between \"current\"\n>    and \"upstream\", has been introduced. \"git push\" without any refspec\n>    will push the current branch out to the same name at the remote\n>    repository only when it is set to track the branch with the same\n>    name over there.  The plan is to make this mode the new default\n>    value when push.default is not configured.\n> \n>  * A couple of commands learned the \"--column\" option to produce\n>    columnar output.\n\nIt would be nice to list the commands.  I found \"tag\" \"status\" and \"branch\"\nfrom the nd/columns branch.  Any others?\n\n>  * A third-party tool \"git subtree\" is distributed in contrib/\n> \n>  * Error messages given when @{u} is used for a branch without its\n>    upstream configured have been clatified.\n\ns/clatified/clarified/\n\n>  * Even with \"-q\"uiet option, \"checkout\" used to report setting up\n\ns/with/with the/\n\n>    tracking.  Also \"branch\" learned the \"-q\"uiet option to squelch\n>    informational message.\n> \n>  * Your build platform may support hardlinks but you may prefer not to\n>    use them, e.g. when installing to DESTDIR to make a tarball and\n>    untarring on a filesystem that has poor support for hardlinks.\n>    There is a Makefile option NO_INSTALL_HARDLINKS for you.\n> \n>  * The smart-http backend used to always override GIT_COMMITTER_*\n>    variables with REMOTE_USER and REMOTE_ADDR, but these variables are\n>    now preserved when set.\n> \n>  * \"git am\" learned the \"--include\" option, which is an opposite of\n>    existing the \"--exclude\" option.\n> \n>  * When \"git am -3\" needs to fall back to an application to a\n\ns/application to/application of/\n\n>    synthesized preimage followed by a 3-way merge, the paths that\n>    needed such treatment are now reported to the end user, so that the\n>    result in them can be eyeballed with extra care.\n> \n>  * The output from \"diff/log --stat\" used to always allocate 4 columns\n>    to show the number of modified lines, but not anymore.\n> \n>  * \"git difftool\" learned the \"--dir-diff\" option to spawn external\n>    diff tools that can compare two directory hierarchies at a time\n>    after populating two temporary directories, instead of running an\n>    instance of the external tool once per a file pair.\n> \n>  * The \"fmt-merge-msg\" command learns to list the primary contributors\n\ns/learns/learned/\n\n>    involved in the side topic you are merging.\n> \n>  * \"git rebase\" learned to optionally keep commits that do not\n>    introduce any change in the original history.\n> \n>  * \"git push --recurse-submodules\" learned to optionally look into the\n>    histories of submodules bound to the superproject and push them\n>    out.\n> \n>  * A 'snapshot' request to \"gitweb\" honors If-Modified-Since: header,\n>    based on the commit date.\n> \n>  * \"gitweb\" learned to highlight the patch it outputs even more.\n> \n> Foreign Interface\n> \n>  * \"git svn\" used to die with unwanted SIGPIPE when talking with HTTP\n\ns/HTTP/an HTTP/\n\n>    server that uses keep-alive.\n> \n>  * \"git svn\" learned to use platform specific authentication\n>    providers, e.g. gnome-keyring, kwallet, etc.\n> \n>  * \"git p4\" has been moved out of contrib/ area and has seen more work\n\ns/out of/out of the/\n\n>    on importing labels as tags from (and exporting tags as labels to)\n>    p4.\n> \n> Performance and Internal Implementation (please report possible regressions)\n> \n>  * Bash completion script (in contrib/) have been cleaned up to make\n>    future work on it simpler.\n> \n>  * An experimental \"version 4\" format of the index file has been\n>    introduced to reduce on-disk footprint and I/O overhead.\n> \n>  * \"git archive\" learned to produce its output without reading the\n>    blob object it writes out in memory in its entirety.\n> \n>  * \"git index-pack\" that runs when fetching or pushing objects to\n>    complete the packfile on the receiving end learned to use multiple\n>    threads to do its job when available.\n> \n>  * The code to compute hash values for lines used by the internal diff\n>    engine was optimized on little-endian machines, using the same\n>    trick the kernel folks came up with.\n> \n>  * \"git apply\" had some memory leaks plugged.\n> \n>  * Setting up a revision traversal with many starting points was\n>    inefficient as these were placed in a date-order priority queue\n>    one-by-one.  Now they are collected in the queue unordered first,\n>    and sorted immediately before getting used.\n> \n>  * More lower-level commands learned to use the streaming API to read\n>    from the object store without keeping everything in core.\n> \n>  * The weighting parameters to suggestion command name typo have been\n>    tweaked, so that \"git tags\" will suggest \"tag?\" and not \"stage?\".\n> \n>  * Because \"sh\" on the user's PATH may be utterly broken on some\n>    systems, run-command API now uses SHELL_PATH, not /bin/sh, when\n>    spawning an external command (not applicable to Windows port).\n> \n>  * The API to iterate over refs/ hierarchy has been tweaked to allow\n\ns/over/over the/\n\n\nThat's all!\n\n\t\tM.\n"}]}