{"thread":{"id":"30506","subject":"[PATCH 0/3] Reduced re-roll of http-proxy-more branch","startedAt":"2012-05-11T13:13:25Z","lastAt":"2012-05-11T17:00:13Z","messageCount":2,"participants":["Nelson Benitez Leon","Jeff King"],"isPatch":true,"patchVersion":1,"patchTotal":3},"messages":[{"id":"191389","messageId":"4FAD1075.8020309@seap.minhap.es","threadId":"30506","inReplyTo":null,"subject":"[PATCH 0/3] Reduced re-roll of http-proxy-more branch","fromName":"Nelson Benitez Leon","fromEmail":"nelsonjesus.benitez@seap.minhap.es","sentAt":"2012-05-11T13:13:25Z","receivedAt":"2012-05-11T13:13:25Z","isPatch":true,"sender":{"key":"nelsonjesus.benitez@seap.minhap.es","avatar":null},"body":"Hi, based on last feedback by Junio and Jeff I've created this\nreduced version of http-proxy-more branch with all the bits\nabout \"reading proxy from environment\" removed. When cURL adds\nthe new api we will only need to expand the code introduced by\ncommit 1/3 .\n\nRegards,\n\nNelson Benitez Leon (3):\n  http: handle proxy authentication failure (error 407)\n  http: Avoid limit of retrying request only twice\n  http: rename HTTP_REAUTH to HTTP_AUTH_RETRY\n\n http.c |   37 ++++++++++++++++++++++++++++++++-----\n http.h |    2 +-\n 2 files changed, 33 insertions(+), 6 deletions(-)\n\n-- \n1.7.7.6\n"},{"id":"191400","messageId":"20120511170013.GA26916@sigill.intra.peff.net","threadId":"30506","inReplyTo":"4FAD1075.8020309@seap.minhap.es","subject":"Re: [PATCH 0/3] Reduced re-roll of http-proxy-more branch","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2012-05-11T17:00:13Z","receivedAt":"2012-05-11T17:00:13Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Fri, May 11, 2012 at 03:13:25PM +0200, Nelson Benitez Leon wrote:\n\n> Hi, based on last feedback by Junio and Jeff I've created this\n> reduced version of http-proxy-more branch with all the bits\n> about \"reading proxy from environment\" removed. When cURL adds\n> the new api we will only need to expand the code introduced by\n> commit 1/3 .\n\nThanks. I know it is frustrating to work on a series only to end up\ndiscarding a big chunk of it. But I think the result here makes a lot\nmore sense in the long run.\n\nPatches 2 and 3 look OK, but I have a few comments on the first one\n(I'll reply separately).\n\n-Peff\n"}]}