{"thread":{"id":"30411","subject":"[PATCH 6/6] http: rename HTTP_REAUTH to HTTP_AUTH_RETRY","startedAt":"2012-05-03T16:40:40Z","lastAt":"2012-05-04T07:25:56Z","messageCount":2,"participants":["Nelson Benitez Leon","Jeff King"],"isPatch":true,"patchVersion":1,"patchTotal":6},"messages":[{"id":"190649","messageId":"4FA2B508.8000702@seap.minhap.es","threadId":"30411","inReplyTo":null,"subject":"[PATCH 6/6] http: rename HTTP_REAUTH to HTTP_AUTH_RETRY","fromName":"Nelson Benitez Leon","fromEmail":"nelsonjesus.benitez@seap.minhap.es","sentAt":"2012-05-03T16:40:40Z","receivedAt":"2012-05-03T16:40:40Z","isPatch":true,"sender":{"key":"nelsonjesus.benitez@seap.minhap.es","avatar":null},"body":"After adding the proxy authentication support in http, the semantics\nof HTTP_REAUTH changed more to a retry rather than a re-authentication,\nso we rename it to HTTP_AUTH_RETRY.\n\nSigned-off-by: Nelson Benitez Leon <nbenitezl@gmail.com>\nSigned-off-by: Junio C Hamano <gitster@pobox.com>\n---\n http.c |    6 +++---\n http.h |    2 +-\n 2 files changed, 4 insertions(+), 4 deletions(-)\n\ndiff --git a/http.c b/http.c\nindex 1468ec7..ba07e12 100644\n--- a/http.c\n+++ b/http.c\n@@ -877,7 +877,7 @@ static int http_request(const char *url, void *result, int target, int options)\n \t\t\t} else {\n \t\t\t\tcredential_fill(&http_auth);\n \t\t\t\tinit_curl_http_auth(slot->curl);\n-\t\t\t\tret = HTTP_REAUTH;\n+\t\t\t\tret = HTTP_AUTH_RETRY;\n \t\t\t}\n \t\t} else if (results.http_code == 407) { /* Proxy authentication failure */\n \t\t\tif (proxy_auth.username && proxy_auth.password) {\n@@ -886,7 +886,7 @@ static int http_request(const char *url, void *result, int target, int options)\n \t\t\t} else {\n \t\t\t\tcredential_fill(&proxy_auth);\n \t\t\t\tset_proxy_auth(slot->curl);\n-\t\t\t\tret = HTTP_REAUTH;\n+\t\t\t\tret = HTTP_AUTH_RETRY;\n \t\t\t}\n \t\t} else {\n \t\t\tif (!curl_errorstr[0])\n@@ -916,7 +916,7 @@ static int http_request_reauth(const char *url, void *result, int target,\n \n \tdo {\n \t\tret = http_request(url, result, target, options);\n-\t} while (ret == HTTP_REAUTH);\n+\t} while (ret == HTTP_AUTH_RETRY);\n \n \treturn ret;\n }\ndiff --git a/http.h b/http.h\nindex 483e3ed..4bfa267 100644\n--- a/http.h\n+++ b/http.h\n@@ -123,7 +123,7 @@ extern char *get_remote_object_url(const char *url, const char *hex,\n #define HTTP_MISSING_TARGET\t1\n #define HTTP_ERROR\t\t2\n #define HTTP_START_FAILED\t3\n-#define HTTP_REAUTH\t4\n+#define HTTP_AUTH_RETRY\t4\n #define HTTP_NOAUTH\t5\n \n /*\n-- \n1.7.7.6\n"},{"id":"190732","messageId":"20120504072556.GF21895@sigill.intra.peff.net","threadId":"30411","inReplyTo":"4FA2B508.8000702@seap.minhap.es","subject":"Re: [PATCH 6/6] http: rename HTTP_REAUTH to HTTP_AUTH_RETRY","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2012-05-04T07:25:56Z","receivedAt":"2012-05-04T07:25:56Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Thu, May 03, 2012 at 06:40:40PM +0200, Nelson Benitez Leon wrote:\n\n> After adding the proxy authentication support in http, the semantics\n> of HTTP_REAUTH changed more to a retry rather than a re-authentication,\n> so we rename it to HTTP_AUTH_RETRY.\n\nThe patch looks fine, but a minor nit on the rationale. It has nothing\nto do with the proxy auth. It has always been a bad name. It is not \"you\nshould re-authenticate\", but rather \"I have already re-authenticated,\nand therefore you should call me again to retry\".\n\n-Peff\n"}]}