{"thread":{"id":"30290","subject":"Incremental updates to \"What's cooking\"","startedAt":"2012-04-20T05:52:31Z","lastAt":"2012-04-20T05:52:31Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"189739","messageId":"7vzka7osps.fsf@pobox.com","threadId":"30290","inReplyTo":null,"subject":"Incremental updates to \"What's cooking\"","fromName":"Junio C Hamano","fromEmail":"junio@pobox.com","sentAt":"2012-04-20T05:52:31Z","receivedAt":"2012-04-20T05:52:31Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"I was planning to have a handful of topics graduate to 'master'\ntoday but there was a bit of accident, and I felt it would be safer\nto postpone it for a few days.  Also I expect to be slower than\nusual for several days.\n\nHere is an incremental updates to \"What's cooking\", relative to the\nissue #07 that was posted yesterday.\n\n[New Topics]\n\n* bw/test-fix-grep-gnuism (2012-04-19) 1 commit\n - t9400: fix gnuism in grep\n\nFix two places that were the only place in the test suite that gave \"a\\+\"\nto platform grep and expected it to mean one or more \"a\", which is a\nblatant GNUism.\n\nWill merge to 'next'.\n\n* rt/cherry-revert-conflict-summary (2012-04-19) 1 commit\n - sequencer: remove additional blank line\n\nIn the older days, the header \"Conflicts:\" in \"cherry-pick\" and\n\"merge\" was separated by a blank line from the list of paths that\nfollow for readability, but when \"merge\" was rewritten in C, we lost\nit by mistake. Remove the newline from \"cherry-pick\" to make them\nmatch again.\n\n--------------------------------------------------\nMoved from [New Topics] to [Cooking]\n\n* js/spawn-via-shell-path-fix (2012-04-17) 1 commit\n  (merged to 'next' on 2012-04-19 at 3e04ef6)\n + Do not use SHELL_PATH from build system in prepare_shell_cmd on Windows\n\nMerged to 'next' to fast-track the fix for Windows.\n\n* jc/merge-reduce-parents-early (2012-04-18) 5 commits\n - fmt-merge-msg: discard needless merge parents\n - builtin/merge.c: reduce parents early\n - builtin/merge.c: collect other parents early\n - builtin/merge.c: remove \"remoteheads\" global variable\n - merge tests: octopus with redundant parents\n (this branch is tangled with lt/octopus-simplify.)\n\nI based this and Linus's on top of the same test script, but it\nturns out that this is more correct way to deal with the issue, so\nI'll drop the other one.\n\n[Cooking]\n\n* cb/daemon-test-race-fix (2012-04-19) 1 commit\n - git-daemon wrapper to wait until daemon is ready\n\nFix race condition between starting and waiting for git-daemon in the\ntest.\n\nRe-queued with a fix.\n\n* nl/http-proxy-more (2012-04-19) 7 commits\n - http: fix proxy password passing\n - http: fix proxy authentication\n - http: rename HTTP_REAUTH to HTTP_AUTH_RETRY\n - http: Avoid limit of retrying request only twice\n - http: handle proxy authentication failure (error 407)\n - http: handle proxy proactive authentication\n - http: try http_proxy env var when http.proxy config option is not set\n \nAnother microfix.  It is starting to look like this may have to be\nmoved to Stalled.\n\n* nh/empty-rebase (2012-04-19) 5 commits\n - fixup! git-rebase: add keep_empty flag\n - git-rebase: add keep_empty flag\n - git-cherry-pick: add test to validate new options\n - git-cherry-pick: add \"--keep-redundant-commits\" option\n - git-cherry-pick: add allow-empty option\n\nAdded a fix-up.\n\n* nd/threaded-index-pack (2012-04-19) 4 commits\n - index-pack: disable threading if NO_PREAD is defined\n - index-pack: support multithreaded delta resolving\n - index-pack: split second pass obj handling into own function\n - compat/win32/pthread.h: Add an pthread_key_delete() implementation\n\nAdded a fix-up.\n\n * jc/index-v4 (2012-04-04) 10 commits\n+  (merged to 'next' on 2012-04-19 at 5e4b029)\n+ + update-index: upgrade/downgrade on-disk index version\n+ + read-cache.c: write prefix-compressed names in the index\n+ + read-cache.c: read prefix-compressed names in index on-disk version v4\n+ + read-cache.c: move code to copy incore to ondisk cache to a helper function\n+ + read-cache.c: move code to copy ondisk to incore cache to a helper function\n+ + read-cache.c: report the header version we do not understand\n+ + read-cache.c: make create_from_disk() report number of bytes it consumed\n+ + read-cache.c: allow unaligned mapping of the index file\n+ + cache.h: hide on-disk index details\n+ + varint: make it available outside the context of pack\n  (this branch is tangled with jc/split-blob.)\n \nTrivially shrinks the on-disk size of the index file to save both I/O and\nchecksum overhead.  The \"v4\" format represented here may not be what we\neventually want to have, but the preparatory refactoring steps and the way\nhow backward compatibility is retained should give plenty to learn to GSoC\nstudent-hopefuls.\n \nThe bottom one makes use of \"varint\" encoding from the stalled\njc/split-blob topic.  Merged to 'next' as warned.\n"}]}