{"thread":{"id":"29953","subject":"What's cooking in git.git (Mar 2012, #06; Wed, 14)","startedAt":"2012-03-14T23:19:42Z","lastAt":"2012-03-14T23:19:42Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"187000","messageId":"7vwr6mn52p.fsf@alter.siamese.dyndns.org","threadId":"29953","inReplyTo":null,"subject":"What's cooking in git.git (Mar 2012, #06; Wed, 14)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-03-14T23:19:42Z","receivedAt":"2012-03-14T23:19:42Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"What's cooking in git.git (Mar 2012, #06; Wed, 14)\n--------------------------------------------------\n\nHere are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'.\n\nAs of tonight, the tip of master is 1.7.10-rc1 and I'll start ignoring new\nfeature patches out of blue and low impact fix patches that are not very\nwell cooked, expecting for them to be rerolled after 1.7.10 final.\n\nYou can find the changes described here in the integration branches of the\nrepositories listed at\n\n    http://git-blame.blogspot.com/p/git-public-repositories.html\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* az/verify-tag-use-gpg-config (2012-03-08) 1 commit\n  (merged to 'next' on 2012-03-09 at d9e556f)\n + verify-tag: Parse GPG configuration options.\n\n\"git tag -s\" honored \"gpg.program\" configuration variable since\n1.7.9, but \"git tag -v\" and \"git verify-tag\" didn't.\n\nThis is a fairly low impact fix.\n\n* jc/i18n-shell-script-gettext (2012-03-12) 1 commit\n  (merged to 'next' on 2012-03-12 at 1326b5e)\n + i18n: fix auto detection of gettext scheme for shell scripts\n\nThe auto detection was testing if a fixed string that is known to be\nnon-empty is empty by mistake.\n\n* jc/maint-undefined-i18n-observation-test (2012-03-09) 1 commit\n  (merged to 'next' on 2012-03-12 at 42aaabe)\n + t0204: clarify the \"observe undefined behaviour\" test\n\nIt was unclear what a test in t0204 wanted to check; it turns out\nthat it was only to observe an undefined behaviour of the system,\nand did not anticipate one kind of reasonable error behaviour.\n\nReplaces the tb/maint-remove-irrelevant-i18n-test topic.\n\n* ms/maint-config-error-at-eol-linecount (2012-03-12) 1 commit\n  (merged to 'next' on 2012-03-12 at ba17441)\n + config: report errors at the EOL with correct line number\n\nWhen \"git config\" diagnoses an error in a configuration file and\nshows the line number for the offending line, it miscounted if the\nerror was at the end of line.\n\n* ph/rerere-doc (2012-03-08) 1 commit\n  (merged to 'next' on 2012-03-12 at 2456f65)\n + rerere: Document 'rerere remaining'\n\n--------------------------------------------------\n[New Topics]\n\n* jh/notes-merge-in-git-dir-worktree (2012-03-12) 2 commits\n - notes-merge: use opendir/readdir instead of using read_directory()\n - t3310: illustrate failure to \"notes merge --commit\" inside $GIT_DIR/\n\nRunning \"notes merge --commit\" failed to perform correctly when run\nfrom any directory inside $GIT_DIR/.  When \"notes merge\" stops with\nconflicts, $GIT_DIR/NOTES_MERGE_WORKTREE is the place a user edits\nto resolve it.\n\nNot urgent.\n\n* jn/diffstat-tests (2012-03-13) 7 commits\n - diffstat summary line varies by locale: miscellany\n - test: use numstat instead of diffstat in binary-diff test\n - test: use --numstat instead of --stat in \"git stash show\" tests\n - test: test cherry-pick functionality and output separately\n - test: modernize funny-names test style\n - test: use numstat instead of diffstat in funny-names test\n - test: use test_i18ncmp when checking --stat output\n\nSome tests checked the \"diff --stat\" output when they do not have to,\nwhich unnecessarily made things harder to verify under GETTEXT_POISON.\nNot urgent.\n\n* th/doc-diff-submodule-option (2012-03-14) 1 commit\n  (merged to 'next' on 2012-03-14 at 0e1d755)\n + Documentation/diff-options: reword description of --submodule option\n\nUpdate \"diff --submodule\" documentation.\nMay want to ship with 1.7.10.\n\n* th/git-diffall (2012-03-14) 5 commits\n  (merged to 'next' on 2012-03-14 at 38e1251)\n + contrib/diffall: fix cleanup trap on Windows\n + contrib/diffall: eliminate duplicate while loops\n + contrib/diffall: eliminate use of tar\n + contrib/diffall: create tmp dirs without mktemp\n + contrib/diffall: comment actual reason for 'cdup'\n\nUpdate sample \"diffall\" script.\nMay want to ship with 1.7.10.\n\n* tr/maint-word-diff-regex-sticky (2012-03-14) 3 commits\n - diff: tweak a _copy_ of diff_options with word-diff\n - diff: refactor the word-diff setup from builtin_diff_cmd\n - t4034: diff.*.wordregex should not be \"sticky\" in --word-diff\n\nThe regexp configured with wordregex was incorrectly reused across\nfiles.\nNot urgent.\n\n* zj/test-cred-helper-nicer-prove (2012-03-14) 3 commits\n - t0303: resurrect commit message as test documentation\n - fixup?\n - t0303: immediately bail out w/o GIT_TEST_CREDENTIAL_HELPER\n\nMinor improvement to t0303.\nNot urgent.\n\n--------------------------------------------------\n[Stalled]\n\n* ab/perl-i18n (2012-03-10) 3 commits\n - fixup! de1e4ae\n - perl/Makefile: install Git::I18N under NO_PERL_MAKEMAKER\n - Git::I18N: compatibility with perl <5.8.3\n\nAttempts to help installations with ancient Perl and/or without\nMakeMaker.  Didn't quite work for me, so I tried to queue a fix-up\ncommit, but an independent confirmation report is needed before it\nis squashed into Ævar's patches.\n\n* dg/test-from-elsewhere (2012-03-04) 2 commits\n - Support out-of-tree Valgrind tests\n - Allow overriding GIT_BUILD_DIR\n\nBetter support for out-of-tree test scripts, but it appears that the\napproach needs to be rethought.  By repointing TEST_DIRECTORY to a\ndirectory other than $(pwd)/.., an out of place test script can reach\ntest helpers and freshly built Git relative to it (GIT_BUILD_DIR is\na mere short-hand for $TEST_DIRECTORY/..).\n\n* cn/apply-fix-ws-can-lengthen-lines (2012-03-11) 1 commit\n . apply: reallocate the postimage buffer when needed\n\nAttempts to address an ancient bug that dates back to the addition\nof an oddball \"tab-in-indent\" whitespace breakage class that wants\nto have longer lines than the original when fixing things up.\n\nNeeds more work; results in double-frees.\n\n* hv/submodule-recurse-push (2012-02-13) 3 commits\n - push: teach --recurse-submodules the on-demand option\n - Refactor submodule push check to use string list instead of integer\n - Teach revision walking machinery to walk multiple times sequencially\n\nThe bottom one was not clearly explained and needs a reroll.\n\n* jc/advise-push-default (2011-12-18) 1 commit\n - push: hint to use push.default=upstream when appropriate\n\nPeff had a good suggestion outlining an updated code structure so\nthat somebody new can try to dip his or her toes in the development.\n\nA rework is being attempted by Christopher Tiwald.\n\n* ss/git-svn-prompt-sans-terminal (2012-01-04) 3 commits\n - fixup! 15eaaf4\n - git-svn, perl/Git.pm: extend Git::prompt helper for querying users\n - perl/Git.pm: \"prompt\" helper to honor GIT_ASKPASS and SSH_ASKPASS\n\nThe bottom one has been replaced with a rewrite based on comments\nfrom Ævar. The second one needs more work, both in perl/Git.pm and\nprompt.c, to give precedence to tty over SSH_ASKPASS when terminal\nis available.\n\n* jc/split-blob (2012-02-23) 7 commits\n - fixup?\n - chunked-object: streaming checkout\n - chunked-object: fallback checkout codepaths\n - bulk-checkin: support chunked-object encoding\n - bulk-checkin: allow the same data to be multiply hashed\n - new representation types in the packstream\n - varint-in-pack: refactor varint encoding/decoding\n\nNot ready.\n\nI finished the streaming checkout codepath, but as explained in\n127b177 (bulk-checkin: support chunked-object encoding, 2011-11-30),\nthese are still early steps of a long and painful journey. At least\npack-objects and fsck need to learn the new encoding for the series\nto be usable locally, and then index-pack/unpack-objects needs to\nlearn it to be used remotely.\n\nGiven that I heard a lot of noise that people want large files, and\nthat I was asked by somebody at GitTogether'11 privately for an\nadvice on how to pay developers (not me) to help adding necessary\nsupport, I am somewhat dissapointed that the original patch series\nthat was sent almost two months ago still remains here without much\ncomments and updates from the developer community. I even made the\ninterface to the logic that decides where to split chunks easily\nreplaceable, and I deliberately made the logic in the original patch\nextremely stupid to entice others, especially the \"bup\" fanboys, to\ncome up with a better logic, thinking that giving people an easy\ntarget to shoot for, they may be encouraged to help out. The plan is\nnot working :-(.\n\n--------------------------------------------------\n[Cooking]\n\n* nd/columns (2012-03-13) 12 commits\n - column: support grouping entries\n - column: support \"denser\" mode\n - ls-files: support --column\n - tag: add --column\n - column: support piping stdout to external git-column process\n - status: add --column\n - branch: add --column\n - help: reuse print_columns() for help -a\n - column: add dense layout support\n - column: add columnar layout\n - Stop starting pager recursively\n - Add column layout skeleton and git-column\n\nRerolled again.  Modulo minor nits, looked nicer than the previous round.\n\n* nd/optim-connected (2012-03-14) 1 commit\n - {fetch,receive}-pack: skip sha-1 integrity test on objects from new pack\n\nOptimizes the local connectivity check performed by \"git fetch\" and \"git\nreceive-pack\" that is run in response to \"git push\".\n\n* jc/commit-hook-authorship (2012-03-11) 3 commits\n  (merged to 'next' on 2012-03-12 at 05ca7f8)\n + commit: pass author/committer info to hooks\n + t7503: does pre-commit-hook learn authorship?\n + ident.c: add split_ident_line() to parse formatted ident line\n (this branch is tangled with jc/run-hook-env-1.)\n\n\"git commit --author=$name\" did not tell the name that was being\nrecorded in the resulting commit to hooks, even though it does do so\nwhen the end user overrode the authorship via the \"GIT_AUTHOR_NAME\"\nenvironment variable.  This is a simpler of the two approaches.\n\nWill defer til 1.7.10.\n\n* jc/run-hook-env-1 (2012-03-11) 4 commits\n . commit: pass author/committer info to hooks\n - run_hook(): enhance the interface to pass arbitrary environment\n + t7503: does pre-commit-hook learn authorship?\n + ident.c: add split_ident_line() to parse formatted ident line\n (this branch is tangled with jc/commit-hook-authorship.)\n\nAddresses the same issue as jc/commit-hook-authorship, sharing the first\ntwo changes with the previous one, but uses a more complex approach, which\nmay not be worth the complexity.  The third patch is a prerequiste for the\nfourth one (not used), but is independently useful.\n\n* jn/maint-fast-import-empty-ls (2012-03-09) 2 commits\n - fast-import: don't allow 'ls' of path with empty components\n - fast-import: leakfix for 'ls' of dirty trees\n\nfast-import did not diagnose \"ls ''\" that asks an empty path\nas an error.\n\n* jc/diff-algo-cleanup (2012-02-19) 2 commits\n - xdiff: PATIENCE/HISTOGRAM are not independent option bits\n - xdiff: remove XDL_PATCH_* macros\n (this branch is used by jc/diff-ignore-case.)\n\nResurrects the preparatory clean-up patches from another topic\nthat was discarded.\n\n* jh/apply-free-patch (2012-03-07) 1 commit\n - apply: do not leak patches and fragments\n\nWill defer til 1.7.10.\n\n* rs/unpack-trees-leakfix (2012-03-06) 1 commit\n  (merged to 'next' on 2012-03-07 at 69a69cd)\n + unpack-trees: plug minor memory leak\n\nWill defer til 1.7.10.\n\n* tb/maint-remove-irrelevant-i18n-test (2012-03-06) 1 commit\n  (merged to 'next' on 2012-03-07 at 23f2dd1)\n + t0204: remove a test that checks undefined behaviour\n\nI tentatively parked this in 'next' but later reverted the merge.\nWill discard.\n\n* mm/push-default-switch-warning (2012-03-09) 1 commit\n - push: start warning upcoming default change for push.default\n\nThis resurrects an ancient patch I wrote during a discussion we had\nin the 1.6.3-1.6.4 era.  It also conflicts with the long-stalled\njc/advise-push-default topic and for a good reason---they address a\nsimilar issue.  The latter is a lower impact patch that uses a more\nfocused approach to limit the scope to the target audience that\nactually needs help.\n\n* sl/customize-sane-tool-path (2012-03-09) 1 commit\n - configure: allow user to prevent $PATH \"sanitization\" on Solaris\n\nWould be nice to hear from people who actually use autoconf, either\non Solaris or other platforms.\n\n* jc/fmt-merge-msg-people (2012-03-13) 1 commit\n - fmt-merge-msg: show those involved in a merged series\n\nRerolled.\n\nThe \"fmt-merge-msg\" command learns to list the primary contributors\ninvolved in the side topic you are merging.\n\nWill defer til 1.7.10.\n\n* nl/http-proxy-more (2012-03-14) 5 commits\n - http: rename HTTP_REAUTH to HTTP_AUTH_RETRY\n - http: Avoid limit of retrying request only twice\n - http: handle proxy authentication failure (error 407)\n - http: handle proxy proactive authentication\n - http: try http_proxy env var when http.proxy config option is not set\n\nThe code to talk to http proxies learn to use the same credential\nAPI used to talk to the final http destinations.\n\nWill defer til 1.7.10.\n\n* nd/stream-more (2012-03-07) 7 commits\n  (merged to 'next' on 2012-03-07 at 7325922)\n + update-server-info: respect core.bigfilethreshold\n + fsck: use streaming API for writing lost-found blobs\n + show: use streaming API for showing blobs\n + parse_object: avoid putting whole blob in core\n + cat-file: use streaming API to print blobs\n + Add more large blob test cases\n + streaming: make streaming-write-entry to be more reusable\n\nUse API to read blob data in smaller chunks in more places to\nreduce the memory footprint.  In general, looked fairly good.\n\nWill defer til 1.7.10.\n\n* nd/threaded-index-pack (2012-03-11) 2 commits\n - index-pack: support multithreaded delta resolving\n - index-pack: split second pass obj handling into own function\n\nAnother reroll after a bugreport on pthread usage discovered by\nRamsey.\n\n--------------------------------------------------\n[Discarded]\n\n* jc/diff-ignore-mode (2012-03-01) 1 commit\n . diff --ignore-mode-change\n\n * jc/diff-ignore-case (2012-02-28) 6 commits\n . diff: -i is \"--ignore-case\" but means a bit more in \"log\"\n . diff: --ignore-case\n . xdiff: introduce XDF_IGNORE_CASE\n . xdiff: introduce XDF_INEXACT_MATCH\n - xdiff: PATIENCE/HISTOGRAM are not independent option bits\n - xdiff: remove XDL_PATCH_* macros\n\n* jh/trace-use-startup-info (2012-03-02) 1 commit\n . Use startup_info->prefix rather than prefix.\n\nI tend to agree with the doubt of the author of this patch expressed.\n"}]}