{"thread":{"id":"29541","subject":"What's cooking in git.git (Feb 2012, #01; Fri, 3)","startedAt":"2012-02-04T07:51:50Z","lastAt":"2012-02-04T07:51:50Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"183814","messageId":"7vr4ybhw89.fsf@alter.siamese.dyndns.org","threadId":"29541","inReplyTo":null,"subject":"What's cooking in git.git (Feb 2012, #01; Fri, 3)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-02-04T07:51:50Z","receivedAt":"2012-02-04T07:51:50Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"What's cooking in git.git (Feb 2012, #01; Fri, 3)\n--------------------------------------------------\n\nHere are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' (proposed updates) while commits prefixed with '+' are in\n'next'.\n\nHere are the repositories that have my integration branches:\n\nWith maint, master, next, pu, todo:\n\n        git://git.kernel.org/pub/scm/git/git.git\n        git://repo.or.cz/alt-git.git\n        https://code.google.com/p/git-core/\n        https://github.com/git/git\n\nWith only maint and master:\n\n        git://git.sourceforge.jp/gitroot/git-core/git.git\n        git://git-core.git.sourceforge.net/gitroot/git-core/git-core\n\nWith all the topics and integration branches:\n\n        https://github.com/gitster/git\n\nThe preformatted documentation in HTML and man format are found in:\n\n        git://git.kernel.org/pub/scm/git/git-{htmldocs,manpages}.git/\n        git://repo.or.cz/git-{htmldocs,manpages}.git/\n        https://code.google.com/p/git-{htmldocs,manpages}.git/\n        https://github.com/gitster/git-{htmldocs,manpages}.git/\n\n--------------------------------------------------\n[New Topics]\n\n* nd/diffstat-gramnum (2012-02-03) 1 commit\n - Use correct grammar in diffstat summary line\n\nThe commands in the \"git diff\" family and \"git apply --stat\" that count\nthe number of files changed and the number of lines inserted/deleted have\nbeen updated to match the output from \"diffstat\".  This also opens the\ndoor to i18n this line.\n\nWill merge to 'next'.\n\n* jx/i18n-more-marking (2012-02-01) 2 commits\n - i18n: format_tracking_info \"Your branch is behind\" message\n - i18n: git-commit whence_s \"merge/cherry-pick\" message\n\nWill merge to 'next'.\n\n* jk/grep-binary-attribute (2012-02-02) 9 commits\n - grep: pre-load userdiff drivers when threaded\n - grep: load file data after checking binary-ness\n - grep: respect diff attributes for binary-ness\n - grep: cache userdiff_driver in grep_source\n - grep: drop grep_buffer's \"name\" parameter\n - convert git-grep to use grep_source interface\n - grep: refactor the concept of \"grep source\" into an object\n - grep: move sha1-reading mutex into low-level code\n - grep: make locking flag global\n\nFixes a longstanding bug that there was no way to tell \"git grep\" that a\npath may look like text but it is not, which \"git diff\" can do using the\nattributes system. Now \"git grep\" honors the same \"binary\" (or \"-diff\")\nattribute.\n\nWill merge to 'next'.\n\n* jc/parse-date-raw (2012-02-03) 2 commits\n - parse_date(): '@' prefix forces git-timestamp\n - parse_date(): allow ancient git-timestamp\n\n\"rebase\" and \"commit --amend\" failed to work on commits with ancient\ntimestamps near year 1970.\n\nWaiting for comments.\n\n* jk/git-dir-lookup (2012-02-02) 1 commit\n - standardize and improve lookup rules for external local repos\n\nWill merge to 'next'.\n\n* jk/prompt-fallback-to-tty (2012-02-03) 2 commits\n - prompt: fall back to terminal if askpass fails\n - prompt: clean up strbuf usage\n\nThe code to ask for password did not fall back to the terminal input when\nGIT_ASKPASS is set but does not work (e.g. lack of X with GUI askpass\nhelper).\n\n* jk/tests-write-script (2012-02-03) 2 commits\n - t0300: use write_script helper\n - tests: add write_script helper function\n\nWill merge to 'next'.\n\n* jn/gitweb-search-utf-8 (2012-02-03) 1 commit\n - gitweb: Allow UTF-8 encoded CGI query parameters and path_info\n\nSearch box in \"gitweb\" did not accept non-ASCII characters correctly.\nWill merge to 'next'.\n\n* jn/rpm-spec (2012-02-03) 1 commit\n - git.spec: Workaround localized messages not put in any RPM\n\nFix breakage in v1.7.9 Makefile; rpmbuild notices an unpackaged but\ninstalled *.mo file and fails.\n\nWill merge to 'next'.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* jc/pull-signed-tag (2012-01-23) 1 commit\n  (merged to 'next' on 2012-01-23 at 4257553)\n + merge: use editor by default in interactive sessions\n\n\"git merge\" in an interactive session learned to spawn the editor by\ndefault to let the user edit the auto-generated merge message, to\nencourage people to explain their merges better. Legacy scripts can\nexport MERGE_AUTOEDIT=no to retain the historical behaviour.\n\n* tr/merge-edit-guidance (2012-01-31) 1 commit\n  (merged to 'next' on 2012-01-31 at bb678f7)\n + merge: add instructions to the commit message when editing\n\n\"git merge\" adds advice text to the commit log template when running\ninteractively.\n\n--------------------------------------------------\n[Stalled]\n\n* jc/advise-push-default (2011-12-18) 1 commit\n - push: hint to use push.default=upstream when appropriate\n\nPeff had a good suggestion outlining an updated code structure so that\nsomebody new can try to dip his or her toes in the development. Any\ntakers?\n\nWaiting for a reroll.\n\n* ss/git-svn-prompt-sans-terminal (2012-01-04) 3 commits\n - fixup! 15eaaf4\n - git-svn, perl/Git.pm: extend Git::prompt helper for querying users\n - perl/Git.pm: \"prompt\" helper to honor GIT_ASKPASS and SSH_ASKPASS\n\nThe bottom one has been replaced with a rewrite based on comments from\nÆvar. The second one needs more work, both in perl/Git.pm and prompt.c, to\ngive precedence to tty over SSH_ASKPASS when terminal is available.\n\n* nd/commit-ignore-i-t-a (2012-01-16) 2 commits\n - commit, write-tree: allow to ignore CE_INTENT_TO_ADD while writing trees\n - cache-tree: update API to take abitrary flags\n\nMay want to consider this as fixing an earlier UI mistake, and not as a\nfeature that devides the userbase.\n\n--------------------------------------------------\n[Cooking]\n\n* fc/zsh-completion (2012-02-03) 3 commits\n - completion: simplify __gitcomp and __gitcomp_nl implementations\n - completion: use ls -1 instead of rolling a loop to do that ourselves\n - completion: work around zsh option propagation bug\n\nFix git subcommand completion for zsh (in contrib/completion).\n\nWill merge to 'next'.\n\n* jc/maint-request-pull-for-tag (2012-01-31) 1 commit\n  (merged to 'next' on 2012-02-01 at 7649f18)\n + request-pull: explicitly ask tags/$name to be pulled\n\nWhen asking for a tag to be pulled, \"request-pull\" shows the name of the\ntag prefixed with \"tags/\"\n\n* nd/find-pack-entry-recent-cache-invalidation (2012-02-01) 2 commits\n  (merged to 'next' on 2012-02-01 at e26aed0)\n + find_pack_entry(): do not keep packed_git pointer locally\n + sha1_file.c: move the core logic of find_pack_entry() into fill_pack_entry()\n\n* nd/pack-objects-parseopt (2012-02-01) 3 commits\n - pack-objects: convert to use parse_options()\n - pack-objects: remove bogus comment\n - pack-objects: do not accept \"--index-version=version,\"\n\nWill merge to 'next'.\n\n\"pack-objects\" learned use parse-options, losing custom command line\nparsing code.\n\n* bl/gitweb-project-filter (2012-02-01) 8 commits\n  (merged to 'next' on 2012-02-01 at 2c96ce7)\n + gitweb: Make project search respect project_filter\n + gitweb: improve usability of projects search form\n + gitweb: place links to parent directories in page header\n + gitweb: show active project_filter in project_list page header\n + gitweb: limit links to alternate forms of project_list to active project_filter\n + gitweb: add project_filter to limit project list to a subdirectory\n + gitweb: prepare git_get_projects_list for use outside 'forks'.\n + gitweb: move hard coded .git suffix out of git_get_projects_list\n\n\"gitweb\" allows intermediate entries in the directory hierarchy that leads\nto a projects to be clicked, which in turn shows the list of projects\ninside that directory.\n\n* rt/completion-branch-edit-desc (2012-01-29) 1 commit\n  (merged to 'next' on 2012-02-01 at 0627ebf)\n + completion: --edit-description option for git-branch\n\nOriginally merged to 'next' on 2012-01-31.\nWill merge to 'master'.\n\n* jn/svn-fe (2012-02-02) 47 commits\n - vcs-svn: suppress a -Wtype-limits warning\n - vcs-svn: allow import of > 4GiB files\n - vcs-svn: rename check_overflow arguments for clarity\n  (merged to 'next' on 2012-02-01 at 9288c95)\n + vcs-svn/svndiff.c: squelch false \"unused\" warning from gcc\n + Merge branch 'svn-fe' of git://repo.or.cz/git/jrn into jn/svn-fe\n + vcs-svn: reset first_commit_done in fast_export_init\n + Merge branch 'db/text-delta' into svn-fe\n + vcs-svn: do not initialize report_buffer twice\n + Merge branch 'db/text-delta' into svn-fe\n + vcs-svn: avoid hangs from corrupt deltas\n + vcs-svn: guard against overflow when computing preimage length\n + Merge branch 'db/delta-applier' into db/text-delta\n + vcs-svn: implement text-delta handling\n + Merge branch 'db/delta-applier' into db/text-delta\n + Merge branch 'db/delta-applier' into svn-fe\n + vcs-svn: cap number of bytes read from sliding view\n + test-svn-fe: split off \"test-svn-fe -d\" into a separate function\n + vcs-svn: let deltas use data from preimage\n + vcs-svn: let deltas use data from postimage\n + vcs-svn: verify that deltas consume all inline data\n + vcs-svn: implement copyfrom_data delta instruction\n + vcs-svn: read instructions from deltas\n + vcs-svn: read inline data from deltas\n + vcs-svn: read the preimage when applying deltas\n + vcs-svn: parse svndiff0 window header\n + vcs-svn: skeleton of an svn delta parser\n + vcs-svn: make buffer_read_binary API more convenient\n + vcs-svn: learn to maintain a sliding view of a file\n + Makefile: list one vcs-svn/xdiff object or header per line\n + Merge branch 'db/svn-fe-code-purge' into svn-fe\n + vcs-svn: drop obj_pool\n + vcs-svn: drop treap\n + vcs-svn: drop string_pool\n + vcs-svn: pass paths through to fast-import\n + Merge branch 'db/strbufs-for-metadata' into db/svn-fe-code-purge\n + Merge branch 'db/length-as-hash' (early part) into db/svn-fe-code-purge\n + Merge branch 'db/vcs-svn-incremental' into svn-fe\n + vcs-svn: avoid using ls command twice\n + vcs-svn: use mark from previous import for parent commit\n + vcs-svn: handle filenames with dq correctly\n + vcs-svn: quote paths correctly for ls command\n + vcs-svn: eliminate repo_tree structure\n + vcs-svn: add a comment before each commit\n + vcs-svn: save marks for imported commits\n + vcs-svn: use higher mark numbers for blobs\n + vcs-svn: set up channel to read fast-import cat-blob response\n + Merge commit 'v1.7.5' into svn-fe\n\nOriginally merged to 'next' on 2012-01-29.\n\n\"vcs-svn\"/\"svn-fe\" learned to read dumps with svn-deltas and support\nincremental imports.\n\nWill merge to 'next' through the tip and then to 'master' soon after.\n\n* jc/split-blob (2012-01-24) 6 commits\n - chunked-object: streaming checkout\n - chunked-object: fallback checkout codepaths\n - bulk-checkin: support chunked-object encoding\n - bulk-checkin: allow the same data to be multiply hashed\n - new representation types in the packstream\n - varint-in-pack: refactor varint encoding/decoding\n\nNot ready.\n\nI finished the streaming checkout codepath, but as explained in 127b177\n(bulk-checkin: support chunked-object encoding, 2011-11-30), these are\nstill early steps of a long and painful journey. At least pack-objects and\nfsck need to learn the new encoding for the series to be usable locally,\nand then index-pack/unpack-objects needs to learn it to be used remotely.\n\nGiven that I heard a lot of noise that people want large files, and that I\nwas asked by somebody at GitTogether'11 privately for an advice on how to\npay developers (not me) to help adding necessary support, I am somewhat\ndissapointed that the original patch series that was sent almost two\nmonths ago still remains here without much comments and updates from the\ndeveloper community. I even made the interface to the logic that decides\nwhere to split chunks easily replaceable, and I deliberately made the\nlogic in the original patch extremely stupid to entice others, especially\nthe \"bup\" fanboys, to come up with a better logic, thinking that giving\npeople an easy target to shoot for, they may be encouraged to help\nout. The plan is not working :-(.\n"}]}