{"thread":{"id":"26877","subject":"What's cooking in git.git (Mar 2011, #05; Sun, 27)","startedAt":"2011-03-27T07:49:29Z","lastAt":"2011-03-27T07:49:29Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"164384","messageId":"7vbp0x2eba.fsf@alter.siamese.dyndns.org","threadId":"26877","inReplyTo":null,"subject":"What's cooking in git.git (Mar 2011, #05; Sun, 27)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2011-03-27T07:49:29Z","receivedAt":"2011-03-27T07:49:29Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.\n\n--------------------------------------------------\n[New Topics]\n\n* jc/merge-sans-branch (2011-03-23) 2 commits\n - merge: merge with the default upstream branch without argument\n - merge: match the help text with the documentation\n\nAllow running \"git merge\" without telling it what to merge.  It will merge\nwith the \"upstream\" of the current branch if configured.\n\n* jh/gitweb-localtime (2011-03-23) 1 commit\n - gitweb: javascript ability to adjust time based on timezone\n\n* jk/maint-merge-rename-create (2011-03-25) 3 commits\n - merge: turn on rewrite detection\n - merge: handle renames with replacement content\n - t3030: fix accidental success in symlink rename\n\n* jk/pull-into-empty (2011-03-25) 2 commits\n - pull: do not clobber untracked files on initial pull\n - merge: merge unborn index before setting ref\n\n* mz/maint-rename-unmerged (2011-03-23) 1 commit\n - diffcore-rename: don't consider unmerged path as source\n\n* nd/struct-pathspec (2011-03-25) 4 commits\n - Improve tree_entry_interesting() handling code\n - Convert read_tree{,_recursive} to support struct pathspec\n - Reimplement read_tree_recursive() using tree_entry_interesting()\n - Merge branch 'en/object-list-with-pathspec' into 'nd/struct-pathspec'\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* jc/fetch-progressive-stride (2011-03-20) 3 commits\n  (merged to 'next' on 2011-03-20 at 2917b19)\n + fetch-pack: use smaller handshake window for initial request\n + fetch-pack: progressively use larger handshake windows\n + fetch-pack: factor out hardcoded handshake window size\n\n* jc/index-update-if-able (2011-03-21) 2 commits\n  (merged to 'next' on 2011-03-23 at e7e071a)\n + update $GIT_INDEX_FILE when there are racily clean entries\n + diff/status: refactor opportunistic index update\n\n* jc/maint-rerere-in-workdir (2011-03-10) 1 commit\n  (merged to 'next' on 2011-03-23 at e5ef1a2)\n + rerere: make sure it works even in a workdir attached to a young repository\n\nResurrected, as this was originally written with the explicit goal of\nhelping contrib/workdir/git-new-workdir users, and it is good enough to\nonly support absolute symbolic links for that purpose.\n\n* jk/checkout-orphan-warning (2011-03-20) 3 commits\n  (merged to 'next' on 2011-03-23 at 26adae6)\n + checkout: tweak detached-orphan warning format\n + checkout: clear commit marks after detached-orphan check\n + checkout: add basic tests for detached-orphan warning\n\n* jp/completion-help-alias (2011-03-21) 1 commit\n  (merged to 'next' on 2011-03-23 at e21fa7b)\n + git-completion: Add git help completion for aliases\n\n* js/remove-unused-variables (2011-03-22) 1 commit\n  (merged to 'next' on 2011-03-23 at 4630013)\n + Remove unused variables\n\n* mg/rev-list-n-parents (2011-03-23) 3 commits\n  (merged to 'next' on 2011-03-23 at 8baa059)\n + rev-list --min-parents,--max-parents: doc, test and completion\n + revision.c: introduce --min-parents and --max-parents options\n + t6009: use test_commit() from test-lib.sh\n\nRerolled with --no-max-parents and the like.\n\n* nd/index-doc (2011-03-01) 2 commits\n  (merged to 'next' on 2011-03-23 at 316cafc)\n + doc: technical details about the index file format\n + doc: technical details about the index file format\n\n* ss/git-gui-mergetool (2011-02-26) 2 commits\n  (merged to 'next' on 2011-03-17 at a8fac18)\n + mergetool--lib: Add Beyond Compare 3 as a tool\n + mergetool--lib: Sort tools alphabetically for easier lookup\n\nMerged through Pat's git-gui tree.\n\n--------------------------------------------------\n[Stalled]\n\n* mz/rebase (2011-02-28) 34 commits\n - rebase: define options in OPTIONS_SPEC\n  (merged to 'next' on 2011-02-25 at 52caa7a)\n + Makefile: do not install sourced rebase scripts\n  (merged to 'next' on 2011-02-22 at 3219155)\n + rebase: use @{upstream} if no upstream specified\n + rebase -i: remove unnecessary state rebase-root\n + rebase -i: don't read unused variable preserve_merges\n + git-rebase--am: remove unnecessary --3way option\n + rebase -m: don't print exit code 2 when merge fails\n + rebase -m: remember allow_rerere_autoupdate option\n + rebase: remember strategy and strategy options\n + rebase: remember verbose option\n + rebase: extract code for writing basic state\n + rebase: factor out sub command handling\n + rebase: make -v a tiny bit more verbose\n + rebase -i: align variable names\n + rebase: show consistent conflict resolution hint\n + rebase: extract am code to new source file\n + rebase: extract merge code to new source file\n + rebase: remove $branch as synonym for $orig_head\n + rebase -i: support --stat\n + rebase: factor out call to pre-rebase hook\n + rebase: factor out clean work tree check\n + rebase: factor out reference parsing\n + rebase: reorder validation steps\n + rebase -i: remove now unnecessary directory checks\n + rebase: factor out command line option processing\n + rebase: align variable content\n + rebase: align variable names\n + rebase: stricter check of standalone sub command\n + rebase: act on command line outside parsing loop\n + rebase: improve detection of rebase in progress\n + rebase: remove unused rebase state 'prev_head'\n + rebase: read state outside loop\n + rebase: refactor reading of state\n + rebase: clearer names for directory variables\n\nI think the tip one is a response to J6t's regression concerns; it looked\nOk to me.\n\n* jc/diff-irreversible-delete (2011-02-28) 1 commit\n - git diff -D: omit the preimage of deletes\n\n\"diff -B -D\" should omit the deleting half of a broken pair from the\noutput.  Need documentation and tests.\n\n* gr/cvsimport-alternative-cvspass-location (2011-02-18) 1 commit\n - Look for password in both CVS and CVSNT password files.\n\nIt seems that we need separate parsers for these two formats in order not\nto regress the users of the original cvs.\n\n* jc/index-pack (2011-02-25) 5 commits\n - index-pack --verify: read anomalous offsets from v2 idx file\n - write_idx_file: need_large_offset() helper function\n - index-pack: --verify\n - write_idx_file: introduce a struct to hold idx customization options\n - index-pack: group the delta-base array entries also by type\n\nStill a WIP, and will not be ready for 1.7.5. Need to put histogram output\ninto index-pack --verify to really kill verify-pack.\n\n* jk/tag-contains (2010-07-05) 4 commits\n - Why is \"git tag --contains\" so slow?\n - default core.clockskew variable to one day\n - limit \"contains\" traversals based on commit timestamp\n - tag: speed up --contains calculation\n\nThe idea of the bottom one is probably Ok, except that the use of object\nflags needs to be rethought, or at least the helper needs to be moved to\nbuiltin/tag.c to make it clear that it should not be used outside the\ncurrent usage context.\n\n* jk/edit-notes-in-commit-log (2011-03-07) 2 commits\n - [wip] commit: allow editing notes in commit message editor\n - notes: make expand_notes_ref globally accessible\n\n* mg/grep-full-tree (2011-03-01) 2 commits\n - grep: make --full-tree work with pathspecs\n - grep: --full-tree\n\nDo not merge; it would be preferable to use \":/\" or whatever magic\npathspec that is relative to the root of the working tree.\n\n--------------------------------------------------\n[Cooking]\n\n* jc/add-u-migration (2011-03-22) 3 commits\n - add: make \"add -u/-A\" update full tree without pathspec (step 3)\n - add: make \"add -u/-A\" update full tree without pathspec (step 2)\n - add: make \"add -u/-A\" update full tree without pathspec\n\nThe message in the bottom one really needs proofreading to move this topic\nforward. Will merge to 'next' the bottom one, hopefully after that.\n\n* jk/progress-with-pager (2011-03-24) 4 commits\n - diff: turn on rename detection progress reporting\n - show: turn on rename detection progress reporting\n - progress: use pager's original_stderr if available\n - pager: save the original stderr when redirecting to pager\n\n* sb/sparse-more (2011-03-21) 1 commit\n  (merged to 'next' on 2011-03-23 at 4bec1d1)\n + Makefile: Cover more files with make check\n\n* jc/rename-degrade-cc-to-c (2011-01-06) 4 commits\n - diffcore-rename: fall back to -C when -C -C busts the rename limit\n - diffcore-rename: record filepair for rename src\n - diffcore-rename: refactor \"too many candidates\" logic\n - builtin/diff.c: remove duplicated call to diff_result_code()\n\nTook another look and even wrote tests, but it turns out that it needed\nrebasing on bf0ab10 (merge: improve inexact rename limit warning,\n2011-02-19), as that commit didn't anticipate that we may want this\nwarning outside merge-recursive codepath.  The top one ended up\nlarger than it should have been as a result.\n\n* cn/system-path-tweak (2011-03-17) 1 commit\n - system_path: use a static buffer\n\n* en/merge-recursive (2011-03-17) 4 commits\n  (merged to 'next' on 2011-03-18 at a32016b)\n + merge-recursive: tweak magic band-aid\n  (merged to 'next' on 2011-03-09 at 3762932)\n + merge-recursive: When we detect we can skip an update, actually skip it\n + t6022: New test checking for unnecessary updates of files in D/F conflicts\n + t6022: New test checking for unnecessary updates of renamed+modified files\n\nI am not happy with these magic band aids.\n\n* nd/init-gitdir (2011-03-19) 2 commits\n - init, clone: support --separate-git-dir for .git file\n - git-init.txt: move description section up\n\n* jl/submodule-fetch-on-demand (2011-03-06) 7 commits\n  (merged to 'next' on 2011-03-20 at a5e452d)\n + fetch/pull: Describe --recurse-submodule restrictions in the BUGS section\n + submodule update: Don't fetch when the submodule commit is already present\n + fetch/pull: Don't recurse into a submodule when commits are already present\n + Submodules: Add 'on-demand' value for the 'fetchRecurseSubmodule' option\n + config: teach the fetch.recurseSubmodules option the 'on-demand' value\n + fetch/pull: Add the 'on-demand' value to the --recurse-submodules option\n + fetch/pull: recurse into submodules when necessary\n\n* ab/i18n-st (2011-02-22) 69 commits\n  (merged to 'next' on 2011-03-23 at e2732e2)\n + i18n: git-shortlog basic messages\n + i18n: git-revert split up \"could not revert/apply\" message\n + i18n: git-revert literal \"me\" messages\n + i18n: git-revert \"Your local changes\" message\n + i18n: git-revert basic messages\n + i18n: git-notes GIT_NOTES_REWRITE_MODE error message\n + i18n: git-notes basic commands\n + i18n: git-gc \"Auto packing the repository\" message\n + i18n: git-gc basic messages\n + i18n: git-describe basic messages\n + i18n: git-clean clean.requireForce messages\n + i18n: git-clean basic messages\n + i18n: git-bundle basic messages\n + i18n: git-archive basic messages\n + i18n: git-status \"renamed: \" message\n + i18n: git-status \"Initial commit\" message\n + i18n: git-status \"Changes to be committed\" message\n + i18n: git-status shortstatus messages\n + i18n: git-status \"nothing to commit\" messages\n + i18n: git-status basic messages\n + i18n: git-push \"prevent you from losing\" message\n + i18n: git-push basic messages\n + i18n: git-tag tag_template message\n + i18n: git-tag basic messages\n + i18n: git-reset \"Unstaged changes after reset\" message\n + i18n: git-reset reset_type_names messages\n + i18n: git-reset basic messages\n + i18n: git-rm basic messages\n + i18n: git-mv \"bad\" messages\n + i18n: git-mv basic messages\n + i18n: git-merge \"Wonderful\" message\n + i18n: git-merge \"You have not concluded your merge\" messages\n + i18n: git-merge \"Updating %s..%s\" message\n + i18n: git-merge basic messages\n + i18n: git-log \"--OPT does not make sense\" messages\n + i18n: git-log basic messages\n + i18n: git-grep \"--open-files-in-pager\" message\n + i18n: git-grep basic messages\n + i18n: git-fetch split up \"(non-fast-forward)\" message\n + i18n: git-fetch update_local_ref messages\n + i18n: git-fetch formatting messages\n + i18n: git-fetch basic messages\n + i18n: git-diff basic messages\n + i18n: git-commit advice messages\n + i18n: git-commit \"enter the commit message\" message\n + i18n: git-commit print_summary messages\n + i18n: git-commit formatting messages\n + i18n: git-commit \"middle of a merge\" message\n + i18n: git-commit basic messages\n + i18n: git-checkout \"Switched to a .. branch\" message\n + i18n: git-checkout \"HEAD is now at\" message\n + i18n: git-checkout describe_detached_head messages\n + i18n: git-checkout: our/their version message\n + i18n: git-checkout basic messages\n + i18n: git-branch \"(no branch)\" message\n + i18n: git-branch \"git branch -v\" messages\n + i18n: git-branch \"Deleted branch [...]\" message\n + i18n: git-branch \"remote branch '%s' not found\" message\n + i18n: git-branch basic messages\n + i18n: git-add \"Unstaged changes\" message\n + i18n: git-add \"remove '%s'\" message\n + i18n: git-add \"did not match any files\" message\n + i18n: git-add \"The following paths are ignored\" message\n + i18n: git-add basic messages\n + i18n: git-clone \"Cloning into\" message\n + i18n: git-clone \"Cloning into\" message\n + i18n: git-clone basic messages\n + i18n: git-init \"Initialized [...] repository\" message\n + i18n: git-init basic messages\n\nNow in 'next'.\n\n--------------------------------------------------\n[Discarded]\n\n* jc/diff-dotdot (2011-03-23) 2 commits\n . warn use of \"git diff A..B\"\n . diff: remove dead code that flips arguments order\n\nThis is 1/4 tongue-in-cheek. Now we seem to have at least two volunteer\ncluebat bearers, so I wouldn't have to worry about this topic very much.\n\n* jh/merge-sans-branch (2011-02-10) 4 commits\n . merge: add support for merging from upstream by default\n - merge: introduce per-branch-configuration helper function\n - merge: introduce setup_merge_commit helper function\n - merge: update the usage information to be more modern\n\nI've been wanting to move this forward for quite some time but \nended up redoing it myself (see jc/merge-sans-branch)\n"}]}