{"thread":{"id":"25464","subject":"[PATCH] documentation: git-config minor cleanups","startedAt":"2010-10-18T03:10:45Z","lastAt":"2010-10-18T03:38:33Z","messageCount":2,"participants":["Cliff Frey","Jonathan Nieder"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"153688","messageId":"1287371445-26134-1-git-send-email-cliff@meraki.com","threadId":"25464","inReplyTo":null,"subject":"[PATCH] documentation: git-config minor cleanups","fromName":"Cliff Frey","fromEmail":"cliff@meraki.com","sentAt":"2010-10-18T03:10:45Z","receivedAt":"2010-10-18T03:10:45Z","isPatch":true,"sender":{"key":"cliff@meraki.com","avatar":null},"body":"Change push.default's description to add hyphens between values and\ndescriptions to make the manpage easier to read.  The html version is\nreadable either way.\n\nChange status.showUntrackedFiles to make item descriptions be\nsentences and to use the same asciidoc format as push.default.  The\nonly visual change is the additions of \".\"\n\nSigned-off-by: Cliff Frey <cliff@meraki.com>\n---\n Documentation/config.txt |   14 +++++++-------\n 1 files changed, 7 insertions(+), 7 deletions(-)\n\ndiff --git a/Documentation/config.txt b/Documentation/config.txt\nindex 71ddb6c..1cd820d 100644\n--- a/Documentation/config.txt\n+++ b/Documentation/config.txt\n@@ -1560,12 +1560,12 @@ push.default::\n \tno refspec is implied by any of the options given on the command\n \tline. Possible values are:\n +\n-* `nothing` do not push anything.\n-* `matching` push all matching branches.\n+* `nothing` - do not push anything.\n+* `matching` - push all matching branches.\n   All branches having the same name in both ends are considered to be\n   matching. This is the default.\n-* `tracking` push the current branch to its upstream branch.\n-* `current` push the current branch to a branch of the same name.\n+* `tracking` - push the current branch to its upstream branch.\n+* `current` - push the current branch to a branch of the same name.\n \n rebase.stat::\n \tWhether to show a diffstat of what changed upstream since the last\n@@ -1765,9 +1765,9 @@ status.showUntrackedFiles::\n \tthe untracked files. Possible values are:\n +\n --\n-\t- 'no'     - Show no untracked files\n-\t- 'normal' - Shows untracked files and directories\n-\t- 'all'    - Shows also individual files in untracked directories.\n+* `no` - Show no untracked files.\n+* `normal` - Shows untracked files and directories.\n+* `all` - Shows also individual files in untracked directories.\n --\n +\n If this variable is not specified, it defaults to 'normal'.\n-- \n1.7.3.1.120.g38a18\n"},{"id":"153690","messageId":"20101018033722.GA3340@burratino","threadId":"25464","inReplyTo":"1287371445-26134-1-git-send-email-cliff@meraki.com","subject":"Re: [PATCH] documentation: git-config minor cleanups","fromName":"Jonathan Nieder","fromEmail":"jrnieder@gmail.com","sentAt":"2010-10-18T03:38:33Z","receivedAt":"2010-10-18T03:38:33Z","isPatch":true,"sender":{"key":"jrnieder@gmail.com","avatar":"https://avatars.githubusercontent.com/u/281595?v=4"},"body":"Cliff Frey wrote:\n\n> Change push.default's description to add hyphens between values and\n> descriptions to make the manpage easier to read.  The html version is\n> readable either way.\n> \n> Change status.showUntrackedFiles to make item descriptions be\n> sentences and to use the same asciidoc format as push.default.\n\nYep, it is hard to read\n\n| ·    nothing do not push anything.\n|\n| ·    matching push all matching branches. All\n|     branches having the same name in both ends are\n[etc]\n\nwithout the font change to indicate where each term begins and ends.\n\nSo for what it's worth:\nAcked-by: Jonathan Nieder <jrnieder@gmail.com>\n\nThanks.\n\n> --- a/Documentation/config.txt\n> +++ b/Documentation/config.txt\n> @@ -1765,9 +1765,9 @@ status.showUntrackedFiles::\n>  \tthe untracked files. Possible values are:\n>  +\n>  --\n> -\t- 'no'     - Show no untracked files\n> -\t- 'normal' - Shows untracked files and directories\n> -\t- 'all'    - Shows also individual files in untracked directories.\n> +* `no` - Show no untracked files.\n> +* `normal` - Shows untracked files and directories.\n> +* `all` - Shows also individual files in untracked directories.\n\nIf you are making these into sentences, they should be\n\n - Show no untracked...\n - Show untracked...\n - Also show...\n\n, no?  [i.e., s/Shows/Show/c]\n"}]}