{"thread":{"id":"23740","subject":"What's cooking in git.git (May 2010, #02; Fri, 7)","startedAt":"2010-05-08T05:45:35Z","lastAt":"2010-05-08T05:45:35Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"141232","messageId":"7vy6fvaqv4.fsf@alter.siamese.dyndns.org","threadId":"23740","inReplyTo":null,"subject":"What's cooking in git.git (May 2010, #02; Fri, 7)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-05-08T05:45:35Z","receivedAt":"2010-05-08T05:45:35Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.  The ones\nmarked with '.' do not appear in any of the integration branches, but I am\nstill holding onto them.\n\nI'm in the middle of physically moving and haven't started graduating the\ntopics that have been cooking in 'next'.  Perhaps I can find time to do so\nfor some of them over the weekend.  I expect that I won't be back up to\nspeed until later this month.\n\n--------------------------------------------------\n[New Topics]\n\n* jn/gitweb-syntax-highlight (2010-04-27) 2 commits\n - gitweb: Refactor syntax highlighting support\n - gitweb: Syntax highlighting support\n\n* jn/maint-amend-missing-name (2010-05-02) 1 commit\n - commit --amend: cope with missing display name\n\n* rs/diff-no-minimal (2010-05-02) 1 commit\n - git diff too slow for a file\n\n* ab/test-cleanup (2010-05-07) 2 commits\n - Turn setup code in t2007-checkout-symlink.sh into a test\n - Move t6000lib.sh to lib-*\n\n* by/blame-doc-m-c (2010-05-06) 1 commit\n - blame-options.txt: Add default value for `-M/-C` options.\n\n* by/log-follow (2010-05-06) 3 commits\n - Make git log --follow find copies among unmodified files.\n - Make diffcore_std only can run once before a diff_flush\n - Add a macro DIFF_QUEUE_CLEAR.\n\n* eb/crlf (2010-05-07) 3 commits\n - Add per-repository eol normalization\n - Add tests for per-repository eol normalization\n - Add \"auto-eol\" attribute and \"core.eolStyle\" config variable\n\n* jn/notes-doc (2010-05-03) 4 commits\n - Documentation/notes: nitpicks\n - Documentation/notes: describe content of notes\n - Documentation/notes: adjust description to use configuration section\n - Documentation/notes: describe effect of environment and configuration\n\n* mg/advice-statushints (2010-04-22) 2 commits\n - wt-status: take advice.statusHints seriously\n - t7508: test advice.statusHints\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* jc/doc-submit-gmail (2010-04-07) 1 commit\n  (merged to 'next' on 2010-04-10 at cd4e8cf)\n + SubmittingPatches: update GMail section\n\n* jg/auto-initialize-notes-with-percent-n-in-format (2010-04-13) 1 commit\n + pretty: Initialize notes if %N is used\n\n* jk/maint-diffstat-overflow (2010-04-17) 1 commit\n + diff: use large integers for diffstat calculations\n\n* rr/remote-helper-doc (2010-04-07) 3 commits\n + Documentation/remote-helpers: Add invocation section\n + Documentation/urls: Rewrite to accomodate <transport>::<address>\n + Documentation/remote-helpers: Rewrite description\n\n* wp/doc-filter-direction (2010-04-17) 1 commit\n + documentation: clarify direction of core.autocrlf\n\nThese were pushed out as part of 1.7.1\n\n--------------------------------------------------\n[Stalled]\n\n* js/rebase-origin-x (2010-02-05) 1 commit\n - [RFC w/o test and incomplete] rebase: add -x option to record original commit name\n\nI retract my objection against the idea of -x; needs polishing before\nmoving forward.\n\n* js/grep-open (2010-05-01) 3 commits\n - grep: do not ignore return value from chdir()\n - grep -O: allow optional argument specifying the pager (or editor)\n - grep: Add the option '--open-files-in-pager'\n (this branch is used by jp/hold-string-list-sanity.)\n\nProbably needs to support --no-index mode as well.\n\n* jp/hold-string-list-sanity (2010-04-06) 9 commits\n . string_list: Fix argument order for string_list_append\n . Merge branch 'sr/remote-helper-export' into HEAD\n . Merge branch 'js/grep-open' into HEAD\n . Merge branch 'sb/fmt-merge-msg' into HEAD\n . string_list: Fix argument order for string_list_lookup\n . string_list: Fix argument order for string_list_insert_at_index\n . string_list: Fix argument order for string_list_insert\n . string_list: Fix argument order for for_each_string_list\n . string_list: Fix argument order for print_string_list\n (this branch uses js/grep-open and sr/remote-helper-export.)\n\nBuilding this on top of slushy codebase is not a very promising endeavor.\nGood thing to do, but it came at a bad time.\n\n--------------------------------------------------\n[Cooking]\n\n* cb/maint-stash-orphaned-file (2010-04-18) 2 commits\n  (merged to 'next' on 2010-05-04 at 38488ba)\n + stash tests: stash can lose data in a file removed from the index\n + stash: Don't overwrite files that have gone from the index\n\n(was in 'next' on 2010-04-22)\n\n* jn/maint-bundle (2010-04-19) 2 commits\n  (merged to 'next' on 2010-05-04 at f2086f5)\n + fix \"bundle --stdin\" segfault\n + t5704 (bundle): add tests for bundle --stdin\n\n(was in 'next' on 2010-04-22)\n\n* pb/patch-id-plus (2010-04-19) 2 commits\n  (merged to 'next' on 2010-05-04 at 59881b8)\n + patch-id: Add support for mbox format\n + patch-id: extract parsing one diff out of generate_id_list\n\n(was in 'next' on 2010-04-22)\n\n* rr/doc-submitting (2010-04-19) 1 commit\n  (merged to 'next' on 2010-05-04 at 5f040bd)\n + SubmittingPatches: Add new section about what to base work on\n\n(was in 'next' on 2010-04-22)\n\n* st/remote-tags-no-tags (2010-04-20) 2 commits\n - remote add: add a --[no-]tags option\n - Honor \"tagopt = --tags\" configuration option\n\n* jc/rev-list-ancestry-path (2010-04-20) 1 commit\n - revision: --ancestry-path\n\nJust an illustration patch.  merge simplification logic used when\npathspecs are in effect interacts with this rather badly.\n\n* cb/assume-unchanged-fix (2010-05-01) 2 commits\n - Documentation: git-add does not update files marked \"assume unchanged\"\n - do not overwrite files marked \"assume unchanged\"\n\n* jn/fsck-ident (2010-04-24) 1 commit\n - fsck: check ident lines in commit objects\n\nThere also was a companion patch to fast-import to deal with foreign SCM\ninterface that may not have human-readable author identifier.\n\n* jn/gitweb-caching-prep (2010-04-24) 5 commits\n - gitweb: Move generating page title to separate subroutine\n - gitweb: Add custom error handler using die_error\n - gitweb: Use nonlocal jump instead of 'exit' in die_error\n - gitweb: href(..., -path_info => 0|1)\n - Export more test-related variables when running external tests\n\n* jn/gitweb-install (2010-05-01) 2 commits\n - gitweb: Create install target for gitweb in Makefile\n - gitweb: Improve installation instructions in gitweb/INSTALL\n\n* jn/gitweb-our-squelch (2010-04-30) 1 commit\n - gitweb: Silence 'Variable VAR may be unavailable' warnings\n\n* jn/maint-request-pull (2010-05-07) 3 commits\n - t5150: protect backslash with backslash in shell\n - request-pull: protect against OPTIONS_KEEPDASHDASH from environment\n - tests for request-pull\n (this branch is used by jn/request-pull.)\n\n* jn/request-pull (2010-04-24) 2 commits\n - adapt request-pull tests for new pull request format\n - Merge branch 'jn/maint-request-pull' into jn/request-pull\n (this branch uses jn/maint-request-pull.)\n\n* jn/shortlog (2010-05-03) 5 commits\n - pretty: Respect --abbrev option\n - shortlog: Document and test --format option\n - t4201 (shortlog): Test output format with multiple authors\n - t4201 (shortlog): guard setup with test_expect_success\n - Documentation/shortlog: scripted users should not rely on implicit HEAD\n\n* wp/pretty-enhancement (2010-05-02) 3 commits\n - pretty: add aliases for pretty formats\n - pretty: add infrastructure for commit format aliases\n - pretty: make it easier to add new formats\n\n* jn/t7006-fixup (2010-04-14) 1 commit\n  (merged to 'next' on 2010-05-04 at 490ab5d)\n + t7006: guard cleanup with test_expect_success\n\n(was in 'next' on 2010-04-22)\n\n* js/maint-receive-pack-symref-alias (2010-04-19) 3 commits\n  (merged to 'next' on 2010-05-04 at 259f4f1)\n + t5516-fetch-push.sh: style cleanup\n + receive-pack: detect aliased updates which can occur with symrefs\n + receive-pack: switch global variable 'commands' to a parameter\n\n(was in 'next' on 2010-04-22)\n\n* sp/maint-dumb-http-pack-reidx (2010-04-19) 12 commits\n  (merged to 'next' on 2010-05-04 at 166443a)\n + http.c::new_http_pack_request: do away with the temp variable filename\n + http-fetch: Use temporary files for pack-*.idx until verified\n + http-fetch: Use index-pack rather than verify-pack to check packs\n + Allow parse_pack_index on temporary files\n + Extract verify_pack_index for reuse from verify_pack\n + Introduce close_pack_index to permit replacement\n + http.c: Remove unnecessary strdup of sha1_to_hex result\n + http.c: Don't store destination name in request structures\n + http.c: Drop useless != NULL test in finish_http_pack_request\n + http.c: Tiny refactoring of finish_http_pack_request\n + t5550-http-fetch: Use subshell for repository operations\n + http.c: Remove bad free of static block\n\n(was in 'next' on 2010-04-22)\n\n* hg/id-munging (2010-04-06) 2 commits\n - convert: Keep foreign $Id$ on checkout.\n - convert: Safer handling of $Id$ contraction.\n\n* jn/submodule-basic-test (2010-04-10) 3 commits\n  (merged to 'next' on 2010-05-04 at 0bec27a)\n + t7400: clarify submodule update tests\n + t7400: clarify 'submodule add' tests\n + t7400: split setup into multiple tests\n\n(was in 'next' on 2010-04-22)\n\n* np/index-pack-memsave (2010-04-12) 3 commits\n  (merged to 'next' on 2010-05-04 at 366b014)\n + index-pack: smarter memory usage when appending objects\n + index-pack: rationalize unpack_entry_data()\n + index-pack: smarter memory usage when resolving deltas\n\n(was in 'next' on 2010-04-22)\n\n* jc/am-3-show-corrupted-patch (2010-04-09) 1 commit\n  (merged to 'next' on 2010-05-04 at 951f0e6)\n + am -3: recover the diagnostic messages for corrupt patches\n\n(was in 'next' on 2010-04-22)\n\n* jc/maint-no-reflog-expire-unreach-for-head (2010-04-09) 3 commits\n  (merged to 'next' on 2010-05-04 at d23a180)\n + reflog --expire-unreachable: special case entries in \"HEAD\" reflog\n + more war on \"sleep\" in tests\n + Document gc.<pattern>.reflogexpire variables\n (this branch uses jc/maint-reflog-expire-unreachable.)\n\n(was in 'next' on 2010-04-22)\n\n* cw/maint-exec-defpath (2010-04-15) 2 commits\n  (merged to 'next' on 2010-05-04 at 8d1591f)\n + autoconf: Check if <paths.h> exists and set HAVE_PATHS_H\n + exec_cmd.c: replace hard-coded path list with one from <paths.h>\n\n(was in 'next' on 2010-04-22)\n\n* tr/word-diff (2010-04-14) 1 commit\n  (merged to 'next' on 2010-05-04 at d191b25)\n + diff: add --word-diff option that generalizes --color-words\n\n(was in 'next' on 2010-04-22)\nThere are gitk patches that go with this series.\n\n* sp/maint-describe-tiebreak-with-tagger-date (2010-04-12) 5 commits\n  (merged to 'next' on 2010-05-04 at af2d605)\n + describe: Break annotated tag ties by tagger date\n + tag.c: Parse tagger date (if present)\n + tag.c: Refactor parse_tag_buffer to be saner to program\n + tag.h: Remove unused signature field\n + tag.c: Correct indentation\n\n(was in 'next' on 2010-04-22)\n\n* bg/apply-blank-trailing-context (2010-04-08) 1 commit\n  (merged to 'next' on 2010-05-04 at 31f3482)\n + apply: Allow blank *trailing* context lines to match beyond EOF\n\n(was in 'next' on 2010-04-14)\n\n* bg/send-email-smtpdomain (2010-04-10) 4 commits\n  (merged to 'next' on 2010-05-04 at 2afbe2c)\n + send-email: Cleanup smtp-domain and add config\n + Document send-email --smtp-domain\n + send-email: Don't use FQDNs without a '.'\n + send-email: Cleanup { style\n\n(was in 'next' on 2010-04-14)\n\n* rc/ls-remote-default (2010-04-09) 1 commit\n  (merged to 'next' on 2010-05-04 at 2af33e1)\n + ls-remote: fall-back to default remotes when no remote specified\n\n(was in 'next' on 2010-04-14)\n\n* rc/maint-curl-helper (2010-04-08) 3 commits\n  (merged to 'next' on 2010-05-04 at c32988d)\n + remote-curl: ensure that URLs have a trailing slash\n + http: make end_url_with_slash() public\n + t5541-http-push: add test for URLs with trailing slash\n\n(was in 'next' on 2010-04-14)\n\n* hg/maint-attr-fix (2010-04-06) 3 commits\n  (merged to 'next' on 2010-05-04 at 8b98845)\n + attr: Expand macros immediately when encountered.\n + attr: Allow multiple changes to an attribute on the same line.\n + attr: Fixed debug output for macro expansion.\n\n(was in 'next' on 2010-04-14)\n\n* jc/status-show-ignored (2010-05-01) 6 commits\n  (merged to 'next' on 2010-05-04 at 8b32120)\n + wt-status: fix 'fprintf' compilation warning\n + status: --ignored option shows ignored files\n + wt-status: rename and restructure status-print-untracked\n + wt-status: collect ignored files\n + wt-status: plug memory leak while collecting untracked files\n + wt-status: remove unused workdir_untracked member\n\n(was in 'next' on 2010-05-01)\n\nI am negative about conflating the JSON output to the mix at this point.\nLet's stabilize \"status\" with the existing --porcelain/-z option first.\n\n* eb/unpretty-b-format (2010-03-24) 1 commit\n  (merged to 'next' on 2010-05-04 at a466ed8)\n + Add `%B' in format strings for raw commit body in `git log' and friends\n\n(was in 'next' on 2010-04-07)\n\n* ab/commit-empty-message (2010-04-06) 1 commit\n  (merged to 'next' on 2010-05-04 at 54c2e47)\n + Add option to git-commit to allow empty log messages\n\n(was in 'next' on 2010-04-07)\n\n* jc/test-sleepless (2010-04-06) 1 commit\n  (merged to 'next' on 2010-05-04 at 9ff84b0)\n + war on \"sleep\" in tests\n\n(was in 'next' on 2010-04-07)\n\n* jc/maint-reflog-expire-unreachable (2010-04-07) 1 commit\n  (merged to 'next' on 2010-05-04 at 4efe837)\n + reflog --expire-unreachable: avoid merge-base computation\n (this branch is used by jc/maint-no-reflog-expire-unreach-for-head.)\n\n(was in 'next' on 2010-04-22)\n\n* np/malloc-threading (2010-04-08) 2 commits\n  (merged to 'next' on 2010-05-04 at 1b0567f)\n + Thread-safe xmalloc and xrealloc needs a recursive mutex\n + Make xmalloc and xrealloc thread-safe\n\n(was in 'next' on 2010-04-10)\n\nThe fix should eventually go to 'maint' and 'master'.\n\n* js/async-thread (2010-03-09) 7 commits\n - Enable threaded async procedures whenever pthreads is available\n  (merged to 'next' on 2010-05-04 at 2644e74)\n + Dying in an async procedure should only exit the thread, not the process.\n + Reimplement async procedures using pthreads\n + Windows: more pthreads functions\n + Fix signature of fcntl() compatibility dummy\n + Make report() from usage.c public as vreportf() and use it.\n + Modernize t5530-upload-pack-error.\n\n(all except for the tip was in 'next' on 2010-03-20).\n\n* sd/log-decorate (2010-04-08) 6 commits\n  (merged to 'next' on 2010-05-04 at 6e54ae9)\n + log.decorate: only ignore it under \"log --pretty=raw\"\n + script with rev-list instead of log\n + log --pretty/--oneline: ignore log.decorate\n + log.decorate: usability fixes\n + Add `log.decorate' configuration variable.\n + git_config_maybe_bool()\n\n(was in 'next' on 2010-04-08)\n\n* mh/status-optionally-refresh (2010-04-03) 3 commits\n  (merged to 'next' on 2010-05-04 at be164f0)\n + t7508: add a test for \"git status\" in a read-only repository\n + git status: refresh the index if possible\n + t7508: add test for \"git status\" refreshing the index\n\n(was in 'next' on 2010-04-05)\n\n* cw/ws-indent-with-tab (2010-04-03) 6 commits\n  (merged to 'next' on 2010-05-04 at 1d7aca4)\n + whitespace: tests for git-apply --whitespace=fix with tab-in-indent\n + whitespace: add tab-in-indent support for --whitespace=fix\n + whitespace: replumb ws_fix_copy to take a strbuf *dst instead of char *dst\n + whitespace: tests for git-diff --check with tab-in-indent error class\n + whitespace: add tab-in-indent error class\n + whitespace: we cannot \"catch all errors known to git\" anymore\n\n(was in 'next' on 2010-04-05)\n\n* sr/remote-helper-export (2010-04-12) 9 commits\n  (merged to 'next' on 2010-05-04 at 519ab16)\n + t5800: testgit helper requires Python support\n + Makefile: Simplify handling of python scripts\n + remote-helpers: add tests for testgit helper\n + remote-helpers: add testgit helper\n + remote-helpers: add support for an export command\n + remote-helpers: allow requesing the path to the .git directory\n + fast-import: always create marks_file directories\n + clone: also configure url for bare clones\n + clone: pass the remote name to remote_get\n (this branch is used by jp/hold-string-list-sanity.)\n\n(was in 'next' on 2010-04-12)\n\n* cc/revert-strategy (2010-03-31) 5 commits\n  (merged to 'next' on 2010-05-04 at 6d44a83)\n + revert: add \"--strategy\" option to choose merge strategy\n + merge: make function try_merge_command non static\n + merge: refactor code that calls \"git merge-STRATEGY\"\n + revert: refactor merge recursive code into its own function\n + revert: use strbuf to refactor the code that writes the merge message\n\n(was in 'next' on 2010-04-05)\n\n* sc/http-late-auth (2010-04-01) 1 commit\n  (merged to 'next' on 2010-05-04 at 23ae2e8)\n + Prompt for a username when an HTTP request 401s\n\n(was in 'next' on 2010-04-02)\n\n* jk/cached-textconv (2010-04-01) 5 commits\n  (merged to 'next' on 2010-05-04 at e4b72a0)\n + diff: avoid useless filespec population\n + diff: cache textconv output\n + textconv: refactor calls to run_textconv\n + introduce notes-cache interface\n + make commit_tree a library function\n\n(was in 'next' on 2010-04-02)\n\n* ld/discovery-limit-to-fs (2010-04-04) 6 commits\n - write-index: check and warn when worktree crosses a filesystem boundary\n  (merged to 'next' on 2010-05-04 at b7118ad)\n + Rename ONE_FILESYSTEM to DISCOVERY_ACROSS_FILESYSTEM\n + GIT_ONE_FILESYSTEM: flip the default to stop at filesystem boundaries\n + Add support for GIT_ONE_FILESYSTEM\n + truncate cwd string before printing error message\n + config.c: remove static keyword from git_env_bool()\n\n(all except for the tip was in 'next' on 2010-04-07)\n\nThe tip one is a bit iffy.\n\n* pc/remove-warn (2010-03-26) 4 commits\n  (merged to 'next' on 2010-05-04 at c79c1e6)\n + Remove a redundant errno test in a usage of remove_path\n + Introduce remove_or_warn function\n + Implement the rmdir_or_warn function\n + Generalise the unlink_or_warn function\n\n(was in 'next' on 2010-04-02)\n\n* em/checkout-orphan (2010-03-21) 1 commit\n  (merged to 'next' on 2010-05-04 at ddb45fc)\n + git checkout: create unparented branch by --orphan\n\n(was in 'next' on 2010-03-28)\n\nPerhaps needs a bit of documentation updates, describing the \"going open\nsource\" scenario.\n\n* ar/config-from-command-line (2010-03-26) 2 commits\n  (merged to 'next' on 2010-05-04 at 2962717)\n + Use strbufs instead of open-coded string manipulation\n + Allow passing of configuration parameters in the command line\n\n(was in 'next' on 2010-04-07)\n"}]}