{"thread":{"id":"23417","subject":"What's cooking in git.git (Apr 2010, #04; Sat, 10)","startedAt":"2010-04-11T03:55:13Z","lastAt":"2010-04-11T20:27:36Z","messageCount":2,"participants":["Junio C Hamano","Johannes Sixt"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"139232","messageId":"7vr5mmr6ce.fsf@alter.siamese.dyndns.org","threadId":"23417","inReplyTo":null,"subject":"What's cooking in git.git (Apr 2010, #04; Sat, 10)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-04-11T03:55:13Z","receivedAt":"2010-04-11T03:55:13Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.  The ones\nmarked with '.' do not appear in any of the integration branches, but I am\nstill holding onto them.\n\nWe are at 1.7.1-rc1; please test 'master', report & fix regressions.\nHopefully we can do another rc during the next week and release the final\none next weekend.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* mr/gitweb-jsmin (2010-04-02) 6 commits\n  (merged to 'next' on 2010-04-05 at 5ad036c)\n + gitweb: update INSTALL to use shorter make target\n + gitweb: add documentation to INSTALL regarding gitweb.js\n + instaweb: add minification awareness\n + Gitweb: add autoconfigure support for minifiers\n + Gitweb: add support for minifying gitweb.css\n + Gitweb: add ignore and clean rules for minified files\n\n--------------------------------------------------\n[New Topics]\n\n* bg/apply-blank-trailing-context (2010-04-08) 1 commit\n - apply: Allow blank *trailing* context lines to match beyond EOF\n\nLooked Ok; soon in 'next'\n\n* bg/send-email-smtpdomain (2010-04-10) 4 commits\n - send-email: Cleanup smtp-domain and add config\n - Document send-email --smtp-domain\n - send-email: Don't use FQDNs without a '.'\n - send-email: Cleanup { style\n\nLooked Ok; soon in 'next'\n\n* rc/ls-remote-default (2010-04-09) 1 commit\n - ls-remote: fall-back to default remotes when no remote specified\n\nLooked Ok; soon in 'next'\n\n* rc/maint-curl-helper (2010-04-08) 3 commits\n - remote-curl: ensure that URLs have a trailing slash\n - http: make end_url_with_slash() public\n - t5541-http-push: add test for URLs with trailing slash\n\nLooked Ok; soon in 'next'\n\n* jc/status-show-ignored (2010-04-10) 5 commits\n - status: --ignored option shows ignored files\n - wt-status: rename and restructure status-print-untracked\n - wt-status: collect ignored files\n - wt-status: plug memory leak while collecting untracked files\n - wt-status: remove unused workdir_untracked member\n\nThis is merely an illustration patch.  I am negative about conflating the\nJSON output to the mix at this point.  If we are going to add JSON option\nto everywhere we would generate \"machine readable\" output with the -z\nand/or --porcelain options, that is fine, but let's stabilize \"status\"\nwith the existing --porcelain/-z option first.\n\n* hg/maint-attr-fix (2010-04-06) 3 commits\n - attr: Expand macros immediately when encountered.\n - attr: Allow multiple changes to an attribute on the same line.\n - attr: Fixed debug output for macro expansion.\n\n* jc/am-3-show-corrupted-patch (2010-04-09) 1 commit\n . wip\n\n* jc/maint-no-reflog-expire-unreach-for-head (2010-04-09) 1 commit\n . WIP: no reflog expireunreachable for HEAD\n (this branch uses jc/maint-reflog-expire-unreachable.)\n\n* sp/maint-describe-tiebreak-with-tagger-date (2010-04-10) 1 commit\n - describe: Break annotated tag ties by tagger date\n\n--------------------------------------------------\n[Stalled]\n\n* js/rebase-origin-x (2010-02-05) 1 commit\n - [RFC w/o test and incomplete] rebase: add -x option to record original commit name\n\nI retract my objection against the idea of -x; needs polishing before\nmoving forward.\n\n* js/grep-open (2010-03-26) 2 commits\n - grep -O: allow optional argument specifying the pager (or editor)\n - grep: Add the option '--open-files-in-pager'\n (this branch is used by jp/hold-sring-list-sanity.)\n\nProbably needs to support --no-index mode as well.\n\n* tr/word-diff (2010-04-04) 2 commits\n - gitk: add the equivalent of diff --color-words\n - diff: add --word-diff option that generalizes --color-words\n\n* jp/hold-sring-list-sanity (2010-04-06) 6 commits\n . string_list: Fix argument order for string_list_append\n . string_list: Fix argument order for string_list_lookup\n . string_list: Fix argument order for string_list_insert_at_index\n . string_list: Fix argument order for string_list_insert\n . string_list: Fix argument order for for_each_string_list\n . string_list: Fix argument order for print_string_list\n (this branch uses js/grep-open and early parts of sr/remote-helper-export.)\n\nBuilding this on top of slushy codebase is not a very promising endeavor.\nGood thing to do, but bad timing.\n\n--------------------------------------------------\n[Cooking]\n\n* ne/rev-cache (2010-04-05) 7 commits\n - graft awareness\n - object name support\n - integration into revision walker\n - administrative api and tools\n - support for non-commit objects\n - basic api and porcelain\n - man page and technical docs\n\nFor some reason this was extremely hard to read, partly because it had too\nmany distracting style violations and too many long lines.\n\n* eb/unpretty-b-format (2010-03-24) 1 commit\n  (merged to 'next' on 2010-04-07 at 7f5c112)\n + Add `%B' in format strings for raw commit body in `git log' and friends\n\n* ab/commit-empty-message (2010-04-06) 1 commit\n  (merged to 'next' on 2010-04-07 at 701e863)\n + Add option to git-commit to allow empty log messages\n\n* jc/test-sleepless (2010-04-06) 1 commit\n  (merged to 'next' on 2010-04-07 at 8ccf40a)\n + war on \"sleep\" in tests\n\n* jc/maint-reflog-expire-unreachable (2010-04-07) 1 commit\n - reflog --expire-unreachable: avoid merge-base computation\n (this branch is used by jc/maint-no-reflog-expire-unreach-for-head.)\n\n* jc/doc-submit-gmail (2010-04-07) 1 commit\n  (merged to 'next' on 2010-04-10 at cd4e8cf)\n + SubmittingPatches: update GMail section\n\n* np/malloc-threading (2010-04-08) 2 commits\n  (merged to 'next' on 2010-04-10 at e1730fb)\n + Thread-safe xmalloc and xrealloc needs a recursive mutex\n + Make xmalloc and xrealloc thread-safe\n\nThe fix should eventually go to 'maint' and 'master'.  This queues the one\nfrom J6t for Windows compatibility.\n\n* js/async-thread (2010-03-09) 7 commits\n - Enable threaded async procedures whenever pthreads is available\n  (merged to 'next' on 2010-03-20 at 9939243)\n + Dying in an async procedure should only exit the thread, not the process.\n + Reimplement async procedures using pthreads\n + Windows: more pthreads functions\n + Fix signature of fcntl() compatibility dummy\n + Make report() from usage.c public as vreportf() and use it.\n + Modernize t5530-upload-pack-error.\n\nBeen waiting for resolution of locking issues in malloc-threading.\n\n* sd/log-decorate (2010-04-08) 6 commits\n  (merged to 'next' on 2010-04-08 at 68fee56)\n + log.decorate: only ignore it under \"log --pretty=raw\"\n + script with rev-list instead of log\n  (merged to 'next' on 2010-04-06 at 992c9ad)\n + log --pretty/--oneline: ignore log.decorate\n  (merged to 'next' on 2010-03-08 at 58a6fba)\n + log.decorate: usability fixes\n + Add `log.decorate' configuration variable.\n + git_config_maybe_bool()\n\n* mh/status-optionally-refresh (2010-04-03) 3 commits\n  (merged to 'next' on 2010-04-05 at 0e64aac)\n + t7508: add a test for \"git status\" in a read-only repository\n + git status: refresh the index if possible\n + t7508: add test for \"git status\" refreshing the index\n\n* cw/ws-indent-with-tab (2010-04-03) 6 commits\n  (merged to 'next' on 2010-04-05 at 5b5e579)\n + whitespace: tests for git-apply --whitespace=fix with tab-in-indent\n + whitespace: add tab-in-indent support for --whitespace=fix\n + whitespace: replumb ws_fix_copy to take a strbuf *dst instead of char *dst\n + whitespace: tests for git-diff --check with tab-in-indent error class\n + whitespace: add tab-in-indent error class\n + whitespace: we cannot \"catch all errors known to git\" anymore\n\n* rr/remote-helper-doc (2010-04-07) 3 commits\n - Documentation/remote-helpers: Add invocation section\n - Documentation/urls: Rewrite to accomodate <transport>::<address>\n - Documentation/remote-helpers: Rewrite description\n\nI'd like acks or rewrites from transport people on this topic.\n\n* sr/remote-helper-export (2010-04-09) 8 commits\n  (merged to 'next' on 2010-04-09 at 94f6e3d)\n + Makefile: Simplify handling of python scripts\n  (merged to 'next' on 2010-04-07 at 5651307)\n + remote-helpers: add tests for testgit helper\n + remote-helpers: add testgit helper\n + remote-helpers: add support for an export command\n + remote-helpers: allow requesing the path to the .git directory\n + fast-import: always create marks_file directories\n + clone: also configure url for bare clones\n + clone: pass the remote name to remote_get\n (this branch shares commits with jp/hold-sring-list-sanity.)\n\n* cc/revert-strategy (2010-03-31) 5 commits\n  (merged to 'next' on 2010-04-05 at 50909c1)\n + revert: add \"--strategy\" option to choose merge strategy\n + merge: make function try_merge_command non static\n + merge: refactor code that calls \"git merge-STRATEGY\"\n + revert: refactor merge recursive code into its own function\n + revert: use strbuf to refactor the code that writes the merge message\n\nThis is more about debugging and we are not in a great hurry.\n\n* sc/http-late-auth (2010-04-01) 1 commit\n  (merged to 'next' on 2010-04-02 at c991acf)\n + Prompt for a username when an HTTP request 401s\n\n* jk/cached-textconv (2010-04-01) 5 commits\n  (merged to 'next' on 2010-04-02 at a023e3c)\n + diff: avoid useless filespec population\n + diff: cache textconv output\n + textconv: refactor calls to run_textconv\n + introduce notes-cache interface\n + make commit_tree a library function\n\nThe small leak fixes in the beginning of the series has been merged to\n'master' after a minor fixup.\n\n* ld/discovery-limit-to-fs (2010-04-04) 6 commits\n - write-index: check and warn when worktree crosses a filesystem boundary\n  (merged to 'next' on 2010-04-07 at 11ea09a)\n + Rename ONE_FILESYSTEM to DISCOVERY_ACROSS_FILESYSTEM\n + GIT_ONE_FILESYSTEM: flip the default to stop at filesystem boundaries\n + Add support for GIT_ONE_FILESYSTEM\n + truncate cwd string before printing error message\n + config.c: remove static keyword from git_env_bool()\n\nThe tip one is a bit iffy; the whole series changes behaviour in a corner\ncase, and is not a 1.7.1 material.\n\n* pc/remove-warn (2010-03-26) 4 commits\n  (merged to 'next' on 2010-04-02 at 52fc00d)\n + Remove a redundant errno test in a usage of remove_path\n + Introduce remove_or_warn function\n + Implement the rmdir_or_warn function\n + Generalise the unlink_or_warn function\n\nI cherry-picked only obviously sensible bits.\n\n* em/checkout-orphan (2010-03-21) 1 commit\n  (merged to 'next' on 2010-03-28 at 86b6a4f)\n + git checkout: create unparented branch by --orphan\n\nPerhaps needs a bit of documentation updates, describing the \"going open\nsource\" scenario.\n\n* ar/config-from-command-line (2010-03-26) 2 commits\n  (merged to 'next' on 2010-04-07 at e50fd3a)\n + Use strbufs instead of open-coded string manipulation\n + Allow passing of configuration parameters in the command line\n\n* nd/setup (2010-04-05) 43 commits\n - builtins: do not commit pager choice early\n - builtins: setup repository before print unknown command error\n - t0001: Add test cases for \"git init\" with aliases\n - Guard unallowed access to repository when it's not set up\n - alias: keep repository found while collecting aliases as long as possible\n - Allow to undo setup_git_directory_gently() gracefully (and fix alias code)\n - builtins: check for startup_info->help, print and exit early\n - builtins: utilize startup_info->help where possible\n - run_builtin(): save \"-h\" detection result for later use\n - config: do not read .git/config if there is no repository\n - apply: do not check sha1 if there is no repository\n - Do not read .git/info/attributes if there is no repository\n - Do not read .git/info/exclude if there is no repository\n - git_config(): do not read .git/config if there is no repository\n - init/clone: turn on startup->have_repository properly\n - worktree setup: restore original state when things go wrong\n - Use git_config_early() instead of git_config() during repo setup\n - Add git_config_early()\n - worktree setup: call set_git_dir explicitly\n - rev-parse --git-dir: print relative gitdir correctly\n - enter_repo(): initialize other variables as setup_git_directory_gently() does\n - Move enter_repo() to setup.c\n - index-pack: use RUN_SETUP_GENTLY\n - index-pack: trust the prefix returned by setup_git_directory_gently()\n - worktree setup: calculate prefix even if no worktree is found\n - merge-file: use RUN_SETUP_GENTLY\n - var: use RUN_SETUP_GENTLY\n - ls-remote: use RUN_SETUP_GENTLY\n - help: take note why this command is not applicable for RUN_SETUP_GENTLY\n - diff: use RUN_SETUP_GENTLY\n - bundle: use RUN_SETUP_GENTLY\n - apply: use RUN_SETUP_GENTLY\n - verify-pack: use RUN_SETUP_GENTLY\n - check-ref-format: use RUN_SETUP_GENTLY\n - mailinfo: use RUN_SETUP_GENTLY\n - archive: use RUN_SETUP_GENTLY\n - builtin: USE_PAGER should not be used without RUN_SETUP*\n - grep: use RUN_SETUP_GENTLY\n - shortlog: use RUN_SETUP_GENTLY\n - hash-object: use RUN_SETUP_GENTLY\n - config: use RUN_SETUP_GENTLY\n - builtin: Support RUN_SETUP_GENTLY to set up repository early if found\n - builtin: introduce startup_info struct\n\nRerolled.  I need to look at this series during the feature freeze so that\nwe can decide to (or not to) include it in 'next' early in post 1.7.1 cycle.\n"},{"id":"139282","messageId":"4BC230B8.4000608@kdbg.org","threadId":"23417","inReplyTo":"7vr5mmr6ce.fsf@alter.siamese.dyndns.org","subject":"Re: What's cooking in git.git (Apr 2010, #04; Sat, 10)","fromName":"Johannes Sixt","fromEmail":"j6t@kdbg.org","sentAt":"2010-04-11T20:27:36Z","receivedAt":"2010-04-11T20:27:36Z","isPatch":false,"sender":{"key":"j6t@kdbg.org","avatar":"https://avatars.githubusercontent.com/u/14810926?v=4"},"body":"Am 11.04.2010 05:55, schrieb Junio C Hamano:\n> * ld/discovery-limit-to-fs (2010-04-04) 6 commits\n>   - write-index: check and warn when worktree crosses a filesystem boundary\n>    (merged to 'next' on 2010-04-07 at 11ea09a)\n>   + Rename ONE_FILESYSTEM to DISCOVERY_ACROSS_FILESYSTEM\n>   + GIT_ONE_FILESYSTEM: flip the default to stop at filesystem boundaries\n>   + Add support for GIT_ONE_FILESYSTEM\n>   + truncate cwd string before printing error message\n>   + config.c: remove static keyword from git_env_bool()\n>\n> The tip one is a bit iffy; the whole series changes behaviour in a corner\n> case, and is not a 1.7.1 material.\n\nI do see the warning on Windows even though I shouldn't because we always \nset st_dev and st_rdev to zero. There's something iffy. Will investigate.\n\n-- Hannes\n"}]}