{"thread":{"id":"23223","subject":"What's cooking in git.git (Mar 2010, #07; Sun, 28)","startedAt":"2010-03-29T04:48:56Z","lastAt":"2010-03-29T04:48:56Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"138050","messageId":"7viq8fg2br.fsf@alter.siamese.dyndns.org","threadId":"23223","inReplyTo":null,"subject":"What's cooking in git.git (Mar 2010, #07; Sun, 28)","fromName":"Junio C Hamano","fromEmail":"junio@pobox.com","sentAt":"2010-03-29T04:48:56Z","receivedAt":"2010-03-29T04:48:56Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.  The ones\nmarked with '.' do not appear in any of the integration branches, but I am\nstill holding onto them.\n\nAs it has been about 6 weeks since the previous feature release, I'd want\nto start making noises about feature freeze for 1.7.1 in a few days.  I\nexpect that the changes still under discussion will be ready by the time\nthe post 1.7.1 cycle begins, and we will hopefully have a cycle for 1.7.2\nthat is shorter than usual to include them.\n\n--------------------------------------------------\n[New Topics]\n\n* da/maint-python-startup (2010-03-27) 1 commit\n - Makefile: Remove usage of deprecated Python \"has_key\" method\n\nAnother thing that this fixes is not described in the log message.\n\n* jc/conflict-marker-size (2010-03-24) 1 commit\n - diff --check: honor conflict-marker-size attribute\n\n* ld/discovery-limit-to-fs (2010-03-17) 3 commits\n - Add support for GIT_ONE_FILESYSTEM\n - truncate cwd string before printing error message\n - config.c: remove static keyword from git_env_bool()\n\n* sb/fmt-merge-msg (2010-03-24) 7 commits\n - fmt-merge-msg: hide summary option\n - fmt-merge-msg: remove custom string_list implementation\n - string-list: add unsorted_string_list_lookup()\n - fmt-merge-msg: use pretty.c routines\n - t6200: test fmt-merge-msg more\n - t6200: modernize with test_tick\n - fmt-merge-msg: be quiet if nothing to merge\n\n* pc/remove-warn (2010-03-26) 4 commits\n . Remove a redundant errno test in a usage of remove_path\n . Introduce remove_or_warn function\n . Implement the rmdir_or_warn function\n . Generalise the unlink_or_warn function\n\n--------------------------------------------------\n[Stalled]\n\n* cw/test-lib-relicense (2010-02-22) 1 commit\n . test-lib.sh: Add explicit license detail, with change from GPLv2 to GPLv2+.\n\nAck-collection stopped at the last three names.  I am hoping Carl can take\nit from there without my keeping an eye on it.\n\n* js/rebase-origin-x (2010-02-05) 1 commit\n - [RFC w/o test and incomplete] rebase: add -x option to record original commit name\n\nI retract my objection against the idea of -x; needs polishing before\nmoving forward.\n\n* sg/bash-completion (2010-02-23) 4 commits\n  (merged to 'next' on 2010-03-08 at bc59860)\n + bash: completion for gitk aliases\n + bash: support user-supplied completion scripts for aliases\n + bash: support user-supplied completion scripts for user's git commands\n + bash: improve aliased command recognition\n\nPerhaps rename _git_frotz -> _git_complete_frotz?  I dunno.\n\n* sd/log-decorate (2010-02-17) 3 commits\n  (merged to 'next' on 2010-03-08 at 58a6fba)\n + log.decorate: usability fixes\n + Add `log.decorate' configuration variable.\n + git_config_maybe_bool()\n\nNeeds squelching the configuration setting when \"--pretty=raw\" is given,\nat least, or possibly when any \"--pretty\" is explicitly given.\n\n--------------------------------------------------\n[Cooking]\n\n* np/malloc-threading (2010-03-24) 1 commit\n - Make xmalloc and xrealloc thread-safe\n\nStill has locking issues?\n\n* bw/git-completion-rpmspec (2010-03-20) 1 commit\n - Add a git-completion rpm subpackage to the spec\n\nShipping bash-completion as part of RPM package; since Todd Zullinger who\npackages git for Fedora joined the thread, I am hoping that I can defer\nthe direction of the final version to the discussion between Todd and Ben.\n\n* ef/maint-empty-commit-log (2010-03-21) 1 commit\n - rev-list: fix --pretty=oneline with empty message\n\nLooked reasonable.  Soon in 'next'.\n\n* em/checkout-orphan (2010-03-21) 1 commit\n - git checkout: create unparented branch by --orphan\n\nLooked reasonable, except that we might want to come up with a way to\nallow people with core.logallrefupdates set to false to still override it\nwith \"-l\" when switching to this new branch.  Or we may not care.  I dunno.\n\nSoon in 'next'.\n\n* mg/mailmap-update (2010-03-19) 1 commit\n - .mailmap: Entries for Alex Bennée, Deskin Miller, Vitaly \"_Vi\" Shukela\n\nSoon in 'next'.\n\n* mg/maint-send-email-lazy-editor (2010-03-22) 1 commit\n - send-email: lazily assign editor variable\n\nSoon in 'next'.\n\n* mg/use-default-abbrev-length-in-rev-list (2010-03-22) 1 commit\n - rev-list: use default abbrev length when abbrev-commit is in effect\n\nSoon in 'next'.\n\n* rb/maint-python-path (2010-03-21) 1 commit\n - Correct references to /usr/bin/python which does not exist on FreeBSD\n\nSoon in 'next'.\n\n* rr/imap-send-unconfuse-from-line (2010-03-22) 1 commit\n - imap-send: Remove limitation on message body\n\nSoon in 'next'.\n\n* sp/maint-http-backend-die-triggers-die-recursively (2010-03-22) 1 commit\n - http-backend: Don't infinite loop during die()\n\nSoon in 'next'.\n\n* ar/config-from-command-line (2010-03-26) 2 commits\n - Use strbufs instead of open-coded string manipulation\n - Allow passing of configuration parameters in the command line\n\n* bc/t5505-fix (2010-03-19) 3 commits\n - t/t5505-remote.sh: escape * to prevent interpretation by shell as glob\n - t5505: add missing &&\n - t5505: remove unnecessary subshell invocations\n\nLooked reasonable.  Soon in 'next'.\n\n* bw/template-tool-buildconfig (2010-03-20) 2 commits\n - Modernize git calling conventions in hook templates\n - Make templates honour SHELL_PATH and PERL_PATH\n\nLooked reasonable.  Soon in 'next'.\n\n* mb/rebase-i-no-ff (2010-03-24) 1 commit\n - Teach rebase the --no-ff option.\n\nLooked reasonable.  Soon in 'next'.\n\n* jn/merge-diff3-label (2010-03-20) 14 commits\n  (merged to 'next' on 2010-03-20 at 26f1805)\n + merge-recursive: add a label for ancestor\n + cherry-pick, revert: add a label for ancestor\n + revert: clarify label on conflict hunks\n + compat: add mempcpy()\n + checkout -m --conflict=diff3: add a label for ancestor\n + merge_trees(): add ancestor label parameter for diff3-style output\n + merge_file(): add comment explaining behavior wrt conflict style\n + checkout --conflict=diff3: add a label for ancestor\n + ll_merge(): add ancestor label parameter for diff3-style output\n + merge-file --diff3: add a label for ancestor\n + xdl_merge(): move file1 and file2 labels to xmparam structure\n + xdl_merge(): add optional ancestor label to diff3-style output\n + tests: document cherry-pick behavior in face of conflicts\n + tests: document format of conflicts from checkout -m\n\n* do/rebase-i-arbitrary (2010-03-14) 1 commit\n - rebase--interactive: don't require what's rebased to be a branch\n\nLooked reasonable.  Soon in 'next'.\n\n* ja/send-email-ehlo (2010-03-14) 3 commits\n - git-send-email.perl - try to give real name of the calling host to HELO/EHLO\n - git-send-email.perl: add option --smtp-debug\n - git-send-email.perl: improve error message in send_message()\n\nLooked reasonable.  Soon in 'next'.\n\n* ak/everyday-git (2009-10-21) 1 commit\n - everyday: fsck and gc are not everyday operations\n\nLooked reasonable.  Soon in 'next'.\n\n* bc/acl-test (2010-03-15) 5 commits\n - t/t1304: make a second colon optional in the mask ACL check\n - t/t1304: set the ACL effective rights mask\n - t/t1304: use 'test -r' to test readability rather than looking at mode bits\n - t/t1304: set the Default ACL base entries\n - t/t1304: avoid -d option to setfacl\n\nLooked reasonable.  Soon in 'next'.\n\n* bc/maint-daemon-sans-ss-family (2010-03-15) 1 commit\n - daemon.c: avoid accessing ss_family member of struct sockaddr_storage\n\nLooked reasonable.  Soon in 'next'.\n\n* ef/cherry-abbrev (2010-03-20) 2 commits\n - ls: remove redundant logic\n - cherry: support --abbrev option\n\nLooked reasonable.  Soon in 'next'.\n\n* sb/notes-parse-opt (2010-02-27) 1 commit\n  (merged to 'next' on 2010-03-24 at 82eebc1)\n + notes: rework subcommands and parse options\n\nReady for 'master'.\n\n* gh/maint-stash-show-error-message (2010-03-16) 1 commit\n - Improve error messages from 'git stash show'\n\nLooked reasonable.  Soon in 'next'.\n\n* rs/threaded-grep-context (2010-03-15) 1 commit\n - grep: enable threading for context line printing\n\nLooked reasonable.  Soon in 'next'.\n\n* cc/cherry-pick-ff (2010-03-20) 7 commits\n  (merged to 'next' on 2010-03-20 at a1ae16b)\n + revert: fix tiny memory leak in cherry-pick --ff\n + rebase -i: use new --ff cherry-pick option\n  (merged to 'next' on 2010-03-07 at 5589b26)\n + Documentation: describe new cherry-pick --ff option\n + cherry-pick: add tests for new --ff option\n + revert: add --ff option to allow fast forward when cherry-picking\n + builtin/merge: make checkout_fast_forward() non static\n + parse-options: add parse_options_concat() to concat options\n\nReady for 'master'.\n\n* js/async-thread (2010-03-09) 7 commits\n - Enable threaded async procedures whenever pthreads is available\n  (merged to 'next' on 2010-03-20 at 9939243)\n + Dying in an async procedure should only exit the thread, not the process.\n + Reimplement async procedures using pthreads\n + Windows: more pthreads functions\n + Fix signature of fcntl() compatibility dummy\n + Make report() from usage.c public as vreportf() and use it.\n + Modernize t5530-upload-pack-error.\n\nThe tip one will be soon in 'next', but one step at a time.\n\n* nd/setup (2010-03-25) 43 commits\n - builtins: do not commit pager choice early\n - builtins: reset startup_info->have_run_setup_gitdir when unsetting up repository\n - builtins: setup repository before print unknown command error\n - Guard unallowed access to repository when it's not set up\n - alias: keep repository found while collecting aliases as long as possible\n - Allow to undo setup_git_directory_gently() gracefully (and fix alias code)\n - builtins: check for startup_info->help, print and exit early\n - builtins: utilize startup_info->help where possible\n - run_builtin(): save \"-h\" detection result for later use\n - config: do not read .git/config if there is no repository\n - apply: do not check sha1 when repository has not been found\n - Do not read .git/info/attributes if there is no repository\n - Do not read .git/info/exclude if there is no repository\n - git_config(): do not read .git/config if there is no repository\n - init/clone: turn on startup->have_repository properly\n - worktree setup: restore original state when things go wrong\n - Use git_config_early() instead of git_config() during repo setup\n - Add git_config_early()\n - worktree setup: call set_git_dir explicitly\n - rev-parse --git-dir: print relative gitdir correctly\n - enter_repo(): initialize other variables as setup_git_directory_gently() does\n - Move enter_repo() to setup.c\n - index-pack: use RUN_SETUP_GENTLY\n - index-pack: trust the prefix returned by setup_git_directory_gently()\n - worktree setup: calculate prefix even if no worktree is found\n - merge-file: use RUN_SETUP_GENTLY\n - var: use RUN_SETUP_GENTLY\n - ls-remote: use RUN_SETUP_GENTLY\n - help: use RUN_SETUP_GENTLY\n - diff: use RUN_SETUP_GENTLY\n - bundle: use RUN_SETUP_GENTLY\n - apply: use RUN_SETUP_GENTLY\n - verify-pack: use RUN_SETUP_GENTLY\n - check-ref-format: use RUN_SETUP_GENTLY\n - mailinfo: use RUN_SETUP_GENTLY\n - archive: use RUN_SETUP_GENTLY\n - builtin: USE_PAGER should not be used without RUN_SETUP*\n - grep: use RUN_SETUP_GENTLY\n - shortlog: use RUN_SETUP_GENTLY\n - hash-object: use RUN_SETUP_GENTLY\n - config: use RUN_SETUP_GENTLY\n - builtin: Support RUN_SETUP_GENTLY to set up repository early if found\n - builtin: introduce startup_info struct\n"}]}