{"thread":{"id":"22699","subject":"What's cooking in git.git (Feb 2010, #04; Wed, 17)","startedAt":"2010-02-17T21:09:16Z","lastAt":"2010-02-19T14:55:20Z","messageCount":2,"participants":["Junio C Hamano","Nguyen Thai Ngoc Duy"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"134893","messageId":"7veikjefib.fsf@alter.siamese.dyndns.org","threadId":"22699","inReplyTo":null,"subject":"What's cooking in git.git (Feb 2010, #04; Wed, 17)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-02-17T21:09:16Z","receivedAt":"2010-02-17T21:09:16Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.  The ones\nmarked with '.' do not appear in any of the integration branches, but I am\nstill holding onto them.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* jk/cherry-pick-reword (2010-02-11) 5 commits\n  (merged to 'next' on 2010-02-11 at d0eace1)\n + cherry-pick: prettify the advice message\n + cherry-pick: show commit name instead of sha1\n + cherry-pick: format help message as strbuf\n + cherry-pick: refactor commit parsing code\n + cherry-pick: rewrap advice message\n\n* rs/git-dir-cleanup (2010-02-11) 3 commits\n  (merged to 'next' on 2010-02-11 at fa4f83c)\n + Untouch RelNotes 1.7.0: grep --no-index will not be in the release\n  (merged to 'next' on 2010-02-06 at ef8ab9b)\n + Resurrect \"git grep --no-index\"\n + setenv(GIT_DIR) clean-up\n\n* jk/grep-double-dash (2010-02-06) 1 commit\n  (merged to 'next' on 2010-02-07 at 2ac040d)\n + accept \"git grep -- pattern\"\n\n* jc/typo (2010-02-03) 1 commit\n + Typofixes outside documentation area\n\n--------------------------------------------------\n[New Topics]\n\n* dp/maint-1.6.3-hash-sans-mmap (2010-02-14) 1 commit\n - don't use mmap() to hash files\n\nThis was more of an RFC in that slurping a potentially huge file into\nmemory without using mmap() was conceptually wrong. I suspect somebody\nis cooking a patch to hash and compress a large blob in chunks straight\ninto a packfile as a replacement ;-).\n\n* jc/for-each-ref (2010-02-13) 4 commits\n - for-each-ref --format='%(flag)'\n - for-each-ref --format='%(symref) %(symref:short)'\n - builtin-for-each-ref.c: check if we need to peel onion while parsing the format\n - builtin-for-each-ref.c: comment fixes\n\nShould be Ok for 'next'.\n\n* jn/gitweb-config-error-die (2010-02-14) 1 commit\n - gitweb: Die if there are parsing errors in config file\n\nShould be Ok for 'next'.\n\n* jn/maint-fix-pager (2010-02-14) 6 commits\n - tests: Add tests for automatic use of pager\n - am: Fix launching of pager\n - git svn: Fix launching of pager\n - git.1: Clarify the behavior of the --paginate option\n - Make 'git var GIT_PAGER' always print the configured pager\n - Fix 'git var' usage synopsis\n\nShould be Ok for 'next'.\n\n* ml/color-when (2010-02-16) 1 commit\n - Add an optional argument for --color options\n\n* hm/imap-send-cram-md5 (2010-02-15) 1 commit\n - imap-send: support CRAM-MD5 authentication\n\nA potential clean-up sent as a counter-proposal; waiting for response.\n\n* jh/maint-submodule-status-in-void (2010-02-16) 1 commit\n - submodule summary: Don't barf when invoked in an empty repo\n\nLooked Ok for 'next' but I lost track somewhat...\n\n* ld/maint-diff-quiet-w (2010-02-16) 1 commit\n - git diff --quiet -w: check and report the status\n\nNeeds tests but otherwise looked Ok.\n\n* ml/maint-grep-doc (2010-02-15) 1 commit\n  (merged to 'next' on 2010-02-16 at 4059a38)\n + grep documentation: clarify what files match\n\nSoon to graduate to 'master'.\n\n* tc/maint-transport-ls-remote-with-void (2010-02-16) 1 commit\n  (merged to 'next' on 2010-02-16 at e6ef1a8)\n + transport: add got_remote_refs flag\n\nSoon to graduate to 'master'.\n\n* bg/apply-blank-at-eof (2010-02-17) 3 commits\n - t3417: Add test cases for \"rebase --whitespace=fix\"\n - t4124: Add additional tests of --whitespace=fix\n - apply: Allow blank context lines to match beyond EOF\n\nRFC.\n\n* gf/maint-sh-setup-nongit-ok (2010-02-16) 1 commit\n - require_work_tree broken with NONGIT_OK\n\nLooked sensible and ready for 'next'.\n\n* ml/send-pack-transport-refactor (2010-02-16) 1 commit\n - Refactoring: remove duplicated code from builtin-send-pack.c and transport.c\n\nProbably ready for 'next'.\n\n* np/fast-import-idx-v2 (2010-02-17) 6 commits\n - fast-import: use the diff_delta() max_delta_size argument\n - fast-import: honor pack.indexversion and pack.packsizelimit config vars\n - fast-import: make default pack size unlimited\n - fast-import: use write_idx_file() instead of custom code\n - fast-import: use sha1write() for pack data\n - fast-import: start using struct pack_idx_entry\n\n* sd/format-patch-to (2010-02-17) 1 commit\n - Add 'git format-patch --to=' option and 'format.to' configuration variable.\n\nShouldn't be too hard to add tests to t4014; other than that looked ready\nfor 'next'.\n\n* sd/init-template (2010-02-17) 2 commits\n - Add a \"TEMPLATE DIRECTORY\" section to git-init[1].\n - Add `init.templatedir` configuration variable.\n\nShouldn't be too hard to add tests to t0001; other than that looked ready\nfor 'next'.\n\n* sd/log-decorate (2010-02-17) 3 commits\n - log.decorate: usability fixes\n - Add `log.decorate' configuration variable.\n - git_config_maybe_bool()\n\nProbably ready for 'next', except that people need to be warned about\nhaving to update their scripts to explicitly pass --no-decorate to keep\nthem working.\n\n* jc/maint-status-preload (2010-02-17) 1 commit\n - status: preload index to optimize lstat(2) calls\n\n--------------------------------------------------\n[Cooking]\n\n* ld/push-porcelain (2010-02-09) 4 commits\n - git-push: fix an error message so it goes to stderr\n - git-push: make git push --dry-run --porcelain exit with status 0 even if updates will be rejected\n - git-push: send \"To <remoteurl>\" messages to the standard output in --porcelain mode\n - git-push: squelch advice message if in --porcelain mode\n\nAfter some discussion this needs further simplification?  May need to move\nto Stalled.\n\n* cp/add-u-pathspec (2010-02-09) 2 commits\n - test for add with non-existent pathspec\n - git add -u: die on unmatched pathspec\n\nI am a bit torn on this one.  Traditionally we never complained on\nunmatched pathspec when talking about tracked files.  If we were to go\nthis route, I think we should probably enhance the \"run_diff_files\" and\nfriends in such a way that they mark matched pathspecs, in a way similar\nto match_pathspec() in dir.c does, and report unmatched ones based on\nthat result, instead of adding an extra pass to scan the index.  The same\ngoes for pathspec_matches() in builtin-grep.c\n\nIncidentally, I've proposed \"pathspec unification\" as possible GSoC'10\nproject---with luck, we might finally see a progress on this front ;-)\n\n* hm/maint-imap-send-crlf (2010-02-12) 1 commit\n  (merged to 'next' on 2010-02-17 at c6162cb)\n + git-imap-send: Convert LF to CRLF before storing patch to draft box\n\nSoon to graduate to 'master'.\n\n* nd/root-git (2010-02-14) 5 commits\n - Add test for using Git at root of file system\n - Support working directory located at root\n - Move offset_1st_component() to path.c\n - init-db, rev-parse --git-dir: do not append redundant slash\n - make_absolute_path(): Do not append redundant slash\n\nHow does this interact with the much larger series to rework the set-up\ncodepath?\n\n* pb/log-first-parent-p-m (2010-02-10) 1 commit\n  (merged to 'next' on 2010-02-17 at 2f8e5ae)\n + git log -p -m: document -m and honor --first-parent\n\nNeeds tests but otherwise looked fine.  We might want to teach \"-m trumps\nimplicit --cc\" to \"git show\", but that is a totally separate topic.\n\n* sp/maint-push-sideband (2010-02-10) 8 commits\n  (merged to 'next' on 2010-02-16 at 6f19e5b)\n + receive-pack: Send internal errors over side-band #2\n + t5401: Use a bare repository for the remote peer\n + receive-pack: Send hook output over side band #2\n + receive-pack: Wrap status reports inside side-band-64k\n + receive-pack: Refactor how capabilities are shown to the client\n + send-pack: demultiplex a sideband stream with status data\n + run-command: support custom fd-set in async\n + run-command: Allow stderr to be a caller supplied pipe\n (this branch is used by sp/push-sideband.)\n\nBased on 1.6.5 maintenance track.\n\n* sp/push-sideband (2010-02-10) 0 commits\n (this branch uses sp/maint-push-sideband.)\n\nThis also is in 'next' now.\n\n* ac/cvsimport-revision-mapping (2010-02-06) 1 commit\n  (merged to 'next' on 2010-02-17 at 6756446)\n + cvsimport: new -R option: generate .git/cvs-revisions mapping\n\nAny comments from CVSimport users?\n\n* js/rebase-origin-x (2010-02-05) 1 commit\n - [RFC w/o test and incomplete] rebase: add -x option to record original commit name\n\nI retract my objection against the idea of -x; needs polishing before\nmoving forward.\n\n* jn/maint-makedepend (2010-01-26) 5 commits\n - Makefile: drop dependency on $(wildcard */*.h)\n - Makefile: clean up http-walker.o dependency rules\n - Makefile: remove wt-status.h from LIB_H\n - Makefile: make sure test helpers are rebuilt when headers change\n - Makefile: add missing header file dependencies\n (this branch is used by jn/makedepend and jn/master-makedepend.)\n\n* jn/master-makedepend (2010-01-26) 0 commits\n (this branch uses jn/maint-makedepend; is used by jn/makedepend.)\n\nThis is to help merging the clean-up to \"master\".\n\n* jn/makedepend (2010-01-31) 9 commits\n - Makefile: always remove .depend directories on 'make clean'\n - Makefile: tuck away generated makefile fragments in .depend\n - Teach Makefile to check header dependencies\n - Makefile: list standalone program object files in PROGRAM_OBJS\n - Makefile: lazily compute header dependencies\n - Makefile: list generated object files in OBJECTS\n - Makefile: disable default implicit rules\n - Makefile: rearrange dependency rules\n - Makefile: transport.o depends on branch.h now\n (this branch uses jn/maint-makedepend and jn/master-makedepend.)\n\nAnd this is to build on top.\nLooked ok for 'next'.\n\n* jc/checkout-detached (2010-01-29) 1 commit\n  (merged to 'next' on 2010-02-17 at 7e03edc)\n + Reword \"detached HEAD\" notification\n\n* jc/maint-fix-test-perm (2010-01-30) 2 commits\n  (merged to 'next' on 2010-02-16 at 9d2e037)\n + lib-patch-mode.sh: Fix permission\n + t6000lib: Fix permission\n\n* jh/gitweb-caching (2010-01-30) 1 commit\n - gitweb: Add an option to force version match\n\nThe controversial one.  Will probably drop this.  RFC v3 of gitweb caching\nseries needs to be queued but hasn't happened yet.\n\n* jn/makefile-script-lib (2010-01-31) 1 commit\n  (merged to 'next' on 2010-02-16 at f5334f5)\n + Do not install shell libraries executable\n\nSoon to graduate to 'master'.\n\n* mv/request-pull-modernize (2010-01-29) 1 commit\n  (merged to 'next' on 2010-02-16 at be03aad)\n + request-pull: avoid mentioning that the start point is a single commit\n\nSoon to graduate to 'master'.\n\n* jh/notes (2010-02-13) 30 commits\n - builtin-notes: Add \"copy\" subcommand for copying notes between objects\n - builtin-notes: Misc. refactoring of argc and exit value handling\n - builtin-notes: Add -c/-C options for reusing notes\n - builtin-notes: Refactor handling of -F option to allow combining -m and -F\n - builtin-notes: Deprecate the -m/-F options for \"git notes edit\"\n - builtin-notes: Add \"append\" subcommand for appending to note objects\n - builtin-notes: Add \"add\" subcommand for adding notes to objects\n - builtin-notes: Add --message/--file aliases for -m/-F options\n - builtin-notes: Add \"list\" subcommand for listing note objects\n - Documentation: Generalize git-notes docs to 'objects' instead of 'commits'\n - builtin-notes: Add \"prune\" subcommand for removing notes for missing objects\n - Notes API: prune_notes(): Prune notes that belong to non-existing objects\n - t3305: Verify that removing notes triggers automatic fanout consolidation\n - builtin-notes: Add \"remove\" subcommand for removing existing notes\n - Teach builtin-notes to remove empty notes\n - Teach notes code to properly preserve non-notes in the notes tree\n - t3305: Verify that adding many notes with git-notes triggers increased fanout\n - t3301: Verify successful annotation of non-commits\n - Builtin-ify git-notes\n - Refactor notes concatenation into a flexible interface for combining notes\n - Notes API: Allow multiple concurrent notes trees with new struct notes_tree\n - Notes API: write_notes_tree(): Store the notes tree in the database\n - Notes API: for_each_note(): Traverse the entire notes tree with a callback\n - Notes API: get_note(): Return the note annotating the given object\n - Notes API: remove_note(): Remove note objects from the notes tree structure\n - Notes API: add_note(): Add note objects to the internal notes tree structure\n - Notes API: init_notes(): Initialize the notes tree from the given notes ref\n - Add tests for checking correct handling of $GIT_NOTES_REF and core.notesRef\n - Notes API: get_commit_notes() -> format_note() + remove the commit restriction\n - Minor cosmetic fixes to notes.c\n\nLooked Ok for 'next'; comments?\n\n* cc/reset-keep (2010-01-19) 5 commits\n - reset: disallow using --keep when there are unmerged entries\n - reset: disallow \"reset --keep\" outside a work tree\n - Documentation: reset: describe new \"--keep\" option\n - reset: add test cases for \"--keep\" option\n - reset: add option \"--keep\" to \"git reset\"\n\n* jc/grep-author-all-match-implicit (2010-01-17) 1 commit\n  (merged to 'next' on 2010-02-17 at 3b7be80)\n + \"log --author=me --grep=it\" should find intersection, not union\n"},{"id":"135082","messageId":"fcaeb9bf1002190655w4af9b244x964847c3d5c08c31@mail.gmail.com","threadId":"22699","inReplyTo":"7veikjefib.fsf@alter.siamese.dyndns.org","subject":"Re: What's cooking in git.git (Feb 2010, #04; Wed, 17)","fromName":"Nguyen Thai Ngoc Duy","fromEmail":"pclouds@gmail.com","sentAt":"2010-02-19T14:55:20Z","receivedAt":"2010-02-19T14:55:20Z","isPatch":false,"sender":{"key":"pclouds@gmail.com","avatar":"https://avatars.githubusercontent.com/u/720?v=4"},"body":"On 2/18/10, Junio C Hamano <gitster@pobox.com> wrote:\n>  * nd/root-git (2010-02-14) 5 commits\n>   - Add test for using Git at root of file system\n>   - Support working directory located at root\n>   - Move offset_1st_component() to path.c\n>   - init-db, rev-parse --git-dir: do not append redundant slash\n>   - make_absolute_path(): Do not append redundant slash\n>\n>  How does this interact with the much larger series to rework the set-up\n>  codepath?\n\nThey fix different issues. This one fixes root dir issue. The other\none fixes some code path that tries to access repository when the\nrepository is not properly found. There is a small conflict in\nsetup_git_directory_gently(). I plan to split the larger series,\npushing \"call setup_git_directory_gently() in run_builtin()\" part\nfirst, the rest may come later.\n-- \nDuy\n"}]}