{"thread":{"id":"22211","subject":"What's cooking in git.git (Jan 2010, #04; Wed, 13)","startedAt":"2010-01-13T23:11:14Z","lastAt":"2010-01-13T23:11:14Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"131545","messageId":"7vwrzlk3cd.fsf@alter.siamese.dyndns.org","threadId":"22211","inReplyTo":null,"subject":"What's cooking in git.git (Jan 2010, #04; Wed, 13)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2010-01-13T23:11:14Z","receivedAt":"2010-01-13T23:11:14Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' while commits prefixed with '+' are in 'next'.  The ones\nmarked with '.' do not appear in any of the integration branches, but I am\nstill holding onto them.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* nd/sparse (2010-01-04) 25 commits\n  (merged to 'next' on 2010-01-10 at fa73d6e)\n + t7002: test for not using external grep on skip-worktree paths\n + t7002: set test prerequisite \"external-grep\" if supported\n  (merged to 'next' on 2010-01-02 at 5499bbe)\n + grep: do not do external grep on skip-worktree entries\n + commit: correctly respect skip-worktree bit\n + ie_match_stat(): do not ignore skip-worktree bit with CE_MATCH_IGNORE_VALID\n + tests: rename duplicate t1009\n + sparse checkout: inhibit empty worktree\n + Add tests for sparse checkout\n + read-tree: add --no-sparse-checkout to disable sparse checkout support\n + unpack-trees(): ignore worktree check outside checkout area\n + unpack_trees(): apply $GIT_DIR/info/sparse-checkout to the final index\n + unpack-trees(): \"enable\" sparse checkout and load $GIT_DIR/info/sparse-checkout\n + unpack-trees.c: generalize verify_* functions\n + unpack-trees(): add CE_WT_REMOVE to remove on worktree alone\n + Introduce \"sparse checkout\"\n + dir.c: export excluded_1() and add_excludes_from_file_1()\n + excluded_1(): support exclude files in index\n + unpack-trees(): carry skip-worktree bit over in merged_entry()\n + Read .gitignore from index if it is skip-worktree\n + Avoid writing to buffer in add_excludes_from_file_1()\n + Teach Git to respect skip-worktree bit (writing part)\n + Teach Git to respect skip-worktree bit (reading part)\n + Introduce \"skip-worktree\" bit in index, teach Git to get/set this bit\n + Add test-index-version\n + update-index: refactor mark_valid() in preparation for new options\n\nWith the removal of external grep near future, some codepaths will be\nslightly simplified.\n\n* cc/reset-more (2010-01-08) 8 commits\n  (merged to 'next' on 2010-01-10 at 84730de)\n + t7111: check that reset options work as described in the tables\n  (merged to 'next' on 2010-01-06 at 96639cb)\n + Documentation: reset: add some missing tables\n  (merged to 'next' on 2010-01-04 at 8802c2c)\n + Fix bit assignment for CE_CONFLICTED\n  (merged to 'next' on 2010-01-03 at f83d4c6)\n + \"reset --merge\": fix unmerged case\n + reset: use \"unpack_trees()\" directly instead of \"git read-tree\"\n + reset: add a few tests for \"git reset --merge\"\n + Documentation: reset: add some tables to describe the different options\n + reset: improve mixed reset error message when in a bare repo\n\n* rs/maint-archive-match-pathspec (2009-12-12) 1 commit\n  (merged to 'next' on 2010-01-03 at 92d7d15)\n + archive: complain about path specs that don't match anything\n\n* il/vcs-helper (2010-01-09) 9 commits\n  (merged to 'next' on 2010-01-10 at 11e448e)\n + Reset possible helper before reusing remote structure\n  (merged to 'next' on 2010-01-06 at 7c79f42)\n + Remove special casing of http, https and ftp\n + Support remote archive from all smart transports\n + Support remote helpers implementing smart transports\n + Support taking over transports\n + Refactor git transport options parsing\n + Pass unknown protocols to external protocol handlers\n + Support mandatory capabilities\n + Add remote helper debug mode\n\n* jc/checkout-merge-base (2010-01-07) 4 commits\n  (merged to 'next' on 2010-01-07 at 5229608)\n + rebase -i: teach --onto A...B syntax\n + rebase: fix --onto A...B parsing and add tests\n  (merged to 'next' on 2010-01-02 at 6a8f6fc)\n + \"rebase --onto A...B\" replays history on the merge base between A and B\n + \"checkout A...B\" switches to the merge base between A and B\n\n--------------------------------------------------\n[New Topics]\n\n* jc/maint-1.6.4-grep-lookahead (2010-01-10) 1 commit\n  (merged to 'next' on 2010-01-13 at 20f8f4b)\n + grep: optimize built-in grep by skipping lines that do not hit\n (this branch is used by jc/grep-lookahead and jc/maint-grep-lookahead.)\n\nOptimize the \"line-by-line\" internal grep by skiping en masse over lines\nthat cannot possibly match.\n\n* jc/maint-grep-lookahead (2010-01-12) 0 commits\n (this branch uses jc/maint-1.6.4-grep-lookahead; is used by jc/grep-lookahead.)\n\nEarly conflict resolution for the above for recent git.\n\n* jc/grep-lookahead (2010-01-12) 2 commits\n  (merged to 'next' on 2010-01-13 at 20f8f4b)\n + grep: rip out pessimization to use fixmatch()\n + grep: rip out support for external grep\n (this branch uses jc/maint-1.6.4-grep-lookahead and jc/maint-grep-lookahead.)\n\nThis is for eventual inclusion for the next release.\n\n* jc/symbol-static (2010-01-11) 17 commits\n - symlinks.c: remove unused functions\n - object.c: remove unused functions\n - blob.c: remove unused function\n - strbuf.c: remove unused function\n - sha1_file.c: remove unused function\n - mailmap.c: remove unused function\n - utf8.c: mark file-local function static\n - submodule.c: mark file-local function static\n - quote.c: mark file-local function static\n - remote-curl.c: mark file-local function static\n - read-cache.c: mark file-local functions static\n - parse-options.c: mark file-local function static\n - entry.c: mark file-local function static\n - http.c: mark file-local functions static\n - pretty.c: mark file-local function static\n - builtin-rev-list.c: mark file-local function static\n - bisect.c: mark file-local function static\n\nMark file-local symbols \"static\", and remove unused functions.  Daniel\nsuggests to leave some comment for blob.c and I agree in principle, but\nI don't think of a good description myself.\n\n* nd/include-termios-for-osol (2010-01-11) 1 commit\n - Add missing #include to support TIOCGWINSZ on Solaris\n\n* pc/uninteresting-submodule-disappear-upon-switch-branches (2010-01-11) 1 commit\n - Remove empty directories when checking out a commit with fewer submodules\n\nInstead of using unlink(2) that will never succeed, use rmdir(2) to remove\nan empty directory, knowing that this won't harm a populated directory.\n\n* sd/cd-p-show-toplevel (2010-01-12) 2 commits\n - Use $(git rev-parse --show-toplevel) in cd_to_toplevel().\n - Add 'git rev-parse --show-toplevel' option.\n\nAvoid having to use \"cd -P\" that may not be available on some platforms'\nshells.\n\n* jk/warn-author-committer-after-commit (2010-01-13) 4 commits\n - commit: allow suppression of implicit identity advice\n - commit: show interesting ident information in summary\n - strbuf: add strbuf_addbuf_percentquote\n - strbuf_expand: convert \"%%\" to \"%\"\n\n* js/refer-upstream (2009-09-10) 1 commit\n - Introduce <branch>@{upstream} notation\n\nThis does not teach the public interface about the new syntax; callers\nthat care about distinction between name vs SHA-1 might not work as well\nas they should.\n\n* mm/conflict-advice (2010-01-12) 1 commit\n - Be more user-friendly when refusing to do something because of conflict.\n\n* jc/maint-strbuf-add-fix-doubling (2010-01-12) 1 commit\n - strbuf_addbuf(): allow passing the same buf to dst and src\n\n* jl/submodule-diff (2010-01-13) 2 commits\n - Teach diff that modified submodule directory is dirty\n - Show submodules as modified when they contain a dirty work tree\n\n--------------------------------------------------\n[Stalled]\n\n* ap/merge-backend-opts (2008-07-18) 6 commits\n - Document that merge strategies can now take their own options\n - Extend merge-subtree tests to test -Xsubtree=dir.\n - Make \"subtree\" part more orthogonal to the rest of merge-recursive.\n - Teach git-pull to pass -X<option> to git-merge\n - git merge -X<option>\n - git-merge-file --ours, --theirs\n\n\"git pull\" patch needs sq-then-eval fix to protect it from $IFS\nbut otherwise seemed good.\n\n* mh/rebase-fixup (2010-01-12) 5 commits\n  (merged to 'next' on 2010-01-12 at e84eab0)\n + rebase-i: Ignore comments and blank lines in peek_next_command\n + lib-rebase: Allow comments and blank lines to be added to the rebase script\n + lib-rebase: Provide clearer debugging info about what the editor did\n  (merged to 'next' on 2010-01-06 at c4779a7)\n + Add a command \"fixup\" to rebase --interactive\n + t3404: Use test_commit to set up test repository\n (this branch is used by ns/rebase-auto-squash.)\n\nExpecting further improvements to skip opening the editor if a pick is\nfollowed only by \"fixup\" and no \"squash\".\n\n* ns/rebase-auto-squash (2009-12-08) 1 commit\n  (merged to 'next' on 2010-01-06 at da4e2f5)\n + rebase -i --autosquash: auto-squash commits\n (this branch uses mh/rebase-fixup.)\n\nBlocked by the above.\n\n* jh/notes (2009-12-07) 11 commits\n - Refactor notes concatenation into a flexible interface for combining notes\n - Notes API: Allow multiple concurrent notes trees with new struct notes_tree\n - Notes API: for_each_note(): Traverse the entire notes tree with a callback\n - Notes API: get_note(): Return the note annotating the given object\n - Notes API: add_note(): Add note objects to the internal notes tree structure\n - Notes API: init_notes(): Initialize the notes tree from the given notes ref\n - Notes API: get_commit_notes() -> format_note() + remove the commit restriction\n - Minor style fixes to notes.c\n  (merged to 'next' on 2010-01-02 at ae42130)\n + Add more testcases to test fast-import of notes\n + Rename t9301 to t9350, to make room for more fast-import tests\n + fast-import: Proper notes tree manipulation\n\nhttp://thread.gmane.org/gmane.comp.version-control.git/134738\n\nWhat's the status of the fourth and later patches on this topic?  Overall\nit looked reasonable, if I recall correctly what I thought when I reviewed\nit last time, and I am tempted to merge it to 'next' soonish.  Please\nfile complaints before I do so if people have objections.\n\nHold: JH on 2010-01-05, http://article.gmane.org/gmane.comp.version-control.git/136183\n\n* jh/gitweb-cached (2010-01-13) 7 commits\n - (sign-off?) gitweb: File based caching layer (from git.kernel.org)\n - (sign-off?) gitweb: add a get function to compliment print_local_time\n - (sign-off?) gitweb: Convert output to using indirect file handle\n - gitweb: Optionally add \"git\" links in project list page\n - gitweb: Makefile improvements\n - gitweb: Add option to force version match\n - gitweb: Load checking\n\nReplaced with a re-roll.  Update to t9500 is probably needed.\n\n--------------------------------------------------\n[Cooking]\n\n* jh/commit-status (2010-01-13) 2 commits\n  (merged to 'next' on 2010-01-13 at 0905d59)\n + t7502: test commit.status, --status and --no-status\n + commit: support commit.status, --status, and --no-status\n\nI have already given ample time for people to react, but ended up getting\ntired of waiting for tests to materialize and doing it myself, as I want\nto close merge window for 1.7.0-rc0 by the end of next week to have the\nfinal release early next month.\n\n* bk/fix-relative-gitdir-file (2010-01-08) 2 commits\n - Handle relative paths in submodule .git files\n - Test update-index for a gitlink to a .git file\n\n* jc/ident (2010-01-08) 3 commits\n - ident.c: treat $EMAIL as giving user.email identity explicitly\n  (merged to 'next' on 2010-01-10 at f1f9ded)\n + ident.c: check explicit identity for name and email separately\n + ident.c: remove unused variables\n\nOpinions on the topmost one?\n\n* jc/ls-files-ignored-pathspec (2010-01-08) 4 commits\n - ls-files: fix overeager pathspec optimization\n - read_directory(): further split treat_path()\n - read_directory_recursive(): refactor handling of a single path into a separate function\n - t3001: test ls-files -o ignored/dir\n\n* js/exec-error-report (2010-01-12) 4 commits\n - Improve error message when a transport helper was not found\n - start_command: detect execvp failures early\n - run-command: move wait_or_whine earlier\n - start_command: report child process setup errors to the parent's stderr\n\n* jc/maint-1.6.1-checkout-m-custom-merge (2010-01-06) 1 commit\n  (merged to 'next' on 2010-01-10 at df14116)\n + checkout -m path: fix recreating conflicts\n\n* jn/makefile (2010-01-06) 4 commits\n  (merged to 'next' on 2010-01-10 at f5a5d42)\n + Makefile: consolidate .FORCE-* targets\n + Makefile: learn to generate listings for targets requiring special flags\n + Makefile: use target-specific variable to pass flags to cc\n + Makefile: regenerate assembler listings when asked\n\n* da/difftool (2010-01-09) 6 commits\n  (merged to 'next' on 2010-01-10 at 749c870)\n + git-diff.txt: Link to git-difftool\n + difftool: Allow specifying unconfigured commands with --extcmd\n + difftool--helper: Remove use of the GIT_MERGE_TOOL variable\n + difftool--helper: Update copyright and remove distracting comments\n  (merged to 'next' on 2010-01-06 at e957395)\n + git-difftool: Add '--gui' for selecting a GUI tool\n + t7800-difftool: Set a bogus tool for use by tests\n\n* tc/test-locate-httpd (2010-01-02) 1 commit\n  (merged to 'next' on 2010-01-06 at 9d913e5)\n + t/lib-http.sh: Restructure finding of default httpd location\n\n* jc/fix-tree-walk (2009-09-14) 7 commits\n  (merged to 'next' on 2010-01-13 at 1c01b87)\n + read-tree --debug-unpack\n + unpack-trees.c: look ahead in the index\n + unpack-trees.c: prepare for looking ahead in the index\n + Aggressive three-way merge: fix D/F case\n + traverse_trees(): handle D/F conflict case sanely\n + more D/F conflict tests\n + tests: move convenience regexp to match object names to test-lib.sh\n\nResurrected from \"Ejected\" category.  This is fix for a tricky codepath\nand testing and improving before it hits 'master' is greatly appreciated.\n(I have been using this in my private build for some time).\n\n* jc/branch-d (2009-12-29) 1 commit\n  (merged to 'next' on 2010-01-10 at 61a14b7)\n + branch -d: base the \"already-merged\" safety on the branch it merges with\n\n* jc/rerere (2009-12-04) 1 commit\n  (merged to 'next' on 2010-01-10 at e295b7f)\n + Teach --[no-]rerere-autoupdate option to merge, revert and friends\n\n* jk/run-command-use-shell (2010-01-01) 8 commits\n  (merged to 'next' on 2010-01-10 at 7479e2a)\n + t4030, t4031: work around bogus MSYS bash path conversion\n + diff: run external diff helper with shell\n + textconv: use shell to run helper\n + editor: use run_command's shell feature\n + run-command: optimize out useless shell calls\n + run-command: convert simple callsites to use_shell\n + t0021: use $SHELL_PATH for the filter script\n + run-command: add \"use shell\" option\n\nShuffled the commits in the topic, following J6t's suggestion in\nhttp://thread.gmane.org/gmane.comp.version-control.git/136128\n\n* tc/clone-v-progress (2009-12-26) 4 commits\n  (merged to 'next' on 2010-01-10 at ec2bfd7)\n + clone: use --progress to force progress reporting\n + clone: set transport->verbose when -v/--verbose is used\n + git-clone.txt: reword description of progress behaviour\n + check stderr with isatty() instead of stdout when deciding to show progress\n\nPerhaps needs an entry in the Release Notes, but otherwise looked Ok.\n\n* tc/smart-http-restrict (2010-01-02) 4 commits\n  (merged to 'next' on 2010-01-06 at 82736cb)\n + Smart-http tests: Test http-backend without curl or a webserver\n + Smart-http tests: Break test t5560-http-backend into pieces\n + Smart-http tests: Improve coverage in test t5560\n + Smart-http: check if repository is OK to export before serving it\n\n* jc/cache-unmerge (2009-12-25) 9 commits\n  (merged to 'next' on 2010-01-13 at 2290c44)\n + rerere forget path: forget recorded resolution\n + rerere: refactor rerere logic to make it independent from I/O\n + rerere: remove silly 1024-byte line limit\n + resolve-undo: teach \"update-index --unresolve\" to use resolve-undo info\n + resolve-undo: \"checkout -m path\" uses resolve-undo information\n + resolve-undo: allow plumbing to clear the information\n + resolve-undo: basic tests\n + resolve-undo: record resolved conflicts in a new index extension section\n + builtin-merge.c: use standard active_cache macros\n\n* tr/http-push-ref-status (2010-01-08) 6 commits\n - transport-helper.c::push_refs(): emit \"no refs\" error message\n - transport-helper.c::push_refs(): ignore helper-reported status if ref is not to be pushed\n - transport.c::transport_push(): make ref status affect return value\n - refactor ref status logic for pushing\n - t5541-http-push.sh: add test for unmatched, non-fast-forwarded refs\n - t5541-http-push.sh: add tests for non-fast-forward pushes\n\nRerolled.\n\n* sr/gfi-options (2009-12-04) 7 commits\n  (merged to 'next' on 2010-01-10 at 8b305fb)\n + fast-import: add (non-)relative-marks feature\n + fast-import: allow for multiple --import-marks= arguments\n + fast-import: test the new option command\n + fast-import: add option command\n + fast-import: add feature command\n + fast-import: put marks reading in its own function\n + fast-import: put option parsing code in separate functions\n"}]}