{"thread":{"id":"20302","subject":"[PATCH 2/2] Documentation: git-send-email: correct statement about standard ports","startedAt":"2009-07-30T23:08:53Z","lastAt":"2009-08-05T22:40:36Z","messageCount":6,"participants":["Wesley J. Landaker","Junio C Hamano","Tony Finch"],"isPatch":true,"patchVersion":1,"patchTotal":2},"messages":[{"id":"119197","messageId":"1248995334-28545-1-git-send-email-wjl@icecavern.net","threadId":"20302","inReplyTo":null,"subject":"[PATCH 1/2] Documentation: git-send-email: fix submission port number","fromName":"Wesley J. Landaker","fromEmail":"wjl@icecavern.net","sentAt":"2009-07-30T23:08:53Z","receivedAt":"2009-07-30T23:08:53Z","isPatch":true,"sender":{"key":"wjl@icecavern.net","avatar":"https://avatars.githubusercontent.com/u/67229?v=4"},"body":"The current documentation confuses non-standard SSL smtp port 465 with\nsubmission port 587 (RFC 4406). This patch just changes the referenced\nnumber.\n\nSigned-off-by: Wesley J. Landaker <wjl@icecavern.net>\n---\n Documentation/git-send-email.txt |    2 +-\n 1 files changed, 1 insertions(+), 1 deletions(-)\n\ndiff --git a/Documentation/git-send-email.txt b/Documentation/git-send-email.txt\nindex d6b192b..1c94351 100644\n--- a/Documentation/git-send-email.txt\n+++ b/Documentation/git-send-email.txt\n@@ -143,7 +143,7 @@ user is prompted for a password while the input is masked for privacy.\n --smtp-server-port=<port>::\n \tSpecifies a port different from the default port (SMTP\n \tservers typically listen to smtp port 25 and ssmtp port\n-\t465); symbolic port names (e.g. \"submission\" instead of 465)\n+\t465); symbolic port names (e.g. \"submission\" instead of 587)\n \tare also accepted. The port can also be set with the\n \t'sendemail.smtpserverport' configuration variable.\n \n-- \n1.6.3.1\n"},{"id":"119196","messageId":"1248995334-28545-2-git-send-email-wjl@icecavern.net","threadId":"20302","inReplyTo":"1248995334-28545-1-git-send-email-wjl@icecavern.net","subject":"[PATCH 2/2] Documentation: git-send-email: correct statement about standard ports","fromName":"Wesley J. Landaker","fromEmail":"wjl@icecavern.net","sentAt":"2009-07-30T23:08:54Z","receivedAt":"2009-07-30T23:08:54Z","isPatch":true,"sender":{"key":"wjl@icecavern.net","avatar":"https://avatars.githubusercontent.com/u/67229?v=4"},"body":"The current documentation states that servers typically listen on port\n465 and calls this \"ssmtp\". While it's true that many mail servers use\nport 465 for SSL smtp, this is non-standard, and hails from the days\nbefore smtp and submission TLS support, that arrived in RFC2487 and\nRFC3207. Port 465 is actually assigned by IANA for unrelated purposes,\nand is mostly still used by mail servers today only to support Outlook\nExpress.\n\nIn any case, this patch helps the documentation better reflect both\nstandards and reality, while still helpfully mentioning ports numbers\nthat a user may wish to specify.\n\nSigned-off-by: Wesley J. Landaker <wjl@icecavern.net>\n---\n Documentation/git-send-email.txt |    5 +++--\n 1 files changed, 3 insertions(+), 2 deletions(-)\n\ndiff --git a/Documentation/git-send-email.txt b/Documentation/git-send-email.txt\nindex 1c94351..6415d94 100644\n--- a/Documentation/git-send-email.txt\n+++ b/Documentation/git-send-email.txt\n@@ -142,8 +142,9 @@ user is prompted for a password while the input is masked for privacy.\n \n --smtp-server-port=<port>::\n \tSpecifies a port different from the default port (SMTP\n-\tservers typically listen to smtp port 25 and ssmtp port\n-\t465); symbolic port names (e.g. \"submission\" instead of 587)\n+\tservers typically listen to smtp port 25, but may also listen to\n+\tsubmission port 587, or a non-standard SSL smtp port like 465);\n+\tsymbolic port names (e.g. \"submission\" instead of 587)\n \tare also accepted. The port can also be set with the\n \t'sendemail.smtpserverport' configuration variable.\n \n-- \n1.6.3.1\n"},{"id":"119283","messageId":"7vzlaku9d4.fsf@alter.siamese.dyndns.org","threadId":"20302","inReplyTo":"1248995334-28545-2-git-send-email-wjl@icecavern.net","subject":"Re: [PATCH 2/2] Documentation: git-send-email: correct statement about standard ports","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2009-07-31T16:04:39Z","receivedAt":"2009-07-31T16:04:39Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"\"Wesley J. Landaker\" <wjl@icecavern.net> writes:\n\n> diff --git a/Documentation/git-send-email.txt b/Documentation/git-send-email.txt\n> index 1c94351..6415d94 100644\n> --- a/Documentation/git-send-email.txt\n> +++ b/Documentation/git-send-email.txt\n> @@ -142,8 +142,9 @@ user is prompted for a password while the input is masked for privacy.\n>  \n>  --smtp-server-port=<port>::\n>  \tSpecifies a port different from the default port (SMTP\n> -\tservers typically listen to smtp port 25 and ssmtp port\n> -\t465); symbolic port names (e.g. \"submission\" instead of 587)\n> +\tservers typically listen to smtp port 25, but may also listen to\n> +\tsubmission port 587, or a non-standard SSL smtp port like 465);\n> +\tsymbolic port names (e.g. \"submission\" instead of 587)\n>  \tare also accepted. The port can also be set with the\n>  \t'sendemail.smtpserverport' configuration variable.\n\nAs you noted, port 465 has been used as a well-known de-facto port to run\nSMTP over SSL at many places.  I do not think it would help anybody by\nclarifying that it is a \"non-standard\" port here.  This is not a place to\neducate people on which port they should run their SMTP servers.\n\nBut I do not care deeply enough, and I can let it pass.\n\nI have much more trouble with that \"like 465\" than I have with \"non\nstandard\".\n\nThe purpose of listing the specific numbers in this sectiono is to give\npractical hints.  We could just have said \"we can take the port number\nyour SMTP server listens to with this option, and it is up to you to\nfigure out which port you want to talk to\".  We try to be helpful instead,\nso that the people can try to see if the suggested ports match their\nsituation without having to consult outside references.  That's the whole\nreason for having specific numbers in this section.\n\nAnd in that context, 465 is much more special than any other \"non standard\nport on which a random ISP may happen to run its SMTP over SSL service\".\n\nI think you would help people better to say:\n\n\t... submission port 587, or a widely used non-standard SMTP over\n\tSSL port 465.\n\nif you want to really say non-standard, that is.\n"},{"id":"119294","messageId":"200907311145.01759.wjl@icecavern.net","threadId":"20302","inReplyTo":"7vzlaku9d4.fsf@alter.siamese.dyndns.org","subject":"[PATCHv2 2/2] Documentation: git-send-email: correct statement about standard ports","fromName":"Wesley J. Landaker","fromEmail":"wjl@icecavern.net","sentAt":"2009-07-31T17:45:00Z","receivedAt":"2009-07-31T17:45:00Z","isPatch":false,"sender":{"key":"wjl@icecavern.net","avatar":"https://avatars.githubusercontent.com/u/67229?v=4"},"body":"On Friday 31 July 2009 10:04:39 Junio C Hamano wrote:\n> As you noted, port 465 has been used as a well-known de-facto port to run\n> SMTP over SSL at many places.  I do not think it would help anybody by\n> clarifying that it is a \"non-standard\" port here.  This is not a place to\n> educate people on which port they should run their SMTP servers.\n>\n> But I do not care deeply enough, and I can let it pass.\n>\n> I have much more trouble with that \"like 465\" than I have with \"non\n> standard\".\n\nIf you don't like the phrasing, how about this revised patch? I call it a\n\"common SSL smtp port\", and refer directly to 465. I think should make everyone\nhappy:\n\n---\n\n>From f0f6d41705f51f198c7cd87cbbf4ffdbe3fdf84e Mon Sep 17 00:00:00 2001\nFrom: Wesley J. Landaker <wjl@icecavern.net>\nDate: Thu, 30 Jul 2009 14:53:29 -0600\nSubject: [PATCH 2/2] Documentation: git-send-email: correct statement about standard ports\n\nThe current documentation states that servers typically listen on port\n465 and calls this \"ssmtp\". While it's true that many mail servers use\nport 465 for SSL smtp, this is non-standard, and hails from the days\nbefore smtp and submission TLS support, that arrived in RFC2487 and\nRFC3207. Port 465 is actually assigned by IANA for unrelated purposes,\nand is mostly still used by mail servers today only to support Outlook\nExpress.\n\nIn any case, this patch helps the documentation better reflect both\nstandards and reality, while still helpfully mentioning ports numbers\nthat a user may wish to specify.\n\nSigned-off-by: Wesley J. Landaker <wjl@icecavern.net>\n---\n Documentation/git-send-email.txt |    5 +++--\n 1 files changed, 3 insertions(+), 2 deletions(-)\n\ndiff --git a/Documentation/git-send-email.txt b/Documentation/git-send-email.txt\nindex 1c94351..767cf4d 100644\n--- a/Documentation/git-send-email.txt\n+++ b/Documentation/git-send-email.txt\n@@ -142,8 +142,9 @@ user is prompted for a password while the input is masked for privacy.\n \n --smtp-server-port=<port>::\n \tSpecifies a port different from the default port (SMTP\n-\tservers typically listen to smtp port 25 and ssmtp port\n-\t465); symbolic port names (e.g. \"submission\" instead of 587)\n+\tservers typically listen to smtp port 25, but may also listen to\n+\tsubmission port 587, or the common SSL smtp port 465);\n+\tsymbolic port names (e.g. \"submission\" instead of 587)\n \tare also accepted. The port can also be set with the\n \t'sendemail.smtpserverport' configuration variable.\n \n-- \n1.6.3.1\n"},{"id":"119297","messageId":"7vbpn0r9zf.fsf@alter.siamese.dyndns.org","threadId":"20302","inReplyTo":"200907311145.01759.wjl@icecavern.net","subject":"Re: [PATCHv2 2/2] Documentation: git-send-email: correct statement about standard ports","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2009-07-31T18:19:32Z","receivedAt":"2009-07-31T18:19:32Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"\"Wesley J. Landaker\" <wjl@icecavern.net> writes:\n\n> On Friday 31 July 2009 10:04:39 Junio C Hamano wrote:\n>> As you noted, port 465 has been used as a well-known de-facto port to run\n>> SMTP over SSL at many places.  I do not think it would help anybody by\n>> clarifying that it is a \"non-standard\" port here.  This is not a place to\n>> educate people on which port they should run their SMTP servers.\n>>\n>> But I do not care deeply enough, and I can let it pass.\n>>\n>> I have much more trouble with that \"like 465\" than I have with \"non\n>> standard\".\n>\n> If you don't like the phrasing, how about this revised patch? I call it a\n> \"common SSL smtp port\", and refer directly to 465. I think should make everyone\n> happy:\n\nLooks really good.  Thanks.\n"},{"id":"119721","messageId":"alpine.LSU.2.00.0908052303010.15736@hermes-2.csi.cam.ac.uk","threadId":"20302","inReplyTo":"7vzlaku9d4.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 2/2] Documentation: git-send-email: correct statement about standard ports","fromName":"Tony Finch","fromEmail":"dot@dotat.at","sentAt":"2009-08-05T22:40:36Z","receivedAt":"2009-08-05T22:40:36Z","isPatch":true,"sender":{"key":"dot@dotat.at","avatar":"https://avatars.githubusercontent.com/u/68429?v=4"},"body":"On Fri, 31 Jul 2009, Junio C Hamano wrote:\n>\n> As you noted, port 465 has been used as a well-known de-facto port to run\n> SMTP over SSL at many places.  I do not think it would help anybody by\n> clarifying that it is a \"non-standard\" port here.\n\n(off topic pedantry)\n\n465 was at one time the de jure standard IANA registered port for smtps\n(not \"ssmtp\") alongside the imaps and pop3s ports. The IETF foolishly\nwithdrew the registration for political reasons and it was subsequently\nre-assigned to something else. Since the withdrawal there has been no\nregistered port for smtps, but smtps is required to support Outlook (not\njust Outlook Express). Therefore operators have ignored the IETF's\nmistake.\n\nThis is another example of IP \"as she is spoke\" being different from what\nthe standards say. Another good example is TCP congestion control which\nwasn't described in an RFC until RFC 2001.\n\nAlso, MUAs typically use SSL to mean TLS-on-connect and TLS to mean\nSTARTTLS, and the setting has no bearing on whether it uses version\n3.0 and earlier or 3.1 and later of the protocol.\n\nTony.\n-- \nf.anthony.n.finch  <dot@dotat.at>  http://dotat.at/\nGERMAN BIGHT HUMBER: SOUTHWEST 5 TO 7. MODERATE OR ROUGH. SQUALLY SHOWERS.\nMODERATE OR GOOD.\n"}]}