{"thread":{"id":"20255","subject":"[PATCH 0/3 v2] Improve your performance with our patch","startedAt":"2009-07-28T06:08:46Z","lastAt":"2009-07-29T13:30:07Z","messageCount":7,"participants":["Daniel Barkalow","Michael J Gruber","Johannes Schindelin","Reece Dunn","Rogan Dawes"],"isPatch":true,"patchVersion":2,"patchTotal":3},"messages":[{"id":"118922","messageId":"alpine.LNX.2.00.0907280131230.2147@iabervon.org","threadId":"20255","inReplyTo":null,"subject":"[PATCH 0/3 v2] Improve your performance with our patch","fromName":"Daniel Barkalow","fromEmail":"barkalow@iabervon.org","sentAt":"2009-07-28T06:08:46Z","receivedAt":"2009-07-28T06:08:46Z","isPatch":true,"sender":{"key":"barkalow@iabervon.org","avatar":"https://avatars.githubusercontent.com/u/55364219?v=4"},"body":"Ever since I saw spam to the kernel mailing list with that subject, I've \nwanted to title a suitable patch series that. This series makes executing \nthe git startup code a whole lot faster on distros where libcurl has all \nthe possible features, by not linking the regular programs against it.\n\nI have in the works a series to implement my foreign-scm series as an \nextension to this series, mainly adding handling for the ways that \nimporting content is different from simply getting it from a remote \nrepository.\n\nDaniel Barkalow (2):\n  Add support for external programs for handling native fetches\n  Use an external program to implement fetching with curl\n\nLinus Torvalds (1):\n  git-http-fetch: not a builtin\n\n Documentation/git-shim.txt           |   37 +++++++++\n Makefile                             |   12 ++-\n git.c                                |    3 -\n builtin-http-fetch.c => http-fetch.c |    5 +-\n shim-curl.c                          |  132 +++++++++++++++++++++++++++++++\n transport-shim.c                     |  142 ++++++++++++++++++++++++++++++++++\n transport.c                          |  136 +--------------------------------\n transport.h                          |    3 +\n 8 files changed, 328 insertions(+), 142 deletions(-)\n create mode 100644 Documentation/git-shim.txt\n rename builtin-http-fetch.c => http-fetch.c (95%)\n create mode 100644 shim-curl.c\n create mode 100644 transport-shim.c\n"},{"id":"118927","messageId":"4A6EAD50.4060906@drmicha.warpmail.net","threadId":"20255","inReplyTo":"alpine.LNX.2.00.0907280131230.2147@iabervon.org","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Michael J Gruber","fromEmail":"git@drmicha.warpmail.net","sentAt":"2009-07-28T07:48:32Z","receivedAt":"2009-07-28T07:48:32Z","isPatch":true,"sender":{"key":"git@grubix.eu","avatar":"https://avatars.githubusercontent.com/u/233215?v=4"},"body":"Daniel Barkalow venit, vidit, dixit 28.07.2009 08:08:\n> Ever since I saw spam to the kernel mailing list with that subject, I've \n> wanted to title a suitable patch series that. This series makes executing \n\nROTFL :)\n\nI'm glad it passed my spam filters... Do you offer free shipping and a\nrebate if I order a year's supply?\n\nMichael\n"},{"id":"118946","messageId":"alpine.DEB.1.00.0907281307380.8306@pacific.mpi-cbg.de","threadId":"20255","inReplyTo":"alpine.LNX.2.00.0907280131230.2147@iabervon.org","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Johannes Schindelin","fromEmail":"johannes.schindelin@gmx.de","sentAt":"2009-07-28T11:11:16Z","receivedAt":"2009-07-28T11:11:16Z","isPatch":true,"sender":{"key":"johannes.schindelin@gmx.de","avatar":"https://avatars.githubusercontent.com/u/127790?v=4"},"body":"Hi,\n\nOn Tue, 28 Jul 2009, Daniel Barkalow wrote:\n\n>  Documentation/git-shim.txt           |   37 +++++++++\n\nMay I re-register my complaint about the naming?\n\nI mean, yes, I could think of something even worse when it comes to the \n(ridiculously bad!) tradition of naming things \"porcelain\", \"plumbing\" and \n\"potty\", especially when it comes to \"pushing objects\" and \nthen \"pulling\".\n\nBut now that we had a good laugh, it is time to get serious again, and \ngive this child a _way_ better name.\n\nI mean, you already had a good name for your foreign scm series.  Why did \nyou give that up in favor of this lousy naming?\n\nCiao,\nDscho\n"},{"id":"118954","messageId":"3f4fd2640907280550g22e922fue0bbeeed36fba497@mail.gmail.com","threadId":"20255","inReplyTo":"alpine.DEB.1.00.0907281307380.8306@pacific.mpi-cbg.de","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Reece Dunn","fromEmail":"msclrhd@googlemail.com","sentAt":"2009-07-28T12:50:14Z","receivedAt":"2009-07-28T12:50:14Z","isPatch":true,"sender":{"key":"msclrhd@googlemail.com","avatar":null},"body":"2009/7/28 Johannes Schindelin <Johannes.Schindelin@gmx.de>:\n> Hi,\n>\n> On Tue, 28 Jul 2009, Daniel Barkalow wrote:\n>\n>>  Documentation/git-shim.txt           |   37 +++++++++\n>\n> May I re-register my complaint about the naming?\n>\n> I mean, yes, I could think of something even worse when it comes to the\n> (ridiculously bad!) tradition of naming things \"porcelain\", \"plumbing\" and\n> \"potty\", especially when it comes to \"pushing objects\" and\n> then \"pulling\".\n>\n> But now that we had a good laugh, it is time to get serious again, and\n> give this child a _way_ better name.\n>\n> I mean, you already had a good name for your foreign scm series.  Why did\n> you give that up in favor of this lousy naming?\n\nHow about git-http?\n\n- Reece\n"},{"id":"118960","messageId":"alpine.DEB.1.00.0907281528260.8306@pacific.mpi-cbg.de","threadId":"20255","inReplyTo":"3f4fd2640907280550g22e922fue0bbeeed36fba497@mail.gmail.com","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Johannes Schindelin","fromEmail":"johannes.schindelin@gmx.de","sentAt":"2009-07-28T13:29:22Z","receivedAt":"2009-07-28T13:29:22Z","isPatch":true,"sender":{"key":"johannes.schindelin@gmx.de","avatar":"https://avatars.githubusercontent.com/u/127790?v=4"},"body":"Hi,\n\nOn Tue, 28 Jul 2009, Reece Dunn wrote:\n\n> 2009/7/28 Johannes Schindelin <Johannes.Schindelin@gmx.de>:\n>\n> > On Tue, 28 Jul 2009, Daniel Barkalow wrote:\n> >\n> >>  Documentation/git-shim.txt           |   37 +++++++++\n> >\n> > May I re-register my complaint about the naming?\n> >\n> > I mean, yes, I could think of something even worse when it comes to the\n> > (ridiculously bad!) tradition of naming things \"porcelain\", \"plumbing\" and\n> > \"potty\", especially when it comes to \"pushing objects\" and\n> > then \"pulling\".\n> >\n> > But now that we had a good laugh, it is time to get serious again, and\n> > give this child a _way_ better name.\n> >\n> > I mean, you already had a good name for your foreign scm series.  Why did\n> > you give that up in favor of this lousy naming?\n> \n> How about git-http?\n\nIf 'git-fetch' learns to search for a helper by the name of the protocol \n(as it should learn), this will obviously fail with svn://.\n\nCiao,\nDscho\n"},{"id":"119058","messageId":"4A704A62.2060402@dawes.za.net","threadId":"20255","inReplyTo":"alpine.DEB.1.00.0907281307380.8306@pacific.mpi-cbg.de","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Rogan Dawes","fromEmail":"lists@dawes.za.net","sentAt":"2009-07-29T13:10:58Z","receivedAt":"2009-07-29T13:10:58Z","isPatch":true,"sender":{"key":"lists@dawes.za.net","avatar":null},"body":"Johannes Schindelin wrote:\n> Hi,\n> \n> On Tue, 28 Jul 2009, Daniel Barkalow wrote:\n> \n>>  Documentation/git-shim.txt           |   37 +++++++++\n> \n> May I re-register my complaint about the naming?\n> \n> I mean, yes, I could think of something even worse when it comes to the \n> (ridiculously bad!) tradition of naming things \"porcelain\", \"plumbing\" and \n> \"potty\", especially when it comes to \"pushing objects\" and \n> then \"pulling\".\n\nA Shim has nothing to do with plumbing or toilets. From\n<http://en.wikipedia.org/wiki/Shim_%28engineering%29>:\n\nIn engineering, a shim is a thin and often tapered or wedged piece of\nmaterial, used to fill small gaps or spaces between objects. Shims are\ntypically used in order to support, adjust for better fit, or provide a\nlevel surface.\n\nI suspect that it is being used in the \"adjust for better fit\" sense in\nthis case.\n\nRegards,\n\nRogan\n"},{"id":"119059","messageId":"3f4fd2640907290630s37285944y8a364ce958367b@mail.gmail.com","threadId":"20255","inReplyTo":"4A704A62.2060402@dawes.za.net","subject":"Re: [PATCH 0/3 v2] Improve your performance with our patch","fromName":"Reece Dunn","fromEmail":"msclrhd@googlemail.com","sentAt":"2009-07-29T13:30:07Z","receivedAt":"2009-07-29T13:30:07Z","isPatch":true,"sender":{"key":"msclrhd@googlemail.com","avatar":null},"body":"2009/7/29 Rogan Dawes <lists@dawes.za.net>:\n> Johannes Schindelin wrote:\n>> Hi,\n>>\n>> On Tue, 28 Jul 2009, Daniel Barkalow wrote:\n>>\n>>>  Documentation/git-shim.txt           |   37 +++++++++\n>>\n>> May I re-register my complaint about the naming?\n>>\n>> I mean, yes, I could think of something even worse when it comes to the\n>> (ridiculously bad!) tradition of naming things \"porcelain\", \"plumbing\" and\n>> \"potty\", especially when it comes to \"pushing objects\" and\n>> then \"pulling\".\n>\n> A Shim has nothing to do with plumbing or toilets. From\n> <http://en.wikipedia.org/wiki/Shim_%28engineering%29>:\n>\n> In engineering, a shim is a thin and often tapered or wedged piece of\n> material, used to fill small gaps or spaces between objects. Shims are\n> typically used in order to support, adjust for better fit, or provide a\n> level surface.\n>\n> I suspect that it is being used in the \"adjust for better fit\" sense in\n> this case.\n\nYes, a shim is a layer that acts as a bridge from one thing to\nanother. In this case, it is a bridge between the transport code and\nthe transport mechanism. Using shim as an external name is confusing\n-- a shim to what? The fast-import code and git-svn/hg/bzr/cvs/...\ncould be a shim (as it is acting as a bridge between other version\ncontrol systems).\n\nHere, git-remote-* where * is the protocol name is a better naming\nscheme as it tells you about what the logic is doing. The\ndocumentation can be under git-remote.txt.\n\n- Reece\n"}]}