{"thread":{"id":"19710","subject":"[PATCH 00/23] http*: refactor (v6)","startedAt":"2009-06-06T08:42:53Z","lastAt":"2009-06-10T10:36:23Z","messageCount":6,"participants":["Tay Ray Chuan","Junio C Hamano","Jakub Narebski"],"isPatch":true,"patchVersion":1,"patchTotal":23},"messages":[{"id":"115614","messageId":"20090606164253.65a945ba.rctay89@gmail.com","threadId":"19710","inReplyTo":null,"subject":"[PATCH 00/23] http*: refactor (v6)","fromName":"Tay Ray Chuan","fromEmail":"rctay89@gmail.com","sentAt":"2009-06-06T08:42:53Z","receivedAt":"2009-06-06T08:42:53Z","isPatch":true,"sender":{"key":"rctay89@gmail.com","avatar":"https://avatars.githubusercontent.com/u/61553?v=4"},"body":"Junio, this replaces the entire 'rc/http-push' topic.\n\nChanges from the previous patch series:\n\n- add a list of functions added (patch #15)\n\n- use back the die()'s like in the original (patch #16)\n\nChristian Couder (1):\n  http-push: fix missing \"#ifdef USE_CURL_MULTI\" around\n    \"is_running_queue\"\n\nMike Hommey (7):\n  Don't expect verify_pack() callers to set pack_size\n  transport.c::get_refs_via_curl(): do not leak refs_url\n  http.c: new functions for the http API\n  transport.c::get_refs_via_curl(): use the new http API\n  http.c::http_fetch_ref(): use the new http API\n  http-push.c::remote_exists(): use the new http API\n  http-push.c::fetch_symref(): use the new http API\n\nTay Ray Chuan (15):\n  t5540-http-push: test fetching of loose objects\n  t5540-http-push: test fetching of packed objects\n  http*: cleanup slot->local after fclose\n  http-push: send out fetch requests on queue\n  t5550-http-fetch: test fetching of packed objects\n  http-push, http-walker: style fixes\n  http-walker: verify remote packs\n  http*: copy string returned by sha1_to_hex\n  http-push: do not SEGV after fetching a bad pack idx file\n  http*: move common variables and macros to http.[ch]\n  http: create function end_url_with_slash\n  http*: add http_get_info_packs\n  http: use new http API in fetch_index()\n  http*: add helper methods for fetching packs\n  http*: add helper methods for fetching objects (loose)\n\n http-push.c           |  579 ++++++++---------------------------------------\n http-walker.c         |  533 +++++++------------------------------------\n http.c                |  601 +++++++++++++++++++++++++++++++++++++++++++++++--\n http.h                |   85 +++++++\n pack-check.c          |    8 +-\n t/t5540-http-push.sh  |   36 +++\n t/t5550-http-fetch.sh |    8 +\n transport.c           |   36 ++--\n 8 files changed, 905 insertions(+), 981 deletions(-)\n"},{"id":"115661","messageId":"7v8wk5dyrw.fsf@alter.siamese.dyndns.org","threadId":"19710","inReplyTo":"20090606164253.65a945ba.rctay89@gmail.com","subject":"Re: [PATCH 00/23] http*: refactor (v6)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2009-06-06T18:04:35Z","receivedAt":"2009-06-06T18:04:35Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Tay Ray Chuan <rctay89@gmail.com> writes:\n\n> Junio, this replaces the entire 'rc/http-push' topic.\n>\n> Changes from the previous patch series:\n>\n> - add a list of functions added (patch #15)\n>\n> - use back the die()'s like in the original (patch #16)\n\nThanks, will queue, but please double check the result after I push it\nout, as I found some other changes not listed above, relative to what was\nqueued in 'pu' (I am not complaining; I am asking your extra set of\neyeballs in case I somehow screwed up applying your series to my tree).\n\n - return value of fetch_indices() is 0 when http_get_info_packs() returns\n   HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);\n\n - break the function definition of run_request_queue() by removing \"void\"\n   from the parameter list (\"send out fetch requests on queue\" -- no need\n   to resend, I fixed it up again while applying);\n\n - update the error checking in transport.c:get_refs_via_curl() to make it\n   look more similar to what are in fetch_indices() in both http-push.c and\n   http-walker.c.\n\n - add unused \"cleanup:\" label to get_refs_via_curl() in transport.c\n   (again no need to resend, I fixed it up while applying);\n\n - add back a few missing \"->local = NULL\" I screwed up while applying the\n   previous series.\n\nBy the way, this is not your fault at all, but for a patch series\ndescription, \"shortlog\" is a sucky way, as we can see below.  When you\ntalk about \"patch #15\", the reader cannot find which one you are talking\nabout but has to go back to the MUA, so the list is useless for that\npurpose.\n\nThe output of \"shortlog\" in an e-mail message is wonderful when you are a\nsubsystem maintainer who bundles many people's work and are sending out a\npull request (i.e.  you are transferring the whole graph in \"take it or\nreject all\" fashion, and you can refer to an individual changeset with its\ncommit object name).\n\nBut I think a cover letter to a patch series should serve as an easy index\nfrom patch number to the title in some way, and \"shortlog\" is not suitable\nfor that eapecially for a multi-author series.\n\n> Christian Couder (1):\n>   http-push: fix missing \"#ifdef USE_CURL_MULTI\" around\n>     \"is_running_queue\"\n>\n> Mike Hommey (7):\n>   Don't expect verify_pack() callers to set pack_size\n>   transport.c::get_refs_via_curl(): do not leak refs_url\n>   http.c: new functions for the http API\n>   transport.c::get_refs_via_curl(): use the new http API\n>   http.c::http_fetch_ref(): use the new http API\n>   http-push.c::remote_exists(): use the new http API\n>   http-push.c::fetch_symref(): use the new http API\n>\n> Tay Ray Chuan (15):\n>   t5540-http-push: test fetching of loose objects\n>   t5540-http-push: test fetching of packed objects\n>   http*: cleanup slot->local after fclose\n>   http-push: send out fetch requests on queue\n>   t5550-http-fetch: test fetching of packed objects\n>   http-push, http-walker: style fixes\n>   http-walker: verify remote packs\n>   http*: copy string returned by sha1_to_hex\n>   http-push: do not SEGV after fetching a bad pack idx file\n>   http*: move common variables and macros to http.[ch]\n>   http: create function end_url_with_slash\n>   http*: add http_get_info_packs\n>   http: use new http API in fetch_index()\n>   http*: add helper methods for fetching packs\n>   http*: add helper methods for fetching objects (loose)\n\n>  http-push.c           |  579 ++++++++---------------------------------------\n>  http-walker.c         |  533 +++++++------------------------------------\n>  http.c                |  601 +++++++++++++++++++++++++++++++++++++++++++++++--\n>  http.h                |   85 +++++++\n>  pack-check.c          |    8 +-\n>  t/t5540-http-push.sh  |   36 +++\n>  t/t5550-http-fetch.sh |    8 +\n>  transport.c           |   36 ++--\n>  8 files changed, 905 insertions(+), 981 deletions(-)\n"},{"id":"115662","messageId":"m3tz2t43xr.fsf@localhost.localdomain","threadId":"19710","inReplyTo":"7v8wk5dyrw.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 00/23] http*: refactor (v6)","fromName":"Jakub Narebski","fromEmail":"jnareb@gmail.com","sentAt":"2009-06-06T18:23:17Z","receivedAt":"2009-06-06T18:23:17Z","isPatch":true,"sender":{"key":"jnareb@gmail.com","avatar":"https://avatars.githubusercontent.com/u/2706?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> Tay Ray Chuan <rctay89@gmail.com> writes:\n\n[...]\n> By the way, this is not your fault at all, but for a patch series\n> description, \"shortlog\" is a sucky way, as we can see below.  When you\n> talk about \"patch #15\", the reader cannot find which one you are talking\n> about but has to go back to the MUA, so the list is useless for that\n> purpose.\n> \n> The output of \"shortlog\" in an e-mail message is wonderful when you are a\n> subsystem maintainer who bundles many people's work and are sending out a\n> pull request (i.e.  you are transferring the whole graph in \"take it or\n> reject all\" fashion, and you can refer to an individual changeset with its\n> commit object name).\n> \n> But I think a cover letter to a patch series should serve as an easy index\n> from patch number to the title in some way, and \"shortlog\" is not suitable\n> for that eapecially for a multi-author series.\n\nBefore git-send-email learned --cover option, I have used the\nfollowing commands to generate \"Table of contents\" for a patch series:\n * generate patches to some subdirectory using '-o' option \n   of git-format-patch\n * grep for subject and remove \"Subject:\" line:\n   $ grep -h \"Subject:\" mdir/* | sed -e 's/Subject://' >> mdir/0000-cover.txt\n\nThis way I had list of patches in the series in actual order...\n\nP.S. Tay Ray Chuan, this patch series is again not being replies to\n     cover letter...\n-- \nJakub Narebski\nPoland\nShadeHawk on #git\n"},{"id":"115678","messageId":"be6fef0d0906061741p6f3864a9m25d25e23ef0db760@mail.gmail.com","threadId":"19710","inReplyTo":"7v8wk5dyrw.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 00/23] http*: refactor (v6)","fromName":"Tay Ray Chuan","fromEmail":"rctay89@gmail.com","sentAt":"2009-06-07T00:41:59Z","receivedAt":"2009-06-07T00:41:59Z","isPatch":true,"sender":{"key":"rctay89@gmail.com","avatar":"https://avatars.githubusercontent.com/u/61553?v=4"},"body":"Hi,\n\nOn Sun, Jun 7, 2009 at 2:04 AM, Junio C Hamano<gitster@pobox.com> wrote:\n> Thanks, will queue, but please double check the result after I push it\n> out, as I found some other changes not listed above, relative to what was\n> queued in 'pu' (I am not complaining; I am asking your extra set of\n> eyeballs in case I somehow screwed up applying your series to my tree).\n>\n>  - return value of fetch_indices() is 0 when http_get_info_packs() returns\n>   HTTP_MISSING_TARGET (both in http-push.c and http-walker.c);\n\nThis is correct. I had noted this in the patch; perhaps I should have\nincluded it in the cover letter.\n\n>  - break the function definition of run_request_queue() by removing \"void\"\n>   from the parameter list (\"send out fetch requests on queue\" -- no need\n>   to resend, I fixed it up again while applying);\n\nMy bad. I hadn't noticed that you've already been doing this.\n\n>  - update the error checking in transport.c:get_refs_via_curl() to make it\n>   look more similar to what are in fetch_indices() in both http-push.c and\n>   http-walker.c.\n\nYes. I noted this in the patch text.\n\n>  - add unused \"cleanup:\" label to get_refs_via_curl() in transport.c\n>   (again no need to resend, I fixed it up while applying);\n\nIndeed. It was an uncaught consequence of the previous change.\n\n>  - add back a few missing \"->local = NULL\" I screwed up while applying the\n>   previous series.\n\nI'll have to take a look at those.\n\n> By the way, this is not your fault at all, but for a patch series\n> description, \"shortlog\" is a sucky way, as we can see below.  When you\n> talk about \"patch #15\", the reader cannot find which one you are talking\n> about but has to go back to the MUA, so the list is useless for that\n> purpose.\n\nIs there a way to do this with git-format-patch? (\"this\" being a list\nof numbered patches, instead of them being grouped by author)\n\n-- \nCheers,\nRay Chuan\n"},{"id":"115679","messageId":"be6fef0d0906061745q1cd65958raff19241b221e447@mail.gmail.com","threadId":"19710","inReplyTo":"m3tz2t43xr.fsf@localhost.localdomain","subject":"Re: [PATCH 00/23] http*: refactor (v6)","fromName":"Tay Ray Chuan","fromEmail":"rctay89@gmail.com","sentAt":"2009-06-07T00:45:50Z","receivedAt":"2009-06-07T00:45:50Z","isPatch":true,"sender":{"key":"rctay89@gmail.com","avatar":"https://avatars.githubusercontent.com/u/61553?v=4"},"body":"Hi,\n\nOn Sun, Jun 7, 2009 at 2:23 AM, Jakub Narebski<jnareb@gmail.com> wrote:\n> Before git-send-email learned --cover option, I have used the\n> following commands to generate \"Table of contents\" for a patch series:\n>  * generate patches to some subdirectory using '-o' option\n>   of git-format-patch\n>  * grep for subject and remove \"Subject:\" line:\n>   $ grep -h \"Subject:\" mdir/* | sed -e 's/Subject://' >> mdir/0000-cover.txt\n>\n> This way I had list of patches in the series in actual order...\n\nI see. I output my patches into one big mbox file; I'm sure your\ntechnique can be tailored to that.\n\nBut then, isn't there a way to do this with git-format-patch or git-something?\n\n> P.S. Tay Ray Chuan, this patch series is again not being replies to\n>     cover letter...\n\nSorry about that; I already used --thread (you can see that the\npatches all have In-Reply-To headers), but the Message-Id of the cover\nletter changed while I sent it out, so I messed up.\n\n-- \nCheers,\nRay Chuan\n"},{"id":"116001","messageId":"be6fef0d0906100336g44b75800w42cb5cd9ee33f594@mail.gmail.com","threadId":"19710","inReplyTo":"be6fef0d0906061741p6f3864a9m25d25e23ef0db760@mail.gmail.com","subject":"Re: [PATCH 00/23] http*: refactor (v6)","fromName":"Tay Ray Chuan","fromEmail":"rctay89@gmail.com","sentAt":"2009-06-10T10:36:23Z","receivedAt":"2009-06-10T10:36:23Z","isPatch":true,"sender":{"key":"rctay89@gmail.com","avatar":"https://avatars.githubusercontent.com/u/61553?v=4"},"body":"Hi,\n\nOn Sun, Jun 7, 2009 at 8:41 AM, Tay Ray Chuan<rctay89@gmail.com> wrote:\n> On Sun, Jun 7, 2009 at 2:04 AM, Junio C Hamano<gitster@pobox.com> wrote:\n>> Thanks, will queue, but please double check the result after I push it\n>> out, as I found some other changes not listed above, relative to what was\n>> queued in 'pu' (I am not complaining; I am asking your extra set of\n>> eyeballs in case I somehow screwed up applying your series to my tree).\n\nLooks ok; sorry for the trouble caused.\n\n-- \nCheers,\nRay Chuan\n"}]}