{"thread":{"id":"19134","subject":"What's in git.git (Apr 2009, #02; Wed, 29)","startedAt":"2009-04-30T05:33:25Z","lastAt":"2009-04-30T05:33:25Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"112734","messageId":"7v4ow6wvru.fsf@gitster.siamese.dyndns.org","threadId":"19134","inReplyTo":null,"subject":"What's in git.git (Apr 2009, #02; Wed, 29)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2009-04-30T05:33:25Z","receivedAt":"2009-04-30T05:33:25Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"It's been a while since I sent the \"What's in\" report.  Hopefully we can\ndo an -rc4 this weekend and then 1.6.3 final next week.\n\n* The 'maint' branch has these fixes since 1.6.2.3\n\nAllan Caffee (2):\n  builtin-merge: fix a typo in an error message\n  Documentation: fix a grammatical error in api-builtin.txt\n\nBjörn Steinbrink (1):\n  tree_entry_interesting: a pathspec only matches at directory boundary\n\nClemens Buchacher (3):\n  add tests for merging with submodules\n  update cache for conflicting submodule entries\n  simplify output of conflicting merge\n\nErik Faye-Lund (4):\n  test-suite: adding a test for fast-export with tag variants\n  builtin-fast-export.c: turn error into warning\n  builtin-fast-export.c: fix crash on tagged trees\n  builtin-fast-export.c: handle nested tags\n\nFrank Lichtenheld (2):\n  init: Do not segfault on big GIT_TEMPLATE_DIR environment variable\n  gitcvs-migration: Link to git-cvsimport documentation\n\nJeff King (2):\n  doc/gitattributes: clarify location of config text\n  add-interactive: refactor mode hunk handling\n\nJohan Herland (1):\n  Update docs on behaviour of 'core.sharedRepository' and 'git init\n    --shared'\n\nJohannes Schindelin (2):\n  Fix 'git checkout <submodule>' to update the index\n  Fix off-by-one in read_tree_recursive\n\nJohannes Sixt (1):\n  t1301-shared-repo: fix forced modes test\n\nJunio C Hamano (4):\n  match_tree_entry(): a pathspec only matches at directory boundaries\n  Describe fixes since 1.6.2.3\n  GIT 1.6.2.4\n  diff -c -p: do not die on submodules\n\nJunio Hamano (1):\n  Speed up reflog pruning of unreachable commits\n\nLinus Torvalds (2):\n  Clean up reflog unreachability pruning decision\n  grep: fix segfault when \"git grep '('\" is given\n\nMarkus Heidelberg (2):\n  doc/git-daemon: add missing arguments to options\n  doc/git-daemon: add missing arguments to max-connections option\n\nMatthieu Moy (2):\n  git add -p: new \"quit\" command at the prompt.\n  Update git-add.txt according to the new possibilities of 'git add -p'.\n\nNguyễn Thái Ngọc Duy (1):\n  Makefile: remove {fetch,send}-pack from PROGRAMS as they are builtins\n\nPaul Bolle (1):\n  imap-send: use correct configuration variable in documentation\n\nStephen Boyd (1):\n  test-genrandom: Add newline to usage string\n\nThomas Jarosch (1):\n  Fix buffer overflow in config parser\n\nUlrich Windl (1):\n  git-apply: fix option description\n\n\n* The 'master' branch has these since 1.6.3-rc0\n  in addition to the above.\n\nAlex Riesen (3):\n  Wait for git diff to finish in git difftool\n  Explain seemingly pointless use of system in difftool\n  improve error message in config.c\n\nAllan Caffee (4):\n  graph API: Added logic for colored edges\n  t4202-log: extend test coverage of graphing\n  graph API: fix extra space during pre_commit_line state\n  graph API: fix a bug in the rendering of octopus merges\n\nBen Jackson (1):\n  Work around ash \"alternate value\" expansion bug\n\nBenjamin Kramer (2):\n  connect: replace inet_ntop with getnameinfo\n  daemon.c: fix segfault on OS X\n\nBert Wesarg (3):\n  shorten_unambiguous_ref(): add strict mode\n  for-each-ref: utilize core.warnAmbiguousRefs for :short-format\n  rev-parse: --abbrev-ref option to shorten ref name\n\nBill Pemberton (1):\n  Add parsing of elm aliases to git-send-email\n\nBrandon Casey (2):\n  t9001: use older Getopt::Long boolean prefix '--no' rather than '--no-'\n  t7700-repack: repack -a now works properly, expect success from test\n\nDan Loewenherz (1):\n  Convert to use quiet option when available\n\nDavid Aguilar (11):\n  difftool: remove merge options for opendiff, tkdiff, kdiff3 and xxdiff\n  difftool: remove the backup file feature\n  difftool: use perl built-ins when testing for msys\n  difftool: add a -y shortcut for --no-prompt\n  difftool: move 'git-difftool' out of contrib\n  difftool: add various git-difftool tests\n  difftool: add support for a difftool.prompt config variable\n  bash completion: add git-difftool\n  mergetool: use $( ... ) instead of `backticks`\n  difftool/mergetool: refactor commands to use git-mergetool--lib\n  mergetool--lib: simplify API usage by removing more global variables\n\nEric Blake (2):\n  Makefile: installing git in cygwin 1.7.0\n  doc: consistently use ASCIIDOC_EXTRA\n\nErik Broes (1):\n  git-shell: Add 'git-upload-archive' to allowed commands.\n\nFelipe Contreras (1):\n  git config: error when editing a repo config and not being in one\n\nFerry Huberts (1):\n  Fix misspelled mergetool.keepBackup\n\nHolger Weiß (1):\n  gitweb: Fix snapshots requested via PATH_INFO\n\nJeff King (8):\n  doc: clarify --no-track option\n  doc: refer to tracking configuration as \"upstream\"\n  doc/checkout: refer to git-branch(1) as appropriate\n  doc/checkout: split checkout and branch creation in synopsis\n  docs/checkout: clarify what \"non-branch\" means\n  add-interactive: refactor mode hunk handling\n  t7800: respect NO_PERL\n  Makefile: fix NO_PERL bug with gitweb\n\nJohannes Schindelin (3):\n  Add an option not to use link(src, dest) && unlink(src) when that is\n    unreliable\n  t5701: do not get stuck in empty-push/\n  Rename core.unreliableHardlinks to core.createObject\n\nJohannes Sixt (5):\n  Windows: Work around intermittent failures in mingw_rename\n  Windows: Skip fstat/lstat optimization in write_entry()\n  builtin-help: silently tolerate unknown keys\n  remote.c: do not trigger remote.<name>.<var> codepath for two-level names\n  prune-packed: advanced progress even for non-existing fan-out directories\n\nJunio C Hamano (11):\n  gitignore git-bisect--helper\n  unpack-trees: do not muck with attributes when we are not checking out\n  Update draft release notes to 1.6.3\n  read-tree A B: do not corrupt cache-tree\n  Move prime_cache_tree() to cache-tree.c\n  read-tree -m A B: prime cache-tree from the switched-to tree\n  checkout branch: prime cache-tree fully\n  Revert \"stat_tracking_info(): only count real commits\"\n  Makefile: ignore perl/ subdirectory under NO_PERL\n  GIT 1.6.3-rc2\n  merge-recursive: do not die on a conflicting submodule\n\nLinus Torvalds (4):\n  Allow users to un-configure rename detection\n  process_{tree,blob}: show objects without buffering\n  show_object(): push path_name() call further down\n  t4202: fix typo\n\nMark Drago (1):\n  Add semicolon to curly brace group in main Makefile\n\nMarkus Heidelberg (4):\n  doc/merge-config: list ecmerge as a built-in merge tool\n  git-mergetool/difftool: make (g)vimdiff workable under Windows\n  git-mergetool: add new merge tool TortoiseMerge\n  grep: don't support \"grep.color\"-like config options\n\nMatthieu Moy (3):\n  git add -p: new \"quit\" command at the prompt.\n  Update git-add.txt according to the new possibilities of 'git add -p'.\n  clone: add test for push on an empty clone.\n\nMichael J Gruber (3):\n  remote.c: use shorten_unambiguous_ref\n  test-lib.sh: Help test_create_repo() find the templates dir\n  Fix more typos/spelling in comments\n\nMichał Kiedrowicz (6):\n  tests: test applying criss-cross rename patch\n  builtin-apply: keep information about files to be deleted\n  Documentation: boolean value may be given by on/off\n  tests: test applying criss-cross rename patch\n  builtin-apply: keep information about files to be deleted\n  tests: make test-apply-criss-cross-rename more robust\n\nMike Ralphson (3):\n  builtin-remote: fix typo in option description\n  Documentation: fix typos / spelling mistakes\n  Fix typos / spelling in comments\n\nNanako Shiraishi (1):\n  git-am: teach git-am to apply a patch to an unborn branch\n\nNguyễn Thái Ngọc Duy (3):\n  get_local_heads(): do not return random pointer if there is no head\n  attr: add GIT_ATTR_INDEX \"direction\"\n  archive: do not read .gitattributes in working directory\n\nNicolas Pitre (1):\n  progress bar: round to the nearest instead of truncating down\n\nPatrick Welche (1):\n  NetBSD compilation fix\n\nPierre Habouzit (1):\n  hook/update: example of how to prevent branch creation\n\nRené Scharfe (2):\n  archive tests: do not use .gitattributes in working directory\n  archive test: attributes\n\nSam Vilain (1):\n  SubmittingPatches: itemize and reflect upon well written changes\n\nSebastian Pipping (1):\n  difftool/mergetool: add diffuse as merge and diff tool\n\nSitaram Chamarty (1):\n  Remove obsolete bug warning in man git-update-server-info\n\nStephen Boyd (7):\n  config.txt: add missing format.{subjectprefix,cc,attach} variables\n  Documentation: use lowercase for shallow and deep threading\n  git-show-branch.txt: cleanup example description\n  git-format-patch.txt: general rewordings and cleanups\n  config.txt: add missing 'the's and make words plural\n  config.txt: clarify sentences in the configuration and syntax sections\n  config.txt: Make configuration paragraph more consistent\n\nUwe Kleine-König (1):\n  parseopt: fix documentation for --keep-dashdash\n\nWesley J. Landaker (4):\n  Documentation: git-svn: fix spurious bolding that mangles the output\n  Documentation: git-svn: fix a grammatical error without awkwardness\n  Documentation: git-clean: fix minor grammatical errors\n  Documentation: git-clean: make description more readable\n\nWincent Colaiuta (1):\n  git add -p: add missing \"q\" to patch prompt\n"}]}