{"thread":{"id":"16963","subject":"[PATCH] gitweb: suggest name for OPML view","startedAt":"2009-01-02T12:49:30Z","lastAt":"2009-01-10T19:45:56Z","messageCount":5,"participants":["Giuseppe Bilotta","Junio C Hamano","Jakub Narebski"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"99166","messageId":"1230900570-25324-1-git-send-email-giuseppe.bilotta@gmail.com","threadId":"16963","inReplyTo":null,"subject":"[PATCH] gitweb: suggest name for OPML view","fromName":"Giuseppe Bilotta","fromEmail":"giuseppe.bilotta@gmail.com","sentAt":"2009-01-02T12:49:30Z","receivedAt":"2009-01-02T12:49:30Z","isPatch":true,"sender":{"key":"giuseppe.bilotta@gmail.com","avatar":"https://avatars.githubusercontent.com/u/1464?v=4"},"body":"Suggest opml.xml as name for OPML view by providing the appropriate\nheader, consistently with similar usage in project_index view.\n\nSigned-off-by: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>\n---\n gitweb/gitweb.perl |    6 +++++-\n 1 files changed, 5 insertions(+), 1 deletions(-)\n\ndiff --git a/gitweb/gitweb.perl b/gitweb/gitweb.perl\nindex b164001..995bc1a 100755\n--- a/gitweb/gitweb.perl\n+++ b/gitweb/gitweb.perl\n@@ -6122,7 +6122,11 @@ sub git_atom {\n sub git_opml {\n \tmy @list = git_get_projects_list();\n \n-\tprint $cgi->header(-type => 'text/xml', -charset => 'utf-8');\n+\tprint $cgi->header(\n+\t\t-type => 'text/xml',\n+\t\t-charset => 'utf-8',\n+\t\t-content_disposition => 'inline; filename=\"opml.xml\"');\n+\n \tprint <<XML;\n <?xml version=\"1.0\" encoding=\"utf-8\"?>\n <opml version=\"1.0\">\n-- \n1.5.6.5\n"},{"id":"99435","messageId":"7vhc4cluex.fsf@gitster.siamese.dyndns.org","threadId":"16963","inReplyTo":"1230900570-25324-1-git-send-email-giuseppe.bilotta@gmail.com","subject":"Re: [PATCH] gitweb: suggest name for OPML view","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2009-01-06T08:18:14Z","receivedAt":"2009-01-06T08:18:14Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Giuseppe Bilotta <giuseppe.bilotta@gmail.com> writes:\n\n> Suggest opml.xml as name for OPML view by providing the appropriate\n> header, consistently with similar usage in project_index view.\n>\n> Signed-off-by: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>\n\nI think this makes sense; will apply unless there is any objection.\n"},{"id":"99891","messageId":"200901101510.20918.jnareb@gmail.com","threadId":"16963","inReplyTo":"1230900570-25324-1-git-send-email-giuseppe.bilotta@gmail.com","subject":"Re: [PATCH] gitweb: suggest name for OPML view","fromName":"Jakub Narebski","fromEmail":"jnareb@gmail.com","sentAt":"2009-01-10T14:10:20Z","receivedAt":"2009-01-10T14:10:20Z","isPatch":true,"sender":{"key":"jnareb@gmail.com","avatar":"https://avatars.githubusercontent.com/u/2706?v=4"},"body":"On Fri, 2 Jan 2009, Giuseppe Bilotta wrote:\n\n> Suggest opml.xml as name for OPML view by providing the appropriate\n> header, consistently with similar usage in project_index view.\n\nIt is not name for a view, but more of default filename when saving\nit. While it is good idea to have consistency, I guess that while\n'project_index' view and other non-HTML views are meant to be \ndownloaded and saved (snapshots, patches, patchsets), OPML view\nis meant to be used on-line, just like web feeds in RSS and Atom\nformats which are non-HTML too but do not have Content-Disposition\nheader set. \n\nBut I do not use OPML. Anyone?\n\n> \n> Signed-off-by: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>\n> ---\n>  gitweb/gitweb.perl |    6 +++++-\n>  1 files changed, 5 insertions(+), 1 deletions(-)\n> \n> diff --git a/gitweb/gitweb.perl b/gitweb/gitweb.perl\n> index b164001..995bc1a 100755\n> --- a/gitweb/gitweb.perl\n> +++ b/gitweb/gitweb.perl\n> @@ -6122,7 +6122,11 @@ sub git_atom {\n>  sub git_opml {\n>  \tmy @list = git_get_projects_list();\n>  \n> -\tprint $cgi->header(-type => 'text/xml', -charset => 'utf-8');\n> +\tprint $cgi->header(\n> +\t\t-type => 'text/xml',\n> +\t\t-charset => 'utf-8',\n> +\t\t-content_disposition => 'inline; filename=\"opml.xml\"');\n> +\n>  \tprint <<XML;\n>  <?xml version=\"1.0\" encoding=\"utf-8\"?>\n>  <opml version=\"1.0\">\n> -- \n> 1.5.6.5\n> \n> \n\n-- \nJakub Narebski\nPoland\n"},{"id":"99917","messageId":"cb7bb73a0901101115i541f0911o42f08fc47820fb82@mail.gmail.com","threadId":"16963","inReplyTo":"200901101510.20918.jnareb@gmail.com","subject":"Re: [PATCH] gitweb: suggest name for OPML view","fromName":"Giuseppe Bilotta","fromEmail":"giuseppe.bilotta@gmail.com","sentAt":"2009-01-10T19:15:48Z","receivedAt":"2009-01-10T19:15:48Z","isPatch":true,"sender":{"key":"giuseppe.bilotta@gmail.com","avatar":"https://avatars.githubusercontent.com/u/1464?v=4"},"body":"On Sat, Jan 10, 2009 at 9:10 AM, Jakub Narebski <jnareb@gmail.com> wrote:\n> On Fri, 2 Jan 2009, Giuseppe Bilotta wrote:\n>\n>> Suggest opml.xml as name for OPML view by providing the appropriate\n>> header, consistently with similar usage in project_index view.\n>\n> It is not name for a view, but more of default filename when saving\n> it. While it is good idea to have consistency, I guess that while\n> 'project_index' view and other non-HTML views are meant to be\n> downloaded and saved (snapshots, patches, patchsets), OPML view\n> is meant to be used on-line, just like web feeds in RSS and Atom\n> formats which are non-HTML too but do not have Content-Disposition\n> header set.\n\nOPML is used for import/export of RSS feed lists between aggregators\n(e.g. moving your reading list from knewsreader to google reader). As\nsuch, it can also be comfortable to save it to disk for import by some\ntools. IMO, of course. And there's also the consistency thing, and not\nactual reason _not_ to offer the filename, since it comes pretty\ncheap.\n\n-- \nGiuseppe \"Oblomov\" Bilotta\n"},{"id":"99919","messageId":"200901102045.57589.jnareb@gmail.com","threadId":"16963","inReplyTo":"cb7bb73a0901101115i541f0911o42f08fc47820fb82@mail.gmail.com","subject":"Re: [PATCH] gitweb: suggest name for OPML view","fromName":"Jakub Narebski","fromEmail":"jnareb@gmail.com","sentAt":"2009-01-10T19:45:56Z","receivedAt":"2009-01-10T19:45:56Z","isPatch":true,"sender":{"key":"jnareb@gmail.com","avatar":"https://avatars.githubusercontent.com/u/2706?v=4"},"body":"Giuseppe Bilotta wrote:\n> On Sat, Jan 10, 2009 at 9:10 AM, Jakub Narebski <jnareb@gmail.com> wrote:\n>> On Fri, 2 Jan 2009, Giuseppe Bilotta wrote:\n>>\n>>> Suggest opml.xml as name for OPML view by providing the appropriate\n>>> header, consistently with similar usage in project_index view.\n>>\n>> It is not name for a view, but more of default filename when saving\n>> it. While it is good idea to have consistency, I guess that while\n>> 'project_index' view and other non-HTML views are meant to be\n>> downloaded and saved (snapshots, patches, patchsets), OPML view\n>> is meant to be used on-line, just like web feeds in RSS and Atom\n>> formats which are non-HTML too but do not have Content-Disposition\n>> header set.\n> \n> OPML is used for import/export of RSS feed lists between aggregators\n> (e.g. moving your reading list from knewsreader to google reader). As\n> such, it can also be comfortable to save it to disk for import by some\n> tools. IMO, of course. [...]\n\nIf it is used in such way, then I am all for it (and of course for\nconsistency with 'projects_index' view).\n\nAcked-by: Jakub Narebski <jnareb@gmail.com>\n\n-- \nJakub Narebski\nPoland\n"}]}