{"thread":{"id":"16571","subject":"What's in git.git (Dec 2008, #01; Tue, 02)","startedAt":"2008-12-03T06:23:58Z","lastAt":"2008-12-04T19:37:36Z","messageCount":7,"participants":["Junio C Hamano","Teemu Likonen","Jeff King"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"97024","messageId":"7vvdu1hj41.fsf@gitster.siamese.dyndns.org","threadId":"16571","inReplyTo":null,"subject":"What's in git.git (Dec 2008, #01; Tue, 02)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-12-03T06:23:58Z","receivedAt":"2008-12-03T06:23:58Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"We'll probably have 1.6.0.5 by the end of this week.\n\nThe tip of the 'master' branch is at 1.6.1-rc1 with a few more fixes.\nHopefully we will have the final 1.6.1 by the end of the year.\n\n* The 'maint' branch has these fixes since the last announcement.\n\nJoey Hess (1):\n  sha1_file: avoid bogus \"file exists\" error message\n\nJohannes Schindelin (1):\n  fast-export: use an unsorted string list for extra_refs\n\nJunio C Hamano (1):\n  Update draft release notes to 1.6.0.5\n\nMartin Koegler (1):\n  git push: Interpret $GIT_DIR/branches in a Cogito compatible way\n\nMatt McCutchen (1):\n  git checkout: don't warn about unborn branch if -f is already passed\n\nMiklos Vajna (2):\n  Add new testcase to show fast-export does not always exports all tags\n  User's Manual: remove duplicated url at the end of Appendix B\n\nNguyễn Thái Ngọc Duy (1):\n  generate-cmdlist.sh: avoid selecting synopsis at wrong place\n\nPete Wyckoff (1):\n  git-p4: fix keyword-expansion regex\n\nRalf Wildenhues (1):\n  Fix typos in the documentation.\n\nSZEDER Gábor (2):\n  bash: remove dashed command leftovers\n  bash: offer refs instead of filenames for 'git revert'\n\nSam Vilain (1):\n  sha1_file.c: resolve confusion EACCES vs EPERM\n\nSamuel Tardieu (2):\n  tag: Check that options are only allowed in the appropriate mode\n  tag: Add more tests about mixing incompatible modes and options\n\n\n* The 'master' branch has these since the last announcement\n  in addition to the above.\n\nAlexander Gavrilov (3):\n  gitk: Avoid handling the Return key twice in Add Branch\n  gitk: Make line origin search update the busy status\n  gitk: Add a menu option to start git gui\n\nCheng Renquan (1):\n  git-remote: add verbose mode to git remote update\n\nChristian Couder (4):\n  git-gui: french translation update\n  bisect: teach \"skip\" to accept special arguments like \"A..B\"\n  bisect: fix \"git bisect skip <commit>\" and add tests cases\n  Documentation: describe how to \"bisect skip\" a range of commits\n\nChristian Stimming (1):\n  gitk: Update German translation\n\nGiuseppe Bilotta (2):\n  gitweb: make gitweb_check_feature a boolean wrapper\n  Update comment on gitweb_check/get_feature\n\nJohannes Schindelin (1):\n  Document levenshtein.c\n\nJohannes Sixt (2):\n  compat/mingw.c: Teach mingw_rename() to replace read-only files\n  t4030-diff-textconv: Make octal escape sequence more portable\n\nJunio C Hamano (6):\n  gitweb: fix 'ctags' feature check and others\n  gitweb: rename gitweb_check_feature to gitweb_get_feature\n  send-email: do not reverse the command line arguments\n  Include git-gui--askpass in git-gui RPM package\n  GIT 1.6.1-rc1\n  Makefile: introduce NO_PTHREADS\n\nLinus Torvalds (3):\n  Add cache preload facility\n  Fix index preloading for racy dirty case\n  Add backslash to list of 'crud' characters in real name\n\nMark Burton (1):\n  git-gui: Teach start_push_anywhere_action{} to notice when remote is a\n    mirror.\n\nMichele Ballabio (1):\n  git gui: update Italian translation\n\nMiklos Vajna (5):\n  Update Hungarian translation. 100% completed.\n  builtin-clone: use strbuf in guess_dir_name()\n  builtin-clone: use strbuf in clone_local() and copy_or_link_directory()\n  builtin_clone: use strbuf in cmd_clone()\n  git-stash: use git rev-parse -q\n\nNanako Shiraishi (1):\n  git-gui: update Japanese translation\n\nPaul Mackerras (6):\n  gitk: Index line[hnd]tag arrays by id rather than row number\n  gitk: Fix switch statement in parseviewargs\n  gitk: Show local changes properly when we have a path limit\n  gitk: Fix context menu items for generating diffs when in tree mode\n  gitk: Highlight only when search type is \"containing:\".\n  gitk: Fix bug in accessing undefined \"notflag\" variable\n\nPeter Krefting (1):\n  Updated Swedish translation (514t0f0u).\n\nPierre Habouzit (4):\n  git send-email: make the message file name more specific.\n  git send-email: interpret unknown files as revision lists\n  git send-email: add --annotate option\n  git send-email: ask less questions when --compose is used.\n\nRalf Wildenhues (1):\n  Fix typos in the documentation.\n\nRené Scharfe (6):\n  add strbuf_expand_dict_cb(), a helper for simple cases\n  merge-recursive: use strbuf_expand() instead of interpolate()\n  daemon: use strbuf_expand() instead of interpolate()\n  daemon: inline fill_in_extra_table_entries()\n  daemon: deglobalize variable 'directory'\n  remove the unused files interpolate.c and interpolate.h\n\nSZEDER Gábor (1):\n  bash: complete full refs\n\nSamuel Tardieu (1):\n  Fix deletion of last character in levenshtein distance\n\nScott Chacon (1):\n  Add a built-in alias for 'stage' to the 'add' command\n\nTuncer Ayaz (2):\n  Teach/Fix pull/fetch -q/-v options\n  Retain multiple -q/-v occurrences in git pull\n"},{"id":"97027","messageId":"87myfdn2ga.fsf@iki.fi","threadId":"16571","inReplyTo":"7vvdu1hj41.fsf@gitster.siamese.dyndns.org","subject":"\"git help stage\" doesn't display git-stage man page","fromName":"Teemu Likonen","fromEmail":"tlikonen@iki.fi","sentAt":"2008-12-03T07:27:17Z","receivedAt":"2008-12-03T07:27:17Z","isPatch":false,"sender":{"key":"tlikonen@iki.fi","avatar":null},"body":"Junio C Hamano (2008-12-02 22:23 -0800) wrote:\n\n> * The 'master' branch has these since the last announcement\n>   in addition to the above.\n\n> Scott Chacon (1):\n>   Add a built-in alias for 'stage' to the 'add' command\n\nI think there's a minor user-interface defect:\n\n    $ git help stage\n    No manual entry for gitstage\n\n\"git stage\" is only a built-in alias but at some point it may become the\nprimary staging command for new Git users and hence a kind of real Git\ncommand. I think \"git help stage\" should show the git-stage manual page\n(even though it only points to git-add(1)).\n"},{"id":"97031","messageId":"7vwsehfzf7.fsf@gitster.siamese.dyndns.org","threadId":"16571","inReplyTo":"87myfdn2ga.fsf@iki.fi","subject":"Re: \"git help stage\" doesn't display git-stage man page","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-12-03T08:14:36Z","receivedAt":"2008-12-03T08:14:36Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Teemu Likonen <tlikonen@iki.fi> writes:\n\n> Junio C Hamano (2008-12-02 22:23 -0800) wrote:\n>\n>> * The 'master' branch has these since the last announcement\n>>   in addition to the above.\n>\n>> Scott Chacon (1):\n>>   Add a built-in alias for 'stage' to the 'add' command\n>\n> I think there's a minor user-interface defect:\n>\n>     $ git help stage\n>     No manual entry for gitstage\n\nThe patch also breaks the promise made at 1.6.0 that prepending exec path\nto $PATH allows you to use the dashed form.\n\n\t$ PATH=$(git --exec-path):$PATH\n        $ git-stage -p\n\txash: git-stage: cmd not found\n\n> \"git stage\" is only a built-in alias but at some point it may become the\n> primary staging command for new Git users and hence a kind of real Git\n> command. I think \"git help stage\" should show the git-stage manual page\n> (even though it only points to git-add(1)).\n\nI do not think it would ever be _the_ primary command to add the contents\nto the index; we are adding it as a training wheel.\n\nWhen we had the \"staging area\" discussion, somehow people ended up with\nthis notion that you somehow *need to* use the same verb and noun.\nI.e. \"the index is now explained as the _staging area_.  Why isn't the\ncommand to add contents to the staging area called git-stage?\" was the\nprimary argument that lead to this thinking.\n\nI do not think it adds much value to the system to be dogmatic and insist\nthat you _have to_ use the same verb and noun.  \"You add your changes to\nthe staging area\" is a perfectly natural way to explain what you are doing\nand where the \"add\" in git-add command comes from.  It however is Ok to\nallow people to use different spelling (i.e. the verb \"stage\").\n\nIn that sense, I think the intention of the patch to add \"stage\" as an\nadditional verb, while clearly marking it as a synonym to the primary\ncommand \"add\", is aimed at the right place and strikes the right balance.\n\nBy the way, I think this should fix it, although it is very late and I\nhave no time to test it tonight myself.\n\n---\n\n Makefile |    1 +\n 1 files changed, 1 insertions(+), 0 deletions(-)\n\ndiff --git i/Makefile w/Makefile\nindex 9577d6f..5158197 100644\n--- i/Makefile\n+++ w/Makefile\n@@ -320,6 +320,7 @@ BUILT_INS += git-merge-subtree$X\n BUILT_INS += git-peek-remote$X\n BUILT_INS += git-repo-config$X\n BUILT_INS += git-show$X\n+BUILT_INS += git-stage$X\n BUILT_INS += git-status$X\n BUILT_INS += git-whatchanged$X\n \n"},{"id":"97034","messageId":"87bpvtmzkt.fsf@iki.fi","threadId":"16571","inReplyTo":"7vwsehfzf7.fsf@gitster.siamese.dyndns.org","subject":"Re: \"git help stage\" doesn't display git-stage man page","fromName":"Teemu Likonen","fromEmail":"tlikonen@iki.fi","sentAt":"2008-12-03T08:29:22Z","receivedAt":"2008-12-03T08:29:22Z","isPatch":false,"sender":{"key":"tlikonen@iki.fi","avatar":null},"body":"Junio C Hamano (2008-12-03 00:14 -0800) wrote:\n\n> By the way, I think this should fix it, although it is very late and I\n> have no time to test it tonight myself.\n\nIt does fix it for me. Thanks.\n\n\n> diff --git i/Makefile w/Makefile\n> index 9577d6f..5158197 100644\n> --- i/Makefile\n> +++ w/Makefile\n> @@ -320,6 +320,7 @@ BUILT_INS += git-merge-subtree$X\n>  BUILT_INS += git-peek-remote$X\n>  BUILT_INS += git-repo-config$X\n>  BUILT_INS += git-show$X\n> +BUILT_INS += git-stage$X\n>  BUILT_INS += git-status$X\n>  BUILT_INS += git-whatchanged$X\n"},{"id":"97035","messageId":"7vmyfdfyi9.fsf@gitster.siamese.dyndns.org","threadId":"16571","inReplyTo":"7vwsehfzf7.fsf@gitster.siamese.dyndns.org","subject":"Re: \"git help stage\" doesn't display git-stage man page","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-12-03T08:34:22Z","receivedAt":"2008-12-03T08:34:22Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> Teemu Likonen <tlikonen@iki.fi> writes:\n>\n>>> Scott Chacon (1):\n>>>   Add a built-in alias for 'stage' to the 'add' command\n>>\n>> I think there's a minor user-interface defect:\n>>\n>>     $ git help stage\n>>     No manual entry for gitstage\n>\n> ...\n> In that sense, I think the intention of the patch to add \"stage\" as an\n> additional verb, while clearly marking it as a synonym to the primary\n> command \"add\", is aimed at the right place and strikes the right balance.\n>\n> By the way, I think this should fix it, although it is very late and I\n> have no time to test it tonight myself.\n\nOk, I lied.  I'll go to bed after committing this.\n\n-- >8 --\nFrom: Junio C Hamano <gitster@pobox.com>\nDate: Wed, 3 Dec 2008 00:30:34 -0800\nSubject: [PATCH] Install git-stage in exec-path\n\nEarlier the plan was to eventually eradicate git-foo executables from the\nfilesystem for all the built-in commands, but when we released 1.6.0 we\ndecided not to do so.  Instead, it has been promised that by prepending\nthe output from $(git --exec-path) to your $PATH, you can keep using the\ndashed form of commands.\n\nThis also allows \"git stage\" to appear in the autogenerated command list,\nwhich is used to offer man pages by \"git help\" command.\n\nSigned-off-by: Junio C Hamano <gitster@pobox.com>\n---\n Makefile |    1 +\n 1 files changed, 1 insertions(+), 0 deletions(-)\n\ndiff --git a/Makefile b/Makefile\nindex 9577d6f..5158197 100644\n--- a/Makefile\n+++ b/Makefile\n@@ -320,6 +320,7 @@ BUILT_INS += git-merge-subtree$X\n BUILT_INS += git-peek-remote$X\n BUILT_INS += git-repo-config$X\n BUILT_INS += git-show$X\n+BUILT_INS += git-stage$X\n BUILT_INS += git-status$X\n BUILT_INS += git-whatchanged$X\n \n-- \n1.6.1.rc1.44.g06a3\n"},{"id":"97131","messageId":"20081204034203.GA12835@coredump.intra.peff.net","threadId":"16571","inReplyTo":"7vmyfdfyi9.fsf@gitster.siamese.dyndns.org","subject":"Re: \"git help stage\" doesn't display git-stage man page","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2008-12-04T03:42:03Z","receivedAt":"2008-12-04T03:42:03Z","isPatch":false,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Wed, Dec 03, 2008 at 12:34:22AM -0800, Junio C Hamano wrote:\n\n> diff --git a/Makefile b/Makefile\n> index 9577d6f..5158197 100644\n> --- a/Makefile\n> +++ b/Makefile\n> @@ -320,6 +320,7 @@ BUILT_INS += git-merge-subtree$X\n>  BUILT_INS += git-peek-remote$X\n>  BUILT_INS += git-repo-config$X\n>  BUILT_INS += git-show$X\n> +BUILT_INS += git-stage$X\n>  BUILT_INS += git-status$X\n>  BUILT_INS += git-whatchanged$X\n\nWe need this, too, then.\n\n-- >8 --\nadd stage to gitignore\n\nThis is a generated builtin since 24b1f65f (Install git-stage in\nexec-path).\n\nSigned-off-by: Jeff King <peff@peff.net>\n---\n .gitignore |    1 +\n 1 files changed, 1 insertions(+), 0 deletions(-)\n\ndiff --git a/.gitignore b/.gitignore\nindex 0c35577..327e660 100644\n--- a/.gitignore\n+++ b/.gitignore\n@@ -118,6 +118,7 @@ git-show\n git-show-branch\n git-show-index\n git-show-ref\n+git-stage\n git-stash\n git-status\n git-stripspace\n-- \n1.6.1.rc1.309.g51074\n"},{"id":"97167","messageId":"7vzljbd94v.fsf@gitster.siamese.dyndns.org","threadId":"16571","inReplyTo":"20081204034203.GA12835@coredump.intra.peff.net","subject":"Re: \"git help stage\" doesn't display git-stage man page","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-12-04T19:37:36Z","receivedAt":"2008-12-04T19:37:36Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Jeff King <peff@peff.net> writes:\n\n> On Wed, Dec 03, 2008 at 12:34:22AM -0800, Junio C Hamano wrote:\n>\n>> diff --git a/Makefile b/Makefile\n>> index 9577d6f..5158197 100644\n>> --- a/Makefile\n>> +++ b/Makefile\n>> @@ -320,6 +320,7 @@ BUILT_INS += git-merge-subtree$X\n>>  BUILT_INS += git-peek-remote$X\n>>  BUILT_INS += git-repo-config$X\n>>  BUILT_INS += git-show$X\n>> +BUILT_INS += git-stage$X\n>>  BUILT_INS += git-status$X\n>>  BUILT_INS += git-whatchanged$X\n>\n> We need this, too, then.\n\nGood catch, thanks.\n"}]}