{"thread":{"id":"16416","subject":"Re: Challenge of setting up git server (repository). Please help!","startedAt":"2008-11-21T00:14:59Z","lastAt":"2008-11-21T07:22:24Z","messageCount":3,"participants":["Gary Yang","Mike Galbraith"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"96294","messageId":"563817.77498.qm@web37903.mail.mud.yahoo.com","threadId":"16416","inReplyTo":null,"subject":"Re: Challenge of setting up git server (repository). Please help!","fromName":"Gary Yang","fromEmail":"garyyang6@yahoo.com","sentAt":"2008-11-21T00:14:59Z","receivedAt":"2008-11-21T00:14:59Z","isPatch":false,"sender":{"key":"garyyang6@yahoo.com","avatar":null},"body":"Kill the process, then\n\nsudo xinetd -stayalive -pidfile /var/run/xinetd.pid\n\nPlease let me know if it is correct.  Thanks.\n\n\n--- On Thu, 11/20/08, Gary Yang <garyyang6@yahoo.com> wrote:\n\n> From: Gary Yang <garyyang6@yahoo.com>\n> Subject: Re: Challenge of setting up git server (repository). Please help!\n> To: \"J.H.\" <warthog19@eaglescrag.net>\n> Cc: \"Deskin Miller\" <deskinm@umich.edu>, git@vger.kernel.org\n> Date: Thursday, November 20, 2008, 4:12 PM\n> I am not system admin. How to restart it? Can I do this?\n> \n> sudo xinetd -stayalive -pidfile /var/run/xinetd.pid\n> \n> \n> Below is the output of current running xinetd\n> \n> ps -efww | grep xinetd\n> root      8874     1  0 Sep24 ?        00:00:00 xinetd\n> -stayalive -pidfile /var/run/xinetd.pid\n> \n> \n> Thanks.\n> \n> \n> --- On Thu, 11/20/08, J.H. <warthog19@eaglescrag.net>\n> wrote:\n> \n> > From: J.H. <warthog19@eaglescrag.net>\n> > Subject: Re: Challenge of setting up git server\n> (repository). Please help!\n> > To: garyyang6@yahoo.com\n> > Cc: \"Deskin Miller\"\n> <deskinm@umich.edu>, git@vger.kernel.org\n> > Date: Thursday, November 20, 2008, 3:59 PM\n> > Yes.\n> > \n> > - John 'Warthog9' Hawley\n> > Chief Kernel.org Administrator\n> > \n> > \n> > On Thu, 2008-11-20 at 15:54 -0800, Gary Yang wrote:\n> > > Do I need to restart  xinetd after I made changes\n> in\n> > /etc/xinetd.d/git-daemon?\n> > > \n> > > \n> > > --- On Thu, 11/20/08, Gary Yang\n> > <garyyang6@yahoo.com> wrote:\n> > > \n> > > > From: Gary Yang <garyyang6@yahoo.com>\n> > > > Subject: Re: Challenge of setting up git\n> server\n> > (repository). Please help!\n> > > > To: \"Deskin Miller\"\n> > <deskinm@umich.edu>\n> > > > Cc: git@vger.kernel.org\n> > > > Date: Thursday, November 20, 2008, 3:48 PM\n> > > > I ran the command,\"sudo\n> > > > /usr/local/libexec/git-core/git-daemon\n> git-daemon\n> > > > --export-all /pub/git &\" at public\n> > repository\n> > > > machine.\n> > > > \n> > > > At my private machine, I ran, git pull\n> > > > git://svdcgit01.amcc.com/pub/git/u-boot.git\n> > HEAD\"\n> > > > \n> > > > I got: \"fatal: The remote end hung up\n> > > > unexpectedly\"\n> > > > \n> > > > At the public repository server, I got\n> > > > \"'/pub/git/u-boot.git':\n> repository\n> > not\n> > > > exported.\" Any idea of this error?\n> > > > \n> > > > \n> > > > ps -A | grep inetd\n> > > >  8874 ?        00:00:00 xinetd\n> > > > \n> > > > It means it uses xinetd.\n> > > > \n> > > > I copied git-daemon back to /etc/xinetd.d\n> and\n> > added\n> > > > git-daemon to the server_args. See below:\n> > > > \n> > > > cat /etc/xinetd.d/git-daemon\n> > > > # default: off\n> > > > # description: The git server offers access\n> to\n> > git\n> > > > repositories\n> > > > service git\n> > > > {\n> > > >         disable = no\n> > > >         type            = UNLISTED\n> > > >         port            = 9418\n> > > >         socket_type     = stream\n> > > >         wait            = no\n> > > >         user            = nobody\n> > > >         server          =\n> > > > /usr/local/libexec/git-core/git-daemon\n> > > >         server_args     = git-daemon --inetd\n> > --export-all\n> > > > --base-path=/pub/git\n> > > >         log_on_failure  += USERID\n> > > > }\n> > > > \n> > > > \n> > > > I kill the daemon\n> > > > \"/usr/local/libexec/git-core/git-daemon\n> > git-daemon\n> > > > --export-all /pub/git &\". \n> > > > \n> > > > Back to my private box, and did git pull. I\n> got\n> > Connection\n> > > > refused again. what I did wrong?\n> > > > \n> > > > git pull\n> > git://svdcgit01.amcc.com/pub/git/u-boot.git HEAD\n> > > > svdcgit01.amcc.com[0: 10.66.4.168]:\n> > errno=Connection\n> > > > refused\n> > > > fatal: unable to connect a socket\n> (Connection\n> > refused)\n> > > > \n> > > > \n> > > > \n> > > > \n> > > > --- On Thu, 11/20/08, Deskin Miller\n> > > > <deskinm@umich.edu> wrote:\n> > > > \n> > > > > From: Deskin Miller\n> > <deskinm@umich.edu>\n> > > > > Subject: Re: Challenge of setting up\n> git\n> > server\n> > > > (repository). Please help!\n> > > > > To: \"Gary Yang\"\n> > <garyyang6@yahoo.com>\n> > > > > Cc: git@vger.kernel.org\n> > > > > Date: Thursday, November 20, 2008, 3:08\n> PM\n> > > > > On Thu, Nov 20, 2008 at 02:43:30PM\n> -0800,\n> > Gary Yang\n> > > > wrote:\n> > > > > > Many thanks for your explanation.\n> I\n> > hope I\n> > > > understand\n> > > > > what you said. I deleted\n> > /etc/xinetd.d/git-daemon.\n> > > > Then, I\n> > > > > tried to git pull. But, I got\n> connection\n> > refused. git\n> > > > uses\n> > > > > port 9418. Should I request IT Admin to\n> open\n> > the port\n> > > > 9418\n> > > > > for me?\n> > > > > \n> > > > > You'll need port 9418 open, yes;\n> but\n> > since\n> > > > it's an\n> > > > > unprivileged port (1024 or\n> > > > > higher), you can use it as a regular\n> user\n> > and\n> > > > don't\n> > > > > need IT intervention unless you have\n> some\n> > firewall set\n> > > > up\n> > > > > which they need to override for you.\n> > > > > \n> > > > > > git pull\n> > > > git://git.mycompany.com/pub/git/u-boot.git\n> > > > > HEAD\n> > > > > > git.mycompany.com[0: 10.66.4.168]:\n> > > > errno=Connection\n> > > > > refused\n> > > > > > fatal: unable to connect a socket\n> > (Connection\n> > > > refused)\n> > > > > \n> > > > > It's possible, and likely simpler,\n> to\n> > use\n> > > > git-daemon\n> > > > > directly, instead of\n> > > > > having it be managed by inetd;\n> especially\n> > for initial\n> > > > > debugging, I'd recommend\n> > > > > getting that working before trying to\n> > determine if\n> > > > > you're having issues with\n> > > > > inetd configuration: to do so, just run\n> > git-daemon\n> > > > with all\n> > > > > the same arguments\n> > > > > except for --inetd.\n> > > > > \n> > > > > You said you deleted the xinetd config,\n> but\n> > that's\n> > > > only\n> > > > > relevant if your\n> > > > > machine actually uses inetd as its\n> > super-server.  You\n> > > > > should do 'ps -A | grep\n> > > > > inetd' (which will match either\n> inetd or\n> > xinetd),\n> > > > and\n> > > > > see which one is running.\n> > > > > If it's inetd, you should be all\n> set,\n> > and the\n> > > > issue\n> > > > > doesn't look like inetd\n> > > > > (assuming you sent it a signal to\n> reload its\n> > config\n> > > > file). \n> > > > > If on the other\n> > > > > hand xinetd is running, you need to use\n> the\n> > xinetd\n> > > > config\n> > > > > file, and fix the\n> > > > > server_args to look like the arguments\n> which\n> > exist in\n> > > > the\n> > > > > inetd file.  Again,\n> > > > > you need to signal xinetd at this point\n> to\n> > reload its\n> > > > > configuration.\n> > > > > \n> > > > > Based on the linux kernel version\n> you're\n> > > > reporting,\n> > > > > I'm guessing you have some\n> > > > > sort of Red Hat based system, which\n> uses\n> > xinetd to the\n> > > > best\n> > > > > of my knowledge.\n> > > > > \n> > > > > > Another question, I got no output\n> of\n> > > > \"netstat |\n> > > > > grep 9418\". It means no program\n> runs at\n> > port 9418\n> > > > at\n> > > > > the public repository machine. Is it\n> > correct?\n> > > > > > \n> > > > > > netstat | grep 9418\n> > > > > \n> > > > > netstat translates IP addresses to dns\n> > names, and\n> > > > ports to\n> > > > > service names by\n> > > > > default; so, given the line listed in\n> > /etc/services,\n> > > > this\n> > > > > will show\n> > > > > '0.0.0.0:git' or something. \n> Also,\n> > it lists\n> > > > > established connections, not\n> > > > > listening sockets, by default.  I'd\n> > recommend\n> > > > spending\n> > > > > some time with the man\n> > > > > page if you're going to use it to\n> debug\n> > your\n> > > > setup.\n> > > > > \n> > > > > Deskin Miller\n> > > > \n> > > > \n> > > >       \n> > > > --\n> > > > To unsubscribe from this list: send the line\n> > > > \"unsubscribe git\" in\n> > > > the body of a message to\n> > majordomo@vger.kernel.org\n> > > > More majordomo info at \n> > > > http://vger.kernel.org/majordomo-info.html\n> > > \n> > > \n> > >       \n> > > --\n> > > To unsubscribe from this list: send the line\n> > \"unsubscribe git\" in\n> > > the body of a message to\n> majordomo@vger.kernel.org\n> > > More majordomo info at \n> > http://vger.kernel.org/majordomo-info.html\n> > \n> > --\n> > To unsubscribe from this list: send the line\n> > \"unsubscribe git\" in\n> > the body of a message to majordomo@vger.kernel.org\n> > More majordomo info at \n> > http://vger.kernel.org/majordomo-info.html\n\n\n      \n"},{"id":"96296","messageId":"546971.60895.qm@web37907.mail.mud.yahoo.com","threadId":"16416","inReplyTo":"563817.77498.qm@web37903.mail.mud.yahoo.com","subject":"Re: Challenge of setting up git server (repository). Please help!","fromName":"Gary Yang","fromEmail":"garyyang6@yahoo.com","sentAt":"2008-11-21T00:39:08Z","receivedAt":"2008-11-21T00:39:08Z","isPatch":false,"sender":{"key":"garyyang6@yahoo.com","avatar":null},"body":"I killed xinetd. Restarted with sudo xinetd -stayalive -pidfile /var/run/xinetd.pid. \n\nI back to my private box. I did \n\ngit pull git://git.mycompany.com/pub/git/u-boot.git HEAD\n\nThis command hangs for over half hour and is still hanging. Again, below is the content of /etc/xinetd.d/git-daemon. What I did wrong?\n\ncat /etc/xinetd.d/git-daemon\n# default: off\n# description: The git server offers access to git repositories\nservice git\n{\n        disable = no\n        type            = UNLISTED\n        port            = 9418\n        socket_type     = stream\n        wait            = no\n        user            = nobody\n        server          = /usr/local/libexec/git-core/git-daemon\n        server_args     = git-daemon --inetd --export-all --base-path=/pub/git\n        log_on_failure  += USERID\n}\n\n--- On Thu, 11/20/08, Gary Yang <garyyang6@yahoo.com> wrote:\n\n> From: Gary Yang <garyyang6@yahoo.com>\n> Subject: Re: Challenge of setting up git server (repository). Please help!\n> To: \"J.H.\" <warthog19@eaglescrag.net>\n> Cc: \"Deskin Miller\" <deskinm@umich.edu>, git@vger.kernel.org\n> Date: Thursday, November 20, 2008, 4:14 PM\n> Kill the process, then\n> \n> sudo xinetd -stayalive -pidfile /var/run/xinetd.pid\n> \n> Please let me know if it is correct.  Thanks.\n> \n> \n> --- On Thu, 11/20/08, Gary Yang <garyyang6@yahoo.com>\n> wrote:\n> \n> > From: Gary Yang <garyyang6@yahoo.com>\n> > Subject: Re: Challenge of setting up git server\n> (repository). Please help!\n> > To: \"J.H.\" <warthog19@eaglescrag.net>\n> > Cc: \"Deskin Miller\"\n> <deskinm@umich.edu>, git@vger.kernel.org\n> > Date: Thursday, November 20, 2008, 4:12 PM\n> > I am not system admin. How to restart it? Can I do\n> this?\n> > \n> > sudo xinetd -stayalive -pidfile /var/run/xinetd.pid\n> > \n> > \n> > Below is the output of current running xinetd\n> > \n> > ps -efww | grep xinetd\n> > root      8874     1  0 Sep24 ?        00:00:00 xinetd\n> > -stayalive -pidfile /var/run/xinetd.pid\n> > \n> > \n> > Thanks.\n> > \n> > \n> > --- On Thu, 11/20/08, J.H.\n> <warthog19@eaglescrag.net>\n> > wrote:\n> > \n> > > From: J.H. <warthog19@eaglescrag.net>\n> > > Subject: Re: Challenge of setting up git server\n> > (repository). Please help!\n> > > To: garyyang6@yahoo.com\n> > > Cc: \"Deskin Miller\"\n> > <deskinm@umich.edu>, git@vger.kernel.org\n> > > Date: Thursday, November 20, 2008, 3:59 PM\n> > > Yes.\n> > > \n> > > - John 'Warthog9' Hawley\n> > > Chief Kernel.org Administrator\n> > > \n> > > \n> > > On Thu, 2008-11-20 at 15:54 -0800, Gary Yang\n> wrote:\n> > > > Do I need to restart  xinetd after I made\n> changes\n> > in\n> > > /etc/xinetd.d/git-daemon?\n> > > > \n> > > > \n> > > > --- On Thu, 11/20/08, Gary Yang\n> > > <garyyang6@yahoo.com> wrote:\n> > > > \n> > > > > From: Gary Yang\n> <garyyang6@yahoo.com>\n> > > > > Subject: Re: Challenge of setting up\n> git\n> > server\n> > > (repository). Please help!\n> > > > > To: \"Deskin Miller\"\n> > > <deskinm@umich.edu>\n> > > > > Cc: git@vger.kernel.org\n> > > > > Date: Thursday, November 20, 2008, 3:48\n> PM\n> > > > > I ran the command,\"sudo\n> > > > > /usr/local/libexec/git-core/git-daemon\n> > git-daemon\n> > > > > --export-all /pub/git &\" at\n> public\n> > > repository\n> > > > > machine.\n> > > > > \n> > > > > At my private machine, I ran, git pull\n> > > > >\n> git://svdcgit01.amcc.com/pub/git/u-boot.git\n> > > HEAD\"\n> > > > > \n> > > > > I got: \"fatal: The remote end hung\n> up\n> > > > > unexpectedly\"\n> > > > > \n> > > > > At the public repository server, I got\n> > > > > \"'/pub/git/u-boot.git':\n> > repository\n> > > not\n> > > > > exported.\" Any idea of this error?\n> > > > > \n> > > > > \n> > > > > ps -A | grep inetd\n> > > > >  8874 ?        00:00:00 xinetd\n> > > > > \n> > > > > It means it uses xinetd.\n> > > > > \n> > > > > I copied git-daemon back to\n> /etc/xinetd.d\n> > and\n> > > added\n> > > > > git-daemon to the server_args. See\n> below:\n> > > > > \n> > > > > cat /etc/xinetd.d/git-daemon\n> > > > > # default: off\n> > > > > # description: The git server offers\n> access\n> > to\n> > > git\n> > > > > repositories\n> > > > > service git\n> > > > > {\n> > > > >         disable = no\n> > > > >         type            = UNLISTED\n> > > > >         port            = 9418\n> > > > >         socket_type     = stream\n> > > > >         wait            = no\n> > > > >         user            = nobody\n> > > > >         server          =\n> > > > > /usr/local/libexec/git-core/git-daemon\n> > > > >         server_args     = git-daemon\n> --inetd\n> > > --export-all\n> > > > > --base-path=/pub/git\n> > > > >         log_on_failure  += USERID\n> > > > > }\n> > > > > \n> > > > > \n> > > > > I kill the daemon\n> > > > >\n> \"/usr/local/libexec/git-core/git-daemon\n> > > git-daemon\n> > > > > --export-all /pub/git &\". \n> > > > > \n> > > > > Back to my private box, and did git\n> pull. I\n> > got\n> > > Connection\n> > > > > refused again. what I did wrong?\n> > > > > \n> > > > > git pull\n> > > git://svdcgit01.amcc.com/pub/git/u-boot.git HEAD\n> > > > > svdcgit01.amcc.com[0: 10.66.4.168]:\n> > > errno=Connection\n> > > > > refused\n> > > > > fatal: unable to connect a socket\n> > (Connection\n> > > refused)\n> > > > > \n> > > > > \n> > > > > \n> > > > > \n> > > > > --- On Thu, 11/20/08, Deskin Miller\n> > > > > <deskinm@umich.edu> wrote:\n> > > > > \n> > > > > > From: Deskin Miller\n> > > <deskinm@umich.edu>\n> > > > > > Subject: Re: Challenge of setting\n> up\n> > git\n> > > server\n> > > > > (repository). Please help!\n> > > > > > To: \"Gary Yang\"\n> > > <garyyang6@yahoo.com>\n> > > > > > Cc: git@vger.kernel.org\n> > > > > > Date: Thursday, November 20, 2008,\n> 3:08\n> > PM\n> > > > > > On Thu, Nov 20, 2008 at 02:43:30PM\n> > -0800,\n> > > Gary Yang\n> > > > > wrote:\n> > > > > > > Many thanks for your\n> explanation.\n> > I\n> > > hope I\n> > > > > understand\n> > > > > > what you said. I deleted\n> > > /etc/xinetd.d/git-daemon.\n> > > > > Then, I\n> > > > > > tried to git pull. But, I got\n> > connection\n> > > refused. git\n> > > > > uses\n> > > > > > port 9418. Should I request IT\n> Admin to\n> > open\n> > > the port\n> > > > > 9418\n> > > > > > for me?\n> > > > > > \n> > > > > > You'll need port 9418 open,\n> yes;\n> > but\n> > > since\n> > > > > it's an\n> > > > > > unprivileged port (1024 or\n> > > > > > higher), you can use it as a\n> regular\n> > user\n> > > and\n> > > > > don't\n> > > > > > need IT intervention unless you\n> have\n> > some\n> > > firewall set\n> > > > > up\n> > > > > > which they need to override for\n> you.\n> > > > > > \n> > > > > > > git pull\n> > > > >\n> git://git.mycompany.com/pub/git/u-boot.git\n> > > > > > HEAD\n> > > > > > > git.mycompany.com[0:\n> 10.66.4.168]:\n> > > > > errno=Connection\n> > > > > > refused\n> > > > > > > fatal: unable to connect a\n> socket\n> > > (Connection\n> > > > > refused)\n> > > > > > \n> > > > > > It's possible, and likely\n> simpler,\n> > to\n> > > use\n> > > > > git-daemon\n> > > > > > directly, instead of\n> > > > > > having it be managed by inetd;\n> > especially\n> > > for initial\n> > > > > > debugging, I'd recommend\n> > > > > > getting that working before trying\n> to\n> > > determine if\n> > > > > > you're having issues with\n> > > > > > inetd configuration: to do so,\n> just run\n> > > git-daemon\n> > > > > with all\n> > > > > > the same arguments\n> > > > > > except for --inetd.\n> > > > > > \n> > > > > > You said you deleted the xinetd\n> config,\n> > but\n> > > that's\n> > > > > only\n> > > > > > relevant if your\n> > > > > > machine actually uses inetd as its\n> > > super-server.  You\n> > > > > > should do 'ps -A | grep\n> > > > > > inetd' (which will match\n> either\n> > inetd or\n> > > xinetd),\n> > > > > and\n> > > > > > see which one is running.\n> > > > > > If it's inetd, you should be\n> all\n> > set,\n> > > and the\n> > > > > issue\n> > > > > > doesn't look like inetd\n> > > > > > (assuming you sent it a signal to\n> > reload its\n> > > config\n> > > > > file). \n> > > > > > If on the other\n> > > > > > hand xinetd is running, you need\n> to use\n> > the\n> > > xinetd\n> > > > > config\n> > > > > > file, and fix the\n> > > > > > server_args to look like the\n> arguments\n> > which\n> > > exist in\n> > > > > the\n> > > > > > inetd file.  Again,\n> > > > > > you need to signal xinetd at this\n> point\n> > to\n> > > reload its\n> > > > > > configuration.\n> > > > > > \n> > > > > > Based on the linux kernel version\n> > you're\n> > > > > reporting,\n> > > > > > I'm guessing you have some\n> > > > > > sort of Red Hat based system,\n> which\n> > uses\n> > > xinetd to the\n> > > > > best\n> > > > > > of my knowledge.\n> > > > > > \n> > > > > > > Another question, I got no\n> output\n> > of\n> > > > > \"netstat |\n> > > > > > grep 9418\". It means no\n> program\n> > runs at\n> > > port 9418\n> > > > > at\n> > > > > > the public repository machine. Is\n> it\n> > > correct?\n> > > > > > > \n> > > > > > > netstat | grep 9418\n> > > > > > \n> > > > > > netstat translates IP addresses to\n> dns\n> > > names, and\n> > > > > ports to\n> > > > > > service names by\n> > > > > > default; so, given the line listed\n> in\n> > > /etc/services,\n> > > > > this\n> > > > > > will show\n> > > > > > '0.0.0.0:git' or\n> something. \n> > Also,\n> > > it lists\n> > > > > > established connections, not\n> > > > > > listening sockets, by default. \n> I'd\n> > > recommend\n> > > > > spending\n> > > > > > some time with the man\n> > > > > > page if you're going to use it\n> to\n> > debug\n> > > your\n> > > > > setup.\n> > > > > > \n> > > > > > Deskin Miller\n> > > > > \n> > > > > \n> > > > >       \n> > > > > --\n> > > > > To unsubscribe from this list: send the\n> line\n> > > > > \"unsubscribe git\" in\n> > > > > the body of a message to\n> > > majordomo@vger.kernel.org\n> > > > > More majordomo info at \n> > > > >\n> http://vger.kernel.org/majordomo-info.html\n> > > > \n> > > > \n> > > >       \n> > > > --\n> > > > To unsubscribe from this list: send the line\n> > > \"unsubscribe git\" in\n> > > > the body of a message to\n> > majordomo@vger.kernel.org\n> > > > More majordomo info at \n> > > http://vger.kernel.org/majordomo-info.html\n> > > \n> > > --\n> > > To unsubscribe from this list: send the line\n> > > \"unsubscribe git\" in\n> > > the body of a message to\n> majordomo@vger.kernel.org\n> > > More majordomo info at \n> > > http://vger.kernel.org/majordomo-info.html\n> \n> \n>       \n> --\n> To unsubscribe from this list: send the line\n> \"unsubscribe git\" in\n> the body of a message to majordomo@vger.kernel.org\n> More majordomo info at \n> http://vger.kernel.org/majordomo-info.html\n\n\n      \n"},{"id":"96309","messageId":"1227252144.4879.90.camel@marge.simson.net","threadId":"16416","inReplyTo":"546971.60895.qm@web37907.mail.mud.yahoo.com","subject":"Re: Challenge of setting up git server (repository). Please help!","fromName":"Mike Galbraith","fromEmail":"efault@gmx.de","sentAt":"2008-11-21T07:22:24Z","receivedAt":"2008-11-21T07:22:24Z","isPatch":false,"sender":{"key":"efault@gmx.de","avatar":null},"body":"On Thu, 2008-11-20 at 16:39 -0800, Gary Yang wrote:\n> I killed xinetd. Restarted with sudo xinetd -stayalive -pidfile /var/run/xinetd.pid. \n> \n> I back to my private box. I did \n> \n> git pull git://git.mycompany.com/pub/git/u-boot.git HEAD\n> \n> This command hangs for over half hour and is still hanging. Again, below is the content of /etc/xinetd.d/git-daemon. What I did wrong?\n> \n> cat /etc/xinetd.d/git-daemon\n> # default: off\n> # description: The git server offers access to git repositories\n> service git\n> {\n>         disable = no\n>         type            = UNLISTED\n>         port            = 9418\n>         socket_type     = stream\n>         wait            = no\n>         user            = nobody\n>         server          = /usr/local/libexec/git-core/git-daemon\n>         server_args     = git-daemon --inetd --export-all --base-path=/pub/git\n>         log_on_failure  += USERID\n> }\n\nThe way I set it up was to create a user 'git' who is my central\nrepository owner/manager.  All repositories live in ~git.\n\nservice git\n{\n        socket_type     = stream\n        protocol        = tcp\n        wait            = no\n        user            = git\n        group           = daemon\n        server          = /usr/bin/git\n        server_args     = daemon --inetd --export-all --user-path --reuseaddr --detach\n        type            = UNLISTED\n        port            = 9418\n        log_on_failure  += USERID\n}\n\nmarge:..kernel/linux-2.6.28 # git remote -v\nmaster  git://localhost/~git/linux-2.6\n\n>From host homer, with a hole poked in marge's firewall, works fine.\n\n\t-Mike\n"}]}