{"thread":{"id":"15824","subject":"Feature Request: Branch Annotations","startedAt":"2008-10-08T10:49:12Z","lastAt":"2008-10-10T08:24:08Z","messageCount":10,"participants":["Rotem Yaari","Thomas Adam","Baz","Marc Weber","David Soria Parra","Junio C Hamano","Avery Pennarun","Miklos Vajna","Peter Krefting"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"92613","messageId":"d2115f4f0810080349o30b6bc2labc2745b8d981e0d@mail.gmail.com","threadId":"15824","inReplyTo":"d2115f4f0810080348t62e18b14x1dfe798974332b05@mail.gmail.com","subject":"Feature Request: Branch Annotations","fromName":"Rotem Yaari","fromEmail":"vmalloc@gmail.com","sentAt":"2008-10-08T10:49:12Z","receivedAt":"2008-10-08T10:49:12Z","isPatch":false,"sender":{"key":"vmalloc@gmail.com","avatar":null},"body":"Hi,\n\nI usually work with many branches in git, each of which represents a\ndifferent state of development/stability, but also development tasks\nassigned to me.\nSometimes, besides the name of the branch, it could be useful to have\na short description of a branch which quickly reminds me what that\nbranch is intended for.\n\nCurrently I see no way in git to achieve this (there's a description\nfor a repository, but not for individual branches).\n\nAny opinions on this?\n\n\nThanks in advance,\n\n--\nRotem\n"},{"id":"92614","messageId":"18071eea0810080355g743c7bbfq9d7d39c9a76eb59d@mail.gmail.com","threadId":"15824","inReplyTo":"d2115f4f0810080349o30b6bc2labc2745b8d981e0d@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"Thomas Adam","fromEmail":"thomas.adam22@gmail.com","sentAt":"2008-10-08T10:55:37Z","receivedAt":"2008-10-08T10:55:37Z","isPatch":false,"sender":{"key":"thomas.adam22@gmail.com","avatar":"https://gravatar.com/avatar/137f9858bc6bfd5b2f743aefd988c81ce0cbd306248889df80e269519cfc8741?d=mp&s=160"},"body":"2008/10/8 Rotem Yaari <vmalloc@gmail.com>:\n> Hi,\n>\n> I usually work with many branches in git, each of which represents a\n> different state of development/stability, but also development tasks\n> assigned to me.\n> Sometimes, besides the name of the branch, it could be useful to have\n> a short description of a branch which quickly reminds me what that\n> branch is intended for.\n>\n> Currently I see no way in git to achieve this (there's a description\n> for a repository, but not for individual branches).\n>\n> Any opinions on this?\n\nWasn't this discussed here before, with a prototype?  ISTR it was, but\ndropped due to lack of interest?  Have a look through the archives.\n\n-- Thomas Adam\n"},{"id":"92615","messageId":"2faad3050810080441sdb1b29bxe92c467c2dd9a908@mail.gmail.com","threadId":"15824","inReplyTo":"18071eea0810080355g743c7bbfq9d7d39c9a76eb59d@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"Baz","fromEmail":"brian.ewins@gmail.com","sentAt":"2008-10-08T11:41:43Z","receivedAt":"2008-10-08T11:41:43Z","isPatch":false,"sender":{"key":"brian.ewins@gmail.com","avatar":"https://gravatar.com/avatar/9ac03d89105e50a7151e695a1b4b1228151064ec3ac380a73b74ab397796baf7?d=mp&s=160"},"body":"2008/10/8 Thomas Adam <thomas.adam22@gmail.com>:\n> 2008/10/8 Rotem Yaari <vmalloc@gmail.com>:\n>> Hi,\n>>\n>> I usually work with many branches in git, each of which represents a\n>> different state of development/stability, but also development tasks\n>> assigned to me.\n>> Sometimes, besides the name of the branch, it could be useful to have\n>> a short description of a branch which quickly reminds me what that\n>> branch is intended for.\n>>\n>> Currently I see no way in git to achieve this (there's a description\n>> for a repository, but not for individual branches).\n>>\n>> Any opinions on this?\n>\n> Wasn't this discussed here before, with a prototype?  ISTR it was, but\n> dropped due to lack of interest?  Have a look through the archives.\n\nThe most recent thread was 'branch description' back in April, which\ndiscussed alternatives, but petered out:\nhttp://kerneltrap.org/mailarchive/git/2008/4/15/1442684/thread\n\nAn older thread on 'topic descriptions' where Junio described his use\nof the config file for this:\nhttp://kerneltrap.org/mailarchive/git/2006/12/6/232466/thread\n\nAnd there's a similar feature in stgit, which uses the same config\nsetting that Junio did:\nhttp://kerneltrap.org/mailarchive/git/2007/5/14/246358\nhttp://kerneltrap.org/mailarchive/git/2007/4/12/243404\n\n-Baz\n\n>\n> -- Thomas Adam\n> --\n> To unsubscribe from this list: send the line \"unsubscribe git\" in\n> the body of a message to majordomo@vger.kernel.org\n> More majordomo info at  http://vger.kernel.org/majordomo-info.html\n>\n"},{"id":"92616","messageId":"20081008120847.GD9428@gmx.de","threadId":"15824","inReplyTo":"2faad3050810080441sdb1b29bxe92c467c2dd9a908@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"Marc Weber","fromEmail":"marco-oweber@gmx.de","sentAt":"2008-10-08T12:08:47Z","receivedAt":"2008-10-08T12:08:47Z","isPatch":false,"sender":{"key":"marco-oweber@gmx.de","avatar":null},"body":"On Wed, Oct 08, 2008 at 12:41:43PM +0100, Baz wrote:\n> 2008/10/8 Thomas Adam <thomas.adam22@gmail.com>:\n> > 2008/10/8 Rotem Yaari <vmalloc@gmail.com>:\n> >> Hi,\n> >>\n> >> I usually work with many branches in git, each of which represents a\n> >> different state of development/stability, but also development tasks\n> >> assigned to me.\n> >> Sometimes, besides the name of the branch, it could be useful to have\n> >> a short description of a branch which quickly reminds me what that\n> >> branch is intended for.\n> >>\n> >> Currently I see no way in git to achieve this (there's a description\n> >> for a repository, but not for individual branches).\n> >>\n> >> Any opinions on this?\n[...]\nProbably I've missed something. but doesn't top git add some special\nfiles to remember branch relations?\nI guess it removes them before merging upstream ?\nI would have to reread the README or topGit source to confirm this.\n\nMarc Weber\n"},{"id":"92619","messageId":"48ECB5CB.4010703@gmx.net","threadId":"15824","inReplyTo":"d2115f4f0810080349o30b6bc2labc2745b8d981e0d@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"David Soria Parra","fromEmail":"sn_@gmx.net","sentAt":"2008-10-08T13:29:47Z","receivedAt":"2008-10-08T13:29:47Z","isPatch":false,"sender":{"key":"sn_@gmx.net","avatar":"https://gravatar.com/avatar/b1075ecdd33ea094cbc23798fe8b95c73ec1ccf7bb213ac8260c719e2dd97b55?d=mp&s=160"},"body":"\n> Any opinions on this?\n\nwould be great to have something like that build in git-core like\n\ngit branch -i 'Fix bla' ds/fix next\ngit branch -i\n  ds/fix (Fix Bla)\n\ndavid\n"},{"id":"92628","messageId":"7vwsgiptph.fsf@gitster.siamese.dyndns.org","threadId":"15824","inReplyTo":"48ECB5CB.4010703@gmx.net","subject":"Re: Feature Request: Branch Annotations","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-10-08T23:12:26Z","receivedAt":"2008-10-08T23:12:26Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"David Soria Parra <sn_@gmx.net> writes:\n\n>> Any opinions on this?\n>\n> would be great to have something like that build in git-core like\n>\n> git branch -i 'Fix bla' ds/fix next\n> git branch -i\n>  ds/fix (Fix Bla)\n\nHaven't people watched Linus on google tech talk?  Here is an excerpt from\nthe transcript (http://git.or.cz/gitwiki/LinusTalk200705Transcript):\n\n    ... well actually you shouldn't call it \"test\", you should basically\n    name your branches the way you name your functions, you should call\n    them something short and sweet and to the point -- What is that branch\n    doing.\n\nIOW, why did you name the branch \"ds/fix\" and not \"ds/fix-bla\"?\n"},{"id":"92629","messageId":"48ED404C.2000405@gmx.net","threadId":"15824","inReplyTo":"7vwsgiptph.fsf@gitster.siamese.dyndns.org","subject":"Re: Feature Request: Branch Annotations","fromName":"David Soria Parra","fromEmail":"sn_@gmx.net","sentAt":"2008-10-08T23:20:44Z","receivedAt":"2008-10-08T23:20:44Z","isPatch":false,"sender":{"key":"sn_@gmx.net","avatar":"https://gravatar.com/avatar/b1075ecdd33ea094cbc23798fe8b95c73ec1ccf7bb213ac8260c719e2dd97b55?d=mp&s=160"},"body":"\n> Haven't people watched Linus on google tech talk?  Here is an excerpt from\n> the transcript (http://git.or.cz/gitwiki/LinusTalk200705Transcript):\n> \n>     ... well actually you shouldn't call it \"test\", you should basically\n>     name your branches the way you name your functions, you should call\n>     them something short and sweet and to the point -- What is that branch\n>     doing.\n> \n> IOW, why did you name the branch \"ds/fix\" and not \"ds/fix-bla\"?\n\nOkay I just choosed a bad example. Actually I call it ds/fix-function, \nbut nevertheless more additional description can be useful when dealing \nwith a lot of branches. But yes, there might be porcelains that can do that.\n"},{"id":"92630","messageId":"32541b130810081621k32493e20occba9cd97671775d@mail.gmail.com","threadId":"15824","inReplyTo":"7vwsgiptph.fsf@gitster.siamese.dyndns.org","subject":"Re: Feature Request: Branch Annotations","fromName":"Avery Pennarun","fromEmail":"apenwarr@gmail.com","sentAt":"2008-10-08T23:21:33Z","receivedAt":"2008-10-08T23:21:33Z","isPatch":false,"sender":{"key":"apenwarr@gmail.com","avatar":"https://avatars.githubusercontent.com/u/20592?v=4"},"body":"On 10/8/08, Junio C Hamano <gitster@pobox.com> wrote:\n> David Soria Parra <sn_@gmx.net> writes:\n>\n>  >> Any opinions on this?\n>  >\n>  > would be great to have something like that build in git-core like\n>  >\n>  > git branch -i 'Fix bla' ds/fix next\n>  > git branch -i\n>  >  ds/fix (Fix Bla)\n>\n> Haven't people watched Linus on google tech talk?  Here is an excerpt from\n>  the transcript (http://git.or.cz/gitwiki/LinusTalk200705Transcript):\n>\n>     ... well actually you shouldn't call it \"test\", you should basically\n>     name your branches the way you name your functions, you should call\n>     them something short and sweet and to the point -- What is that branch\n>     doing.\n>\n>  IOW, why did you name the branch \"ds/fix\" and not \"ds/fix-bla\"?\n\nBecause it would be excessive typing every time you want to do\nsomething to that branch?\n\nI guess bash completions would help with this (if you're using bash),\nbut even then it's kind of unreasonable to name branches something\nlike \"bug-111234-widget-performance-improvements-for-customer-x\",\nwhich is the sort of information that would be awfully helpful two\nmonths later when you're looking at old unmerged branches.\n\nAvery\n"},{"id":"92635","messageId":"20081009002019.GQ536@genesis.frugalware.org","threadId":"15824","inReplyTo":"32541b130810081621k32493e20occba9cd97671775d@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"Miklos Vajna","fromEmail":"vmiklos@frugalware.org","sentAt":"2008-10-09T00:20:19Z","receivedAt":"2008-10-09T00:20:19Z","isPatch":false,"sender":{"key":"vmiklos@frugalware.org","avatar":"https://gravatar.com/avatar/401c1cbbb3a5d13e650c691a2c71d6fd0b80df1a01bc74d9f1972675dd58f2bd?d=mp&s=160"},"body":"On Wed, Oct 08, 2008 at 07:21:33PM -0400, Avery Pennarun <apenwarr@gmail.com> wrote:\n> I guess bash completions would help with this (if you're using bash),\n> but even then it's kind of unreasonable to name branches something\n> like \"bug-111234-widget-performance-improvements-for-customer-x\",\n\nI think you haven't read the links mentioned in the previous mail.\n\nIIRC the thread had a suggestion about creating such a 'desc' branch,\nthen you could just have a branch named 'fix' and you could do git show\ndesc:fix to see its description.\n\nJust use git as a filesystem, as it was originally designed... ;-)\n"},{"id":"92733","messageId":"Pine.LNX.4.64.0810100922180.10709@ds9.cixit.se","threadId":"15824","inReplyTo":"32541b130810081621k32493e20occba9cd97671775d@mail.gmail.com","subject":"Re: Feature Request: Branch Annotations","fromName":"Peter Krefting","fromEmail":"peter@softwolves.pp.se","sentAt":"2008-10-10T08:24:08Z","receivedAt":"2008-10-10T08:24:08Z","isPatch":false,"sender":{"key":"peter@softwolves.pp.se","avatar":"https://avatars.githubusercontent.com/u/990764?v=4"},"body":"Avery Pennarun:\n\n> I guess bash completions would help with this (if you're using bash),\n> but even then it's kind of unreasonable to name branches something\n> like \"bug-111234-widget-performance-improvements-for-customer-x\",\n> which is the sort of information that would be awfully helpful two\n> months later when you're looking at old unmerged branches.\n\nThat's exactly what I do for one of the projects I am working on (well,\nminus the \"bug-\" prefix, that's implied). Bash completion works quite\nwell for that, and the merge commits do give meaningful information.\n\nBut I would still like to be able to annotate it. Especially for\nlong-living bug-fix branches, it could be useful to be able to add\ndescribe a branch with what state it is in, for instance.\n\n-- \n\\\\// Peter - http://www.softwolves.pp.se/\n"}]}