{"thread":{"id":"15708","subject":"What's in git/spearce.git (Sep 2008, #04; Mon, 29)","startedAt":"2008-09-29T18:46:29Z","lastAt":"2008-09-29T18:46:29Z","messageCount":1,"participants":["Shawn O. Pearce"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"91872","messageId":"20080929184629.GA21310@spearce.org","threadId":"15708","inReplyTo":null,"subject":"What's in git/spearce.git (Sep 2008, #04; Mon, 29)","fromName":"Shawn O. Pearce","fromEmail":"spearce@spearce.org","sentAt":"2008-09-29T18:46:29Z","receivedAt":"2008-09-29T18:46:29Z","isPatch":false,"sender":{"key":"spearce@spearce.org","avatar":"https://avatars.githubusercontent.com/u/34844?v=4"},"body":"What's in git/spearce.git (Sep 2008, #04; Mon, 29)\n\n  maint edb7e82 (Merge branch 'bc/maint-diff-hunk-header-fix' into maint)\n master 9800c0d (Merge branch 'bc/master-diff-hunk-header-fix')\n------------------------------------------------------------------------\n\nWith Junio offline for another week we won't see a 1.6.0.3 until\nprobably mid-October.  With that in mind I've merged a number of\ntopics and trivial patches to maint so we can shake these out\nbefore the 1.6.0.3 release.\n\n* The 'maint' branch has these fixes since the last announcement.\n\nAlex Riesen (3):\n  Remove empty directories in recursive merge\n  Add remove_path: a function to remove as much as possible of a path\n  Use remove_path from dir.c instead of own implementation\n\nBrandon Casey (5):\n  diff.c: return pattern entry pointer rather than just the hunk header\n    pattern\n  diff.c: associate a flag with each pattern and use it for compiling regex\n  diff.*.xfuncname which uses \"extended\" regex's for hunk header selection\n  t4018-diff-funcname: test syntax of builtin xfuncname patterns\n  git-stash.sh: don't default to refs/stash if invalid ref supplied\n\nChris Frey (1):\n  Documentation: clarify the details of overriding LESS via core.pager\n\nDeskin Miller (1):\n  maint: check return of split_cmdline to avoid bad config strings\n\nJohan Herland (2):\n  for-each-ref: Fix --format=%(subject) for log message without newlines\n  Use strchrnul() instead of strchr() plus manual workaround\n\nJonas Fonseca (1):\n  checkout: Do not show local changes when in quiet mode\n\nJunio C Hamano (2):\n  diff: use extended regexp to find hunk headers\n  diff hunk pattern: fix misconverted \"\\{\" tex macro introducers\n\nMichael J Gruber (1):\n  make \"git remote\" report multiple URLs\n\nPing Yin (1):\n  git-submodule: Fix \"Unable to checkout\" for the initial 'update'\n\nRafael Garcia-Suarez (1):\n  Clarify commit error message for unmerged files\n\nShawn O. Pearce (1):\n  Update release notes for 1.6.0.3\n\nStephen Haberman (1):\n  Clarify how the user can satisfy stash's 'dirty state' check.\n\n\n* The 'master' branch has these since the last announcement\n  in addition to the above.\n\nAlex Riesen (1):\n  Cleanup remove_path\n\nAlexander Gavrilov (9):\n  git-gui: Fix Blame Parent & Context for working copy lines.\n  git-gui: Restore ability to Stage Working Copy for conflicts.\n  git-gui: Add more integration options to citool.\n  git-gui: Cleanup handling of the default encoding.\n  git-gui: Add a menu of available encodings.\n  git-gui: Allow forcing display encoding for diffs using a submenu.\n  git-gui: Optimize encoding name resolution using a lookup table.\n  git-gui: Support the encoding menu in gui blame.\n  git-gui: Reenable staging unmerged files by clicking the icon.\n\nAnders Melchiorsen (2):\n  wt-status: Split header generation into three functions\n  wt-status: Teach how to discard changes in the working directory\n\nBrandon Casey (1):\n  t4018-diff-funcname: test syntax of builtin xfuncname patterns\n\nChristian Stimming (2):\n  git-gui: I18n fix sentence parts into full sentences for translation\n    again.\n  git-gui: Updated German translation.\n\nDmitry Potapov (1):\n  mingw: remove use of _getdrive() from lstat/fstat\n\nGarry Dolley (1):\n  Fixed some grammatical errors in git-rebase.txt documentation.\n\nGiuseppe Bilotta (1):\n  gitweb: shortlog now also obeys $hash_parent\n\nHeikki Orsila (1):\n  diff --dirstat-by-file: count changed files, not lines\n\nJohan Herland (2):\n  Fix AsciiDoc errors in merge documentation\n  Fix submodule sync with relative submodule URLs\n\nJohannes Sixt (1):\n  compat/mingw: Support a timeout in the poll emulation if no fds are given\n\nJoshua Williams (1):\n  git-gui: Add support for calling out to the prepare-commit-msg hook\n\nJunio C Hamano (21):\n  checkout -f: allow ignoring unmerged paths when checking out of the index\n  checkout --ours/--theirs: allow checking out one side of a conflicting\n    merge\n  xdl_fill_merge_buffer(): separate out a too deeply nested function\n  xdiff-merge: optionally show conflicts in \"diff3 -m\" style\n  xmerge.c: minimum readability fixups\n  xmerge.c: \"diff3 -m\" style clips merge reduction level to EAGER or less\n  rerere.c: use symbolic constants to keep track of parsing states\n  rerere: understand \"diff3 -m\" style conflicts with the original\n  merge.conflictstyle: choose between \"merge\" and \"diff3 -m\" styles\n  git-merge-recursive: learn to honor merge.conflictstyle\n  checkout -m: recreate merge when checking out of unmerged index\n  checkout --conflict=<style>: recreate merge in a non-default style\n  git-merge documentation: describe how conflict is presented\n  safe_create_leading_directories(): make it about \"leading\" directories\n  git-apply:--include=pathspec\n  is_directory(): a generic helper function\n  receive-pack: make it a builtin\n  push: prepare sender to receive extended ref information from the\n    receiver\n  push: receiver end advertises refs from alternate repositories\n  diff: use extended regexp to find hunk headers\n  diff: fix \"multiple regexp\" semantics to find hunk header comment\n\nMiklos Vajna (13):\n  Split out merge_recursive() to merge-recursive.c\n  merge-recursive: introduce merge_options\n  builtin-merge: avoid run_command_v_opt() for recursive and subtree\n  cherry-pick/revert: make direct internal call to merge_tree()\n  merge-recursive: move call_depth to struct merge_options\n  merge-recursive: get rid of the index_only global variable\n  merge-recursive: move the global obuf to struct merge_options\n  merge-recursive: move current_{file,directory}_set to struct\n    merge_options\n  merge-recursive: get rid of virtual_id\n  builtin-merge: release the lockfile in try_merge_strategy()\n  commit_tree(): add a new author parameter\n  builtin-commit: use commit_tree()\n  t7603: add new testcases to ensure builtin-commit uses reduce_heads()\n\nNanako Shiraishi (4):\n  remote.c: make free_ref(), parse_push_refspec() and free_refspecs()\n    static.\n  graph.c: make many functions static\n  usage.c: remove unused functions\n  Add contrib/rerere-train script\n\nPetr Baudis (1):\n  git-web--browse: Support for using /bin/start on MinGW\n\nPieter de Bie (1):\n  git wrapper: also use aliases to correct mistyped commands\n\nShawn O. Pearce (3):\n  git-gui: Hide commit related UI during citool --nocommit\n  git-gui: Use gitattribute \"encoding\" for file content display\n  git-gui: Assume `blame --incremental` output is in UTF-8\n\nStephan Beyer (1):\n  merge-recursive.c: Add more generic merge_recursive_generic()\n\n\n\n-- \nShawn.\n"}]}