{"thread":{"id":"14687","subject":"What's in git.git (Jul 2008, issue #08; Sat, 26)","startedAt":"2008-07-26T07:36:24Z","lastAt":"2008-07-26T07:36:24Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"85027","messageId":"7vprp1jdvr.fsf@gitster.siamese.dyndns.org","threadId":"14687","inReplyTo":null,"subject":"What's in git.git (Jul 2008, issue #08; Sat, 26)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-07-26T07:36:24Z","receivedAt":"2008-07-26T07:36:24Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"There are quite a bunch of changes to 'master' but they are mostly fix-ups\nto the new codepaths introduced recently; iow, exactly the kind of patches\nwe would want to see before and during the -rc period.\n\n* The 'maint' branch has these fixes since the last announcement.\n\nBjörn Steinbrink (1):\n  index-pack.c: correctly initialize appended objects\n\nJunio C Hamano (2):\n  tests: propagate $(TAR) down from the toplevel Makefile\n  Makefile: fix shell quoting\n\nPeter Valdemar Mørch (1):\n  send-email: find body-encoding correctly\n\nPierre Habouzit (1):\n  git-checkout: fix command line parsing.\n\n\n* The 'master' branch has these since the last announcement\n  in addition to the above.\n\nAlex Riesen (1):\n  Allow pager of diff command be enabled/disabled\n\nBrad King (1):\n  git-svn: teach dcommit about svn auto-props\n\nBrandon Casey (7):\n  t/: Replace diff [-u|-U0] with test_cmp to allow compilation with old\n    diff\n  t4116-apply-reverse.sh: use $TAR rather than tar\n  t3200,t7201: replace '!' with test_must_fail\n  t7502-commit.sh: rearrange test to make more portable\n  t/t4202-log.sh: add newline at end of file\n  Teach fsck and prune about the new location of temporary objects\n  perl/Makefile: update NO_PERL_MAKEMAKER section\n\nDaniel Barkalow (1):\n  In perforce, RCS keywords are case-sensitive\n\nJohannes Schindelin (8):\n  Rename .git/rebase to .git/rebase-apply\n  Rename path_list to string_list\n  Fix two leftovers from path_list->string_list\n  Ignore dirty submodule states in \"git pull --rebase\"\n  Add test to show that show-branch misses out the 8th column\n  sort_in_topological_order(): avoid setting a commit flag\n  builtin-commit: Two trivial style-cleanups\n  git daemon: avoid waking up too often\n\nJohannes Sixt (10):\n  rebase -i: When an 'edit' stops, mention the commit\n  Makefile: Do not install a copy of 'git' in $(gitexecdir)\n  Makefile: Normalize $(bindir) and $(gitexecdir) before comparing\n  Record the command invocation path early\n  Fix relative built-in paths to be relative to the command invocation\n  Allow the built-in exec path to be relative to the command invocation\n    path\n  Allow add_path() to add non-existent directories to the path\n  Windows: Make $(gitexecdir) relative\n  Windows: Make sure argv[0] has a path\n  Windows: Do not compile git-shell\n\nJonathan Nieder (2):\n  git-diff(1): \"--c\" -> \"--cc\" typo fix\n  document that git-tag can tag more than heads\n\nJunio C Hamano (9):\n  Update my e-mail address\n  Revert \"make git-status use a pager\"\n  tests: do not rely on external \"patch\"\n  stash save: fix parameter handling\n  builtin-branch.c: remove unused code in append_ref() callback function\n  builtin-branch.c: optimize --merged and --no-merged\n  Documentation: clarify diff --cc\n  ignore non-existent refs in dwim_log()\n  Documentation: clarify how to disable elements in core.whitespace\n\nLee Marlow (1):\n  bash completion: Add long options for 'git rm'\n\nMiklos Vajna (2):\n  builtin-merge: give a proper error message for invalid strategies in\n    config\n  t7601: extend the 'merge picks up the best result' test\n\nNikolaj Schumacher (1):\n  Don't cut off last character of commit descriptions.\n\nOlivier Marin (4):\n  git-am: remove dash from help message\n  parse-options: fix segmentation fault when a required value is missing\n  git am --skip: clean the index while preserving local changes\n  update test case to protect am --skip behaviour\n\nP. Christeas (1):\n  svnimport: newer libsvn wants us to ask for the root with \"\", not \"/\"\n\nPetr Baudis (2):\n  git-filter-branch.sh: Allow running in bare repositories\n  Documentation/git-filter-branch: teach \"rm\" instead of \"update-index\n    --remove\"\n\nPhilippe Bruhat (1):\n  mailinfo: better parse email adresses containg parentheses\n\nPierre Habouzit (3):\n  builtin-merge: add missing structure initialization\n  git-submodule: move ill placed shift.\n  git-checkout: improve error messages, detect ambiguities.\n\nRené Scharfe (5):\n  archive: add write_archive()\n  archive: move parameter parsing code to archive.c\n  archive: define MAX_ARGS where it's needed\n  archive: declare struct archiver where it's needed\n  archive: allow --exec and --remote without equal sign\n\nSZEDER Gábor (2):\n  checkout: mention '--' in the docs\n  bash: offer only paths after '--' for 'git checkout'\n\nStephan Beyer (7):\n  git-am: Add colon before the subject that is printed out as being applied\n  am --abort: Add to bash-completion and mention in git-rerere\n    documentation\n  Make non-static functions, that may be static, static\n  Move launch_editor() from builtin-tag.c to editor.c\n  editor.c: Libify launch_editor()\n  git-am: Mention --abort in usage string part of OPTIONS_SPEC\n  git-reset: Let -q hush \"locally modified\" messages\n\nSteve Haslam (2):\n  Propagate -u/--upload-pack option of \"git clone\" to transport.\n  Remove references to git-fetch-pack from \"git clone\" documentation.\n\nThomas Rast (1):\n  git-completion.bash: provide completion for 'show-branch'\n"}]}