{"thread":{"id":"13897","subject":"[PATCH] git-rebase -i: improve help readability","startedAt":"2008-06-11T15:01:29Z","lastAt":"2008-06-11T22:51:07Z","messageCount":5,"participants":["Pierre Habouzit","Olivier Marin","Stephan Beyer"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"79457","messageId":"1213196490-7762-1-git-send-email-madcoder@debian.org","threadId":"13897","inReplyTo":null,"subject":"[PATCH] git-rebase -i: have an option for amending the commit message only.","fromName":"Pierre Habouzit","fromEmail":"madcoder@debian.org","sentAt":"2008-06-11T15:01:29Z","receivedAt":"2008-06-11T15:01:29Z","isPatch":true,"sender":{"key":"madcoder@debian.org","avatar":"https://avatars.githubusercontent.com/u/44708?v=4"},"body":"Signed-off-by: Pierre Habouzit <madcoder@debian.org>\n---\n git-rebase--interactive.sh |   10 ++++++++++\n 1 files changed, 10 insertions(+), 0 deletions(-)\n\ndiff --git a/git-rebase--interactive.sh b/git-rebase--interactive.sh\nindex 3f926d8..c1b4260 100755\n--- a/git-rebase--interactive.sh\n+++ b/git-rebase--interactive.sh\n@@ -215,6 +215,15 @@ do_next () {\n \t\tpick_one $sha1 ||\n \t\t\tdie_with_patch $sha1 \"Could not apply $sha1... $rest\"\n \t\t;;\n+\tcomment|c)\n+\t\tcomment_for_reflog comment\n+\n+\t\tmark_action_done\n+\t\tpick_one $sha1 ||\n+\t\t\tdie_with_patch $sha1 \"Could not apply $sha1... $rest\"\n+\t\toutput git commit --no-verify --amend -e -C HEAD\n+\t\t;;\n+\n \tedit|e)\n \t\tcomment_for_reflog edit\n \n@@ -688,6 +697,7 @@ do\n # Commands:\n #  p, pick = use commit\n #  e, edit = use commit, but stop for amending\n+#  c, comment = use commit, but stop for changing the commit message\n #  s, squash = use commit, but meld into previous commit\n #  mark :mark = mark the current HEAD for later reference\n #  reset commit = reset HEAD to the commit\n-- \n1.5.6.rc2.128.g6656e\n"},{"id":"79456","messageId":"1213196490-7762-2-git-send-email-madcoder@debian.org","threadId":"13897","inReplyTo":"1213196490-7762-1-git-send-email-madcoder@debian.org","subject":"[PATCH] git-rebase -i: improve help readability","fromName":"Pierre Habouzit","fromEmail":"madcoder@debian.org","sentAt":"2008-06-11T15:01:30Z","receivedAt":"2008-06-11T15:01:30Z","isPatch":true,"sender":{"key":"madcoder@debian.org","avatar":"https://avatars.githubusercontent.com/u/44708?v=4"},"body":"Signed-off-by: Pierre Habouzit <madcoder@debian.org>\n---\n git-rebase--interactive.sh |   19 ++++++++++---------\n 1 files changed, 10 insertions(+), 9 deletions(-)\n\ndiff --git a/git-rebase--interactive.sh b/git-rebase--interactive.sh\nindex c1b4260..a3c5488 100755\n--- a/git-rebase--interactive.sh\n+++ b/git-rebase--interactive.sh\n@@ -695,15 +695,16 @@ do\n # to a commit previously marked with the 'mark' insn.\n #\n # Commands:\n-#  p, pick = use commit\n-#  e, edit = use commit, but stop for amending\n-#  c, comment = use commit, but stop for changing the commit message\n-#  s, squash = use commit, but meld into previous commit\n-#  mark :mark = mark the current HEAD for later reference\n-#  reset commit = reset HEAD to the commit\n-#  merge commit-M commit-P ... = redo merge commit-M with the\n-#         current HEAD and the parents commit-P\n-#  tag = reset tag to the current HEAD\n+#  p, pick         use commit\n+#  e, edit         use commit, but stop for amending\n+#  c, comment      use commit, but update the commit message on the way\n+#  s, squash       use commit, but meld into previous commit\n+#  mark :mark      mark the current HEAD for later reference\n+#  reset commit    reset HEAD to the commit\n+#  merge commit-M commit-P\n+#                  redo merge commit-M with the current HEAD\n+#                  and the parents commit-P\n+#  tag             reset tag to the current HEAD\n #\n # If you remove a line here THAT COMMIT WILL BE LOST.\n # However, if you remove everything, the rebase will be aborted.\n-- \n1.5.6.rc2.128.g6656e\n"},{"id":"79475","messageId":"48501B3D.3000405@free.fr","threadId":"13897","inReplyTo":"1213196490-7762-1-git-send-email-madcoder@debian.org","subject":"Re: [PATCH] git-rebase -i: have an option for amending the commit message only.","fromName":"Olivier Marin","fromEmail":"dkr+ml.git@free.fr","sentAt":"2008-06-11T18:36:45Z","receivedAt":"2008-06-11T18:36:45Z","isPatch":true,"sender":{"key":"dkr+ml.git@free.fr","avatar":null},"body":"Hi,\n\nI like the feature and I have just two comments:\n\nPierre Habouzit a écrit :\n>\n> +\tcomment|c)\n\nIs \"comment\" the right name? I'm not sure, I just ask.\n\n> +\t\tcomment_for_reflog comment\n> +\n> +\t\tmark_action_done\n> +\t\tpick_one $sha1 ||\n> +\t\t\tdie_with_patch $sha1 \"Could not apply $sha1... $rest\"\n> +\t\toutput git commit --no-verify --amend -e -C HEAD\n\nIt does not work with an editor that opens in the current terminal\nlike vi. Just remove \"output\" should fix the problem, I think.\n\nOlivier.\n"},{"id":"79515","messageId":"20080611222744.GD16439@artemis.madism.org","threadId":"13897","inReplyTo":"48501B3D.3000405@free.fr","subject":"Re: [PATCH] git-rebase -i: have an option for amending the commit message only.","fromName":"Pierre Habouzit","fromEmail":"madcoder@debian.org","sentAt":"2008-06-11T22:27:44Z","receivedAt":"2008-06-11T22:27:44Z","isPatch":true,"sender":{"key":"madcoder@debian.org","avatar":"https://avatars.githubusercontent.com/u/44708?v=4"},"body":"On Wed, Jun 11, 2008 at 06:36:45PM +0000, Olivier Marin wrote:\n> Hi,\n> \n> I like the feature and I have just two comments:\n> \n> Pierre Habouzit a écrit :\n> >\n> > +\tcomment|c)\n> \n> Is \"comment\" the right name? I'm not sure, I just ask.\n\n  Well, edit would have been better, but it's taken already. 'message'\nhas m as a shortcut, already taken by merge, so 'comment' felt like the\nbest I could come up with.\n\n  To be fair, if someone has a better name, I'm all for it. I quite care\nabout the feature, edit needs me to run the --amend myself, whereas I\noften just want to fix a typo in a commit log.\n\n> > +\t\tcomment_for_reflog comment\n> > +\n> > +\t\tmark_action_done\n> > +\t\tpick_one $sha1 ||\n> > +\t\t\tdie_with_patch $sha1 \"Could not apply $sha1... $rest\"\n> > +\t\toutput git commit --no-verify --amend -e -C HEAD\n> \n> It does not work with an editor that opens in the current terminal\n> like vi. Just remove \"output\" should fix the problem, I think.\n\n  I'm surprised because I used it this way, but maybe it was on the\nmachine where my git editor is gvim and not vim …\n\n-- \n·O·  Pierre Habouzit\n··O                                                madcoder@debian.org\nOOO                                                http://www.madism.org\n"},{"id":"79517","messageId":"20080611225107.GB7200@leksak.fem-net","threadId":"13897","inReplyTo":"20080611222744.GD16439@artemis.madism.org","subject":"Re: [PATCH] git-rebase -i: have an option for amending the commit message only.","fromName":"Stephan Beyer","fromEmail":"s-beyer@gmx.net","sentAt":"2008-06-11T22:51:07Z","receivedAt":"2008-06-11T22:51:07Z","isPatch":true,"sender":{"key":"s-beyer@gmx.net","avatar":"https://avatars.githubusercontent.com/u/143889?v=4"},"body":"Hi,\n\nI want to add a quick note as the one who is currently responsible for\nfuture git-sequencer ;-)\n\n> > > +\t\tcomment_for_reflog comment\n> > > +\n> > > +\t\tmark_action_done\n> > > +\t\tpick_one $sha1 ||\n> > > +\t\t\tdie_with_patch $sha1 \"Could not apply $sha1... $rest\"\n> > > +\t\toutput git commit --no-verify --amend -e -C HEAD\n\nI dislike that \"comment\" does a pick.\nWell, your version is consistent with the rest of rebase-i, but \ninconsistent to the more atomic and general approach of the\ngit-sequencer thread.\n\nYou use\n\tcomment deadf00\ninstead of\n\tpick deadf00\nWould you mind if you had to use something like this:\n\tpick deadf00\n\tcomment\nto reedit the message of deadf00?\n\nThe difference for you as vim user is that you won't type \"<Home> c w comment\",\nbut \"o comment\" :-)\nThe outcome is that you can also use it for patches, not only for\ncherry-picks ;)\n\n>   To be fair, if someone has a better name, I'm all for it.\n\nWhat about \"amend\"? :)\n...or \"amend-message\" or something like this.\n\n> I quite care about the feature, edit needs me to run the --amend myself,\n> whereas I often just want to fix a typo in a commit log.\n\nI understand ;)\n\nWell, I like to add it to the sequencer spec and to the prototype as soon \nas the name is clear ;-)\n\nRegards,\n  Stephan\n\n-- \nStephan Beyer <s-beyer@gmx.net>, PGP 0x6EDDD207FCC5040F\n"}]}