{"thread":{"id":"13439","subject":"[PATCH] doc: clarify definition of \"update\" for git-add -u","startedAt":"2008-05-08T17:25:06Z","lastAt":"2008-05-11T08:07:25Z","messageCount":3,"participants":["Jeff King","Junio C Hamano"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"76386","messageId":"20080508172506.GA29802@sigill.intra.peff.net","threadId":"13439","inReplyTo":null,"subject":"[PATCH] doc: clarify definition of \"update\" for git-add -u","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2008-05-08T17:25:06Z","receivedAt":"2008-05-08T17:25:06Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"The \"-u\" option is described only in terms of \"updating\"\nfiles, which in turn is described only as \"similar to what\ngit commit -a does\". Let's be a little more specific about\nwhat updating entails.\n\nSuggested by Geoffrey Irving.\n\nSigned-off-by: Jeff King <peff@peff.net>\n---\nThe wrapping is funny to make the text diff easier to read. Junio, do\nyou prefer it that way, or in the canonical form?\n\n Documentation/git-add.txt |    4 +++-\n 1 files changed, 3 insertions(+), 1 deletions(-)\n\ndiff --git a/Documentation/git-add.txt b/Documentation/git-add.txt\nindex 35e67a0..e2389e3 100644\n--- a/Documentation/git-add.txt\n+++ b/Documentation/git-add.txt\n@@ -71,7 +71,9 @@ OPTIONS\n \tthe specified filepatterns before exiting.\n \n -u::\n-\tUpdate only files that git already knows about. This is similar\n+\tUpdate only files that git already knows about, staging modified\n+\tcontent for commit and marking deleted files for removal. This\n+\tis similar\n \tto what \"git commit -a\" does in preparation for making a commit,\n \texcept that the update is limited to paths specified on the\n \tcommand line. If no paths are specified, all tracked files in the\n-- \n1.5.5.1.274.g7b68b\n"},{"id":"76569","messageId":"7vfxsp8t3z.fsf@gitster.siamese.dyndns.org","threadId":"13439","inReplyTo":"20080508172506.GA29802@sigill.intra.peff.net","subject":"Re: [PATCH] doc: clarify definition of \"update\" for git-add -u","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2008-05-11T02:36:16Z","receivedAt":"2008-05-11T02:36:16Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Jeff King <peff@peff.net> writes:\n\n> The wrapping is funny to make the text diff easier to read. Junio, do\n> you prefer it that way, or in the canonical form?\n\nThanks, will apply.\n"},{"id":"76591","messageId":"20080511080724.GB6971@sigill.intra.peff.net","threadId":"13439","inReplyTo":"7vfxsp8t3z.fsf@gitster.siamese.dyndns.org","subject":"Re: [PATCH] doc: clarify definition of \"update\" for git-add -u","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2008-05-11T08:07:25Z","receivedAt":"2008-05-11T08:07:25Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Sat, May 10, 2008 at 07:36:16PM -0700, Junio C Hamano wrote:\n\n> > The wrapping is funny to make the text diff easier to read. Junio, do\n> > you prefer it that way, or in the canonical form?\n> \n> Thanks, will apply.\n\nThanks. But you still didn't answer my question. ;P\n\n-Peff\n"}]}