{"thread":{"id":"12888","subject":"[PATCH 0/2] add--interactive: better mode change handling","startedAt":"2008-03-27T07:29:31Z","lastAt":"2008-03-27T08:34:00Z","messageCount":2,"participants":["Jeff King","Wincent Colaiuta"],"isPatch":true,"patchVersion":1,"patchTotal":2},"messages":[{"id":"73191","messageId":"20080327072931.GA22444@coredump.intra.peff.net","threadId":"12888","inReplyTo":null,"subject":"[PATCH 0/2] add--interactive: better mode change handling","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2008-03-27T07:29:31Z","receivedAt":"2008-03-27T07:29:31Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"This was spawned by a bug report from Jörg about \"git add -i\"'s handling\nof mode changes. I don't think it's actually a bug, but rather a feature\nrequest, and as such should happen post-1.5.5.\n\nThe two patches are:\n\n  [1/2] add--interactive: ignore mode change in 'p'atch command\n  [2/2] add--interactive: allow user to choose mode update\n\nActually, you might argue that 1/2 _is_ a bugfix, though not quite the\nsame one that was reported.  I don't actually like the behavior after\njust 1/2 is applied, but I split the changes to be more readable.\n\nThere may potentially be a \"[3/2] change the name of the 'p'atch\ncommand\" since it is now not just about the patch (actually, since git\npatches _do_ include mode changes, it maybe is appropriate). Wincent\nsuggested \"pick\" which I think is reasonable. I'm not planning on doing\nsuch a 3/2, but I'm sure some industrious soul can make arguments for or\nagainst changing the name. I will let them handle the ensuing bikeshed\njamboree.\n\n-Peff\n"},{"id":"73195","messageId":"C96B3392-9B17-4703-A4BC-250A70108924@wincent.com","threadId":"12888","inReplyTo":"20080327072931.GA22444@coredump.intra.peff.net","subject":"Re: [PATCH 0/2] add--interactive: better mode change handling","fromName":"Wincent Colaiuta","fromEmail":"win@wincent.com","sentAt":"2008-03-27T08:34:00Z","receivedAt":"2008-03-27T08:34:00Z","isPatch":true,"sender":{"key":"greg@hurrell.net","avatar":"https://avatars.githubusercontent.com/u/7074?v=4"},"body":"El 27/3/2008, a las 8:29, Jeff King escribió:\n\n> There may potentially be a \"[3/2] change the name of the 'p'atch\n> command\" since it is now not just about the patch (actually, since git\n> patches _do_ include mode changes, it maybe is appropriate). Wincent\n> suggested \"pick\" which I think is reasonable. I'm not planning on  \n> doing\n> such a 3/2, but I'm sure some industrious soul can make arguments  \n> for or\n> against changing the name. I will let them handle the ensuing bikeshed\n> jamboree.\n\nI don't really want to participate in such a jamboree either, but I  \nwill add this one last comment that I should have mentioned in my  \nprevious email: one thing to bear in mind when considering changing  \nthe subcommand name is that \"git add\" itself has a \"--patch\" option  \nsince a couple of releases ago, and that means that changing the  \nsubcommand name either means introducing a mismatch between the option  \nname and subcommand name, or going through a deprecate/rename cycle  \nfor the option name too, which we just introduced.\n\nI don't really care either way. My muscle memory is trained for  \n\"patch\" at this point, but changing wouldn't be a problem either.\n\nIn any case, your patches 1 and 2 look pretty sane to me.\n\nCheers,\nWincent\n"}]}